Jump to content

Recommended Posts

I've got the Huawei p8 with Android 6. the App doesn't show album arts, but the widget and the notification area do! I tried different options, but it's always the same

kind regards

Ingo

[Edit: Picture erased]

Screenshot_2017-01-15-13-01-31.png

Edited by Cartridge-Music
[Edit: Picture erased]
Link to post
Share on other sites

What do you see if you press Menu > Info/Tags, does it say that there is album art embedded within the file or not (near the bottom of the list normally)? And have you tried long-pressing on the empty artwork area to see if it shows anything as either present or downloadable?

I'm wondering if this is related to the issues that Huawei devices have with displaying skins on the regular release builds.

Andre

Link to post
Share on other sites

That's a thought. Swipe in the panel from the right and there's a link under the word Visualisation that can be set to Normal, Full-Screen or Disabled. Make sure it's disabled (or try going into viewing visualisations and then back out again)

Andre

Link to post
Share on other sites

If there are only a few not working now it could be related to the tagging in those files, or that those have received and stored incorrect images. Try long-pressing on the cover area (even if it's blank) and see if the correct artwork is listed in the choices.

Andre

Link to post
Share on other sites

Try clearing the cover art cache via Settings > Album Art > Delete Album Art Cache, disable Prefer In-Folder Images and Prefer Downloaded Album Art in the same menu, and do a Full Rescan (in Settings > Folders and Library) to start from scratch and see if that helps. Although uninstalling and re-installing should do pretty much that anyway.

Andre

Link to post
Share on other sites
On 16.1.2017 at 10:19 AM, Cartridge-Music said:

The Menu tells me that there's no embedded cover.

But the lock screen, the widget and the notification area show it.

In the Attachements you always see the same title!

 

Greatings Ingo!

 

So, all images aren't embedded. Not the displaed ones and not the not displayed ones.

Maybe, you can tell me, where the covers are stored...

I don't know, if you realized, that the covers dissapeared after upgrading. I don't know, if they will be displayed after downgrading... Shall I try?

Link to post
Share on other sites

Cover art images are stored in internal memory, /Android/data/_com.maxmpz.audioplayer/album_art (note the underscore). As app data, I would expect them to be erased when uninstalling the app.

Artwork files should not be removed by an app upgrade though (even going from the release build to an alpha-test). Reverting from alpha back to release involves an uninstall/reinstall though, so downloaded art could well be affected. 

Andre

Link to post
Share on other sites

Hello,

As Android media library relies on Album name to retrieve/store cover data in the database, please try to specify an Album name to the songs with a tag editor, as in the screenshots, the field looks empty (Unknown album).

Link to post
Share on other sites

Poweramp can use filenames too, and it does not use the Android media library system at all.

However the OP mentioned that even after selecting an image to download, it was not 'sticking' in Poweramp when the song was next played, which seemed very odd. (By the way, after selecting a new cover image PA may not display it immediately on returning to the Player screen, sometimes you need to move forward a track and back again to see the new cover)

Andre

Link to post
Share on other sites
21 hours ago, andrewilley said:

Cover art images are stored in internal memory, /Android/data/_com.maxmpz.audioplayer/album_art (note the underscore). As app data, I would expect them to be erased when uninstalling the app.

Artwork files should not be removed by an app upgrade though (even going from the release build to an alpha-test). Reverting from alpha back to release involves an uninstall/reinstall though, so downloaded art could well be affected. 

Andre

OK, I will not fallback to V2...

Link to post
Share on other sites
15 hours ago, andrewilley said:

Poweramp can use filenames too, and it does not use the Android media library system at all.

However the OP mentioned that even after selecting an image to download, it was not 'sticking' in Poweramp when the song was next played, which seemed very odd. (By the way, after selecting a new cover image PA may not display it immediately on returning to the Player screen, sometimes you need to move forward a track and back again to see the new cover)

Andre

Sorry, but this is not the fault. It's not helping to skip forth and back.

At weekend I will clear the cache and restart searching for the covers. I thank you all for helping me  so far.

So long! Ingo

Link to post
Share on other sites
On 18.1.2017 at 4:45 PM, andrewilley said:

The best solution is to have the album art embedded in the actual music files of course, but if you've got a lot to do that could take a while. I tend to do batches every so often.

Andre

Now I have cleared the cache. When I let pweramp show me fitting covers and choose one, it's the same old story: Most of the covers aren't shown. The clearing of the cache seems to be ineffecitve.

Can I embed covers with Poweramp?

Link to post
Share on other sites

No. embedding cover artwork needs to be done in a tag manager app. I use TagScanner on my PC which has some excellent batch features, but there are others around (including on Android devices directly). Poweramp does have some limited tag editing features, but only for adjusting basic text fields (so not artwork, ratings, play-counter, etc)

Andre

Link to post
Share on other sites
  • 9 months later...
7 hours ago, Mranonymous321 said:

Can somebody help me please.

I just got a Samsung Note 8. When the phone is in the lock screen, the album art is so small. I do not like that. 

Can you please tell me how to make the album art full screen? Like my previous phone had. 

There are some Lockscreen options in Settings > Lock Screen, try swapping between the PA lockscreen and the system one and see if the settings in there help.

Andre

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...