Jump to content
Poweramp
Mark PPG

Lost pebble track control?

Recommended Posts

Nothing sure if this has been posted before, but I lost the ability to skip a track via my pebble watch. The function still works for other players like Google music, so I assume it's not watch software related. 

Share this post


Link to post
Share on other sites

Yup, same here (Pebble Time). This has been going on since @maxmp started messing with Bluetooth control. Now I'm forced to use my custom Pebble watchapp, which I've not yet shared.

Share this post


Link to post
Share on other sites
7 hours ago, capSAR said:

I will test this out on my Time with Music Boss later today on version 703.

Tried on Music Boss, it works like a charm, however,  it's a shame that the stock built in music app doesn't work with Poweramp v.3 . Volume control still works, but track switching and pause/play does not respond. Plz fix 

Share this post


Link to post
Share on other sites

How did you get it to work on music boss? The controls still don't work even using that app for me at least. I even tried all different options in the music boss app such as alternative media signals and whatnot.

((((( Nm somehow my option for responding to Bluetooth buttons was turned off.))))))))

Share this post


Link to post
Share on other sites

This issue seems to be still present in the official release. Is there any way to work around it? 

Share this post


Link to post
Share on other sites

What output do you use in Poweramp (Hi-Res, OpenSL, Audiotrack)? Also, unfortunately, you don't provide any android/device info (please don't expect your issue to be reproducible on first random phone/android on my table:-).

Share this post


Link to post
Share on other sites
On 12/21/2018 at 3:26 PM, maxmp said:

What output do you use in Poweramp (Hi-Res, OpenSL, Audiotrack)? Also, unfortunately, you don't provide any android/device info (please don't expect your issue to be reproducible on first random phone/android on my table:-). 

Hello, music control does not work either. I have tried to change the audio output and the problem persists. I use a Sony Xperia X with Oreo next to my Pebble Classic.

Share this post


Link to post
Share on other sites
32 minutes ago, DavidD00 said:

Hello, music control does not work either. I have tried to change the audio output and the problem persists. I use a Sony Xperia X with Oreo next to my Pebble Classic.

BT Buttons enabled ?

012019162759.jpg

Share this post


Link to post
Share on other sites
4 minutes ago, blaubär said:

BT Buttons enabled ?

012019162759.jpg

Yes, I've tried activating and deactivating it and the problem persists.

Share this post


Link to post
Share on other sites
On 12/21/2018 at 4:26 PM, maxmp said:

What output do you use in Poweramp (Hi-Res, OpenSL, Audiotrack)? Also, unfortunately, you don't provide any android/device info (please don't expect your issue to be reproducible on first random phone/android on my table:-).

I use default OpenSL. I also tried to switch to Audiotrack - it doesn't make any difference, the problem persists. My phone is ZUK Z2, also tried on Xiaomi Mi5s and Pixel 2 - no difference.

With Poweramp v2.x it works like a charm: if player is killed, when I press play on my Pebble Steel it brings it on and music starts to play, play/pause and track switch also works perfectly.

With Poweramp v3.x it starts player if it is killed and music starts to play, but then neither play/pause nor track switch works. If player is alive or it's service is running in background - nothing works either.

Only volume control works fine for both versions (not sure if it is controlled by player or OS itself).

Of course BT controls are enabled in settings. Had to rollback to v2 because of this :(

If you need any help with further testing/debugging/logs/whatever - feel free to contact me via email or pm (English or Russian works for me).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...