Jump to content
Poweramp
Greywolf

Bluetooth not relaying track/album/artist info

Recommended Posts

I.  The Essentials

Poweramp version and build number:    2.0.10-build-588-play (Full Version)
Your device model:  Samsung S7 Edge (SM-G935P)
Your Android version:  6.0.1
Your Custom ROM name/version (if you're on custom ROM):  N/A

Tried catlog, but it cannot read any logs other than its own as it cannot become root, so this is all I have.

II.  The problem

The BT in my car does not seem to be receiving metadata.  Samsung's Music Player sends this info across fine, but Poweramp is, to me, far superior in terms of UI and sound (Samsung's EQ, for example, is subtractive, not additive).

This is a relatively new phone (a month or so), so I'm kind of reluctant to (try to) root the thing at the moment...

Summary:  Sounds fantastic, I'm very happy to have the album art back, but the lack of transfer is mystifying and irritating...

Share this post


Link to post
Share on other sites

Have you tried adjusting the Metachanged Intent settings at the bottom of the Headset/Bluetooth settings screen? 

Andre

Share this post


Link to post
Share on other sites

I have similar experiences with my watch. My audio book player sends data across but not Poweramp.

Share this post


Link to post
Share on other sites

It didn't seem to make a difference on the Metachanged Intent settings, regardless of which I picked.  The CyanogenMod MI settings don't apply to me (I think) because I'm not running CM.

I will try (again) and report back.  Current settings are:

Metachanged Intent: CHECKED
CyanogenMod Metachanged Intent: DISABLED
Send Album - Artist with Metachanged Title: UNCHECKED

Head unit shows

No Title / No Artist / No Album

Addendum:

This thread should probably move over into the v2 Bugs section (which I lamely couldn't find yesterday when I filed this)...

Edited by Greywolf
addendum

Share this post


Link to post
Share on other sites

Moved as requested. This isn't something I can test unfortunately, as my car head unit doesn't do anything but play music, it does not display music title info apart from internally played USB files.

Andre

Share this post


Link to post
Share on other sites

I have tried with/without cyanogenmod, with/without Metachanged Intent, with/without Send Album - Artist with Metachanged Title...no combination seems to work.

Android is slowly becoming a pain in the AAAAAAAAaaaaahhhhhhhhhhhhhhh*splutch!*

Share this post


Link to post
Share on other sites

I have this issue too and it metadata is sent when you use something like google play music but if you use a 3rd party music player over BT data isn't sent.

Share this post


Link to post
Share on other sites

 

I know the OP is using a stock ROM but Marshmallow (Android 6.x) does seem to have a load of BT issues. At least from the custom ROM side of things. Have you checked out forums for your phone (particularly xda) to see if there are any known issues?

Dave

 

Share this post


Link to post
Share on other sites

Same problem here. Brand new Samsung Galaxy S7 Edge with Marshmallow, and none of the 3rd party music apps transfer Bluetooth metadata to the Car head unit. I have a 2015 model so the bluetooth stack on the head unit is new. Besides, given that both the stock player as well as Google play music have no problems with transferring the metadata, I doesn't seem to be a head unit problem or a Marshmallow problem.

I have a Sony Xperia Z3, and it recently got updated to Marshmallow - I will try Poweramp on that phone and see if its successful and post back in a few hours. That should narrow down the issue to either how Poweramp is playing with Marshmallow or how Poweramp is playing with Samsung. In either case, in my opinion, something needs to be updated with Poweramp. I listen to most my music in my car and if I cant see whats on the screen I'd rather uninstall and get a refund. I started with Poweramp just last week and I like it - but this is a deal breaker for me. Hopefully it can be fixed soon.

**UPDATE**

Tried Poweramp with My Sony Xperia Z3 with Marshmallow 6.0.1 - and metadata works flawlessly. Im guessing this is limited to the Samsung (and perhaps some other phones). Maybe something to do with how they implement the bluetooth stack/protocols. Either way - its no wonder we (customers) get the run around. Samsung will blame the app, and the app developers will blame Samsung - and we never get a fix.

Edited by nightcrawl3r
*Update

Share this post


Link to post
Share on other sites

I have also been having this issue for the past weeks (maybe 6?).

I.  The Essentials

Poweramp version and build number:    2.0.10-build-588-play (Full Version)   I've used Poweramp for several years now.
Your device model:  LG G5 H83010a
Your Android version:  6.0.1
Your Custom ROM name/version (if you're on custom ROM):  Stock LG ROM

II.  The problem

The BT metadata in my cars used to work just fine. For the past weeks it has only shown "unknown" for the metadata from Poweramp. The issue is the same for my 2015 Lexus and my 2015 Kia. Metadata from other media sources (google play, youtube, podcast addict) sends metadata without issue.

I have attempted to tweak every setting in Poweramp, rebooting, re-pairing phone, reinstalling Poweramp.... no change. 

Share this post


Link to post
Share on other sites
On 6/10/2016 at 5:00 PM, AlexMetal said:

II.  The problem

Well its started since android 6.0.1 and i dont see devs fixing it soon or later , since its bugged in playstore version and the beta version. so disappointed 

Share this post


Link to post
Share on other sites

I'm sure these sort of relatively minor issues will be addressed in time, but at the moment most of the dev's time is going into getting v3 ready for release. Each new release does address some discovered bugs, but is mainly about getting the required base functionality working properly.

Once v3 is officially out, there will be a lot more time for tackling other less serious bugs and hopefully some long-standing feature requests too. But please keep reporting things so they don't get forgotten.

Andre

Share this post


Link to post
Share on other sites

Its been 4 months now - no fix in sight. When it didn't work, I asked Poweramp to give me a refund (I only listen to music in my car) and they pretty much ignored me. I  uninstalled the app a few months back, but i tried again this week. still not luck - even in the v3 alpha build.

Share this post


Link to post
Share on other sites

I did mention before that this is a relatively minor issue (sending metadata via BT is not even something mentioned in the specs list at all, as far as I know) and probably won't get a very high priority amongst everything else that Max is working on, however I'm sure he is aware of it. Most BT-related issues seem to be caused by changes made in the BT stack system within Android, which can break existing functionality, and Max has to prioritise where he spends his time. But if it's a general problem rather than just with specific head-units then I'm sure it will get fixed before v3 gets to final release stage.

In the meantime, if you feel non-display of track titles on a BT device is an actual deal-breaker (personally I never use it, but hey) then please could you email Poweramp.maxmpz@gmail.com and discuss the issue of possibly getting a refund. I can't guarantee what the response will be though.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...