Jump to content
Poweramp
maxmp

Requests for Hi-Res Support (please state which build you are using - 704, 709, etc or the newer 790+)

Recommended Posts

4 hours ago, Jeremy_Xus said:

mix2s ,709 is ok but 790 not

I would suggest that if 709 is OK, future releases should be OK too. The high-res output code in 709 is the latest version, and that code will be merged into the next user interface build.

Andre

Share this post


Link to post
Share on other sites
20 hours ago, maxmp said:

You should point your question to rom Authors. Usually, custom ROMs have no hi-res support, but I never tested exactly this device + ROM combination, I will do that as it seems like frequent combination.

Thanks for the quick response. I asked for help in the thread of the resurrection ROM for the S6 as well, that they could implement this feature or at least support in some way.

Share this post


Link to post
Share on other sites

So @maxmp I'm not sure if this is just me doing something wrong and if it is I apologise because I can't figure it out. But I can't seem to get my device to output anything other than 16 bit. 

Device is Pixel XL running the current May 2018 8.1 build

Poweramp I'm using is 709

I have the option for the HD output which I have selected but it never seems to change the output from the other option. Am I doing something wrong or is it not currently supported? I figured since the Google phones are about as AOSP/Vanilla Android as it gets they would be so maybe it's me? See attached screenshot for info. Thanks for your time in advance.

Shaun

rps20180525_121634.jpg

Share this post


Link to post
Share on other sites

1. Poweramp 709

2. Huawei P8 (GRA-UL00)

3. Android 6.0 EMUI 4.0

4. HiSilicon Kirin 930, платформа 3635, звук HI3630HI6402CAR

Edited by YuRock

Share this post


Link to post
Share on other sites
On 5/22/2018 at 7:17 PM, andrewilley said:

Presumably the main OS does not support high-res, but the extensions added by the audio effects package do. What is the audio_policy.conf file on your device with just the basic ROM?

Andre

here is my audio_policy.conf.

if this file not support, how should i do to add the support?

audio_policy.conf

Share this post


Link to post
Share on other sites

Axon 7, pretty please? AFAIK Poweramp has never been able to output to the AK4996 DAC at more than 48k. Neutron is able to output 192k/24 without too much trouble.

I guess it'd not be easy to output hi-res properly on this phone because ZTE has these weird quirks here and there, but if you need any file from the system i can definitely fetch it for you.

 

edit: on another note, i can't actually find audio_policy.conf under /etc... I have audio_effects.conf though. No idea why, maybe it's 8.0 related, or because i have V4A?

Share this post


Link to post
Share on other sites
13 hours ago, cath said:

here is my audio_policy.conf.

That looks like it suports high-res, I'll move this discussion over to the High Res Requests thread.

Andre

Share this post


Link to post
Share on other sites
9 hours ago, Ecksdee said:

Axon 7, pretty please? AFAIK Poweramp has never been able to output to the AK4996 DAC at more than 48k. Neutron is able to output 192k/24 without too much trouble.

I guess it'd not be easy to output hi-res properly on this phone because ZTE has these weird quirks here and there, but if you need any file from the system i can definitely fetch it for you.

 

edit: on another note, i can't actually find audio_policy.conf under /etc... I have audio_effects.conf though. No idea why, maybe it's 8.0 related, or because i have V4A?

check both /vendor/etc and /system/etc, maybe you will see one

Share this post


Link to post
Share on other sites
9 hours ago, Ecksdee said:

Axon 7, pretty please? AFAIK Poweramp has never been able to output to the AK4996 DAC at more than 48k. Neutron is able to output 192k/24 without too much trouble.

I guess it'd not be easy to output hi-res properly on this phone because ZTE has these weird quirks here and there, but if you need any file from the system i can definitely fetch it for you.

 

edit: on another note, i can't actually find audio_policy.conf under /etc... I have audio_effects.conf though. No idea why, maybe it's 8.0 related, or because i have V4A?

its name can be audio_policy_configuration.xml

Share this post


Link to post
Share on other sites
10 hours ago, Seve-s said:

its name can be audio_policy_configuration.xml

Actually, it was on /vendor/etc instead of just /etc... I don't know. @maxmp that'd probably be useful to have written somewhere in the OP, because I legit had no idea why I was missing the damn file ?

 

Here it is. No wonder it supports 192k

audio_policy.conf

Share this post


Link to post
Share on other sites
10 hours ago, Ecksdee said:

Actually, it was on /vendor/etc instead of just /etc... I don't know. @maxmp that'd probably be useful to have written somewhere in the OP, because I legit had no idea why I was missing the damn file ?

 

Thanks for the suggestion, alternative folders added to OP.

Andre

Share this post


Link to post
Share on other sites

Hi, Poweramp dev team, I reuqest for support High Resolution 32bit/384kHz for BPhone2017

Bphone 2017

Qualcomm DAC WCD 9335 full suport 32 bit/384 kHz

BOS based on Android 7.1.2

 

FB_IMG_1527609582952.jpg

Share this post


Link to post
Share on other sites
On 5/28/2018 at 3:17 AM, Ecksdee said:

Axon 7, pretty please? AFAIK Poweramp has never been able to output to the AK4996 DAC at more than 48k. Neutron is able to output 192k/24 without too much trouble.

I guess it'd not be easy to output hi-res properly on this phone because ZTE has these weird quirks here and there, but if you need any file from the system i can definitely fetch it for you.

edit: on another note, i can't actually find audio_policy.conf under /etc... I have audio_effects.conf though. No idea why, maybe it's 8.0 related, or because i have V4A?

It's quite old device, hard to get now. I have ZTE 7 Mini, which has no Hi-res (while having the same DAC), and ZTE Nubia 17s, which has up to 384khz and works in PA just fine.

From your audio_policy for Axon7 it should work with PA.

What is your Android version and ROM if you have any custom one?

Share this post


Link to post
Share on other sites
6 hours ago, maxmp said:

It's quite old device, hard to get now. I have ZTE 7 Mini, which has no Hi-res (while having the same DAC), and ZTE Nubia 17s, which has up to 384khz and works in PA just fine.

From your audio_policy for Axon7 it should work with PA.

What is your Android version and ROM if you have any custom one?

I'm not Ecksdee, but I am running an Axon 7 as well. Lineage OS 14.1 is a pretty common ROM for Axon 7 users.

Some people use AEX now since that is one of the few Oreo ROMs for the Axon 7, LOS 15.1 hasn't arrived yet but is rumored to be released soon.
I'll report back once LOS 15.1 is available to see if HiRes works on there.

Anyway, my Poweramp Version 709 shows this when I enable HiRes-Output and plug in Headphones:

Screenshot_20180530-010817.png

And here's a screenshot of the OS details, latest nightly, Android 7.1.2, etc.

Screenshot_20180530-011029.png

@maxmp Hope this helps. If you need any more data, maybe a debug log or whatever, I'd be happy to provide that too.

Share this post


Link to post
Share on other sites
On 5/29/2018 at 1:30 PM, maxmp said:

It's quite old device, hard to get now. I have ZTE 7 Mini, which has no Hi-res (while having the same DAC), and ZTE Nubia 17s, which has up to 384khz and works in PA just fine.

From your audio_policy for Axon7 it should work with PA.

What is your Android version and ROM if you have any custom one?

Right now I'm on Stock Oreo (8.0), for the G version. 

It's never worked, even with the older version from here (709?) either on Marshmallow or Nougat. About a month ago the official Oreo 8.0 update got leaked and it also doesn't work with 709 or 790. 790 reports happily that it is working at 192k or whatever you input it, but dumpsys media.audio_flinger says otherwise (outputs through mixer at 48k)

Also, hi-res audio works in Neutron, even in Nougat custom ROMs (All of them are patched to use the AK4490).

One more thing: The stock ROMs have a switch, to select the lower power DAC that's in the AK4961 codec. I don't know if this would interfere with Poweramp at all, but since custom ROMs are seemingly hardcoded to avoid using the 4961, it shouldn't be the problem, right?

 

I'd say it's pretty easy to get a new Axon7 on Europe, a friend almost bought one for 250 euros on Spain. And there are surely some used ones around. 

 

Any file that you need, or test, just tell me

 

 

 

Edit: I've downloaded a 192khz test file (since i formatted a while ago) and took a screenie of media.audio_flinger. no idea if this would help at all

Right when I select OpenSL HD as the output, the volume goes down significantly (I have to crank the volume up to almost full scale) so that might be an indication of the AK4961 kicking in or something, can't be sure at all. 

Screenshot_2018-05-31-00-31-50.jpg

Share this post


Link to post
Share on other sites

Xiaomi Mi max running lineage os 7.1.2.

Hi Res fully working.

Using the new beta. 

BTW, damn this beta is good. 

Share this post


Link to post
Share on other sites
1 hour ago, owruby said:

Xiaomi Mi max running lineage os 7.1.2.

Hi Res fully working.

Using the new beta. 

BTW, damn this beta is good. 

then why exactly did you post on a hi-res request thread if you have hi-res working?

 

?

Share this post


Link to post
Share on other sites

Vivo X21A

running android 8.0

Open SL HD lists aux on 705 but does not work

currently using 709 and Open SL HD does not list aux 

 

Share this post


Link to post
Share on other sites
2 hours ago, wormant1 said:

Vivo X21A

running android 8.0

Open SL HD lists aux on 705 but does not work

currently using 709 and Open SL HD does not list aux 

Do you have Hi-Res Experimental Output for Wired headset/Aux in build 709?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×