Jump to content
Poweramp
maxmp

Requests for Hi-Res Support (please state which build of Poweramp you are using)

Recommended Posts

7 hours ago, parts said:

I tried the 790 build and it works Hi-Res output.

Build 790 did not do much error checking if I recall correctly, and it was possible to enable high-res within Poweramp even if the device was eventually only outputting audio at CD quality. Newer versions correct that.

Andre

Share this post


Link to post
Share on other sites
On 12/19/2018 at 8:35 PM, Cellendril said:

Razer Phone 2 + Razer Hammerhead ANC USB-C

ROM stock - Android 8.1.0

Can get 24/96 with other players when using the Hammerhead's DAC. OpenSL works but obviously not same bitrate, etc.

 

Thanks! I'll test with my Sony NW-ZX300 in DAC mode later today. 

Screenshot_20181219-071544~2.png

Screenshot_20181219-071917~2.png

i have the same issue as you but using Creative Super X-fi amp/DAC instead:

On 12/18/2018 at 10:33 PM, Speedknight said:
  1. Device model- Razer Phone 2+Creative Super X-fi USB DAC/AMP(Chip: AKM AK4377 )  
  2. ROM version- Stock Rom 
  3. Why do you think your device supports Hi-Res- https://sg.sxfi.com/products/sxfi-amp

    Screenshot_20181218-222412.thumb.png.1df4b5e358423693f5b8e131b801a768.pngScreenshot_20181218-220127.thumb.png.ee99410f2a811a264eecb848e60d279b.pngm90dklVHnm85ROlnyiR1b9LcQNjFjDm8fknhpUPv

 

If Even hammerhead won't work means the issue is with Poweramp end i guess....

 

 

 

 

Share this post


Link to post
Share on other sites
4 hours ago, maxmp said:

Poweramp doesn't detect anything related to BT ability to play or not hi-res (it does display codec and BT device name for information purposes though).

So if Android establishes LDAC connection and Hi-Res output is selected in Poweramp, you'll get hi-res output via BT (BTW, confirmed with output spectrum analyzing - via BTR3 device - it really plays up sample rates up to 96khz).

With the Sony Music Center app, you can prioritize Codec LDAC on WH-100XM3 headphones and on the smartphone. On the Sony Hodephones Connect app, it is possible to see which codec is selected on the headset.

On AudioTrack Output, 16Bit / 44Khz is selected on Poweramp. I can manually select sample rate of 96khz and bit per sample to 32bit on settings on deveplorer option on the smartphone.

You know, play menu (showing track name, album artwork and artist name). On output it does not show Hi-Res name. It shows AudioTrack Output 16bit / 44khz or AudioTrack Output 32bit / 96khz.

Share this post


Link to post
Share on other sites

1. vivo xplay 5s

2.stock Android 6.0

3.ESS 9018k2m*2       TI  OPA2612*3

4. Poweramp v3 build 814.non-Google Play distribution version

5.Now , it`s not detect any Hi-Res output option

6.This phone can switch between hifi mode and normal mode,I use hifi mode,Similar to "vivo xplay6"

Thanks.

audio_policy.conf.txt

build.txt

Share this post


Link to post
Share on other sites

Please add support. I only see 16/44, but no 24/96 or higher.
Using the newest version. Poweramp v3.0 Build 814
 

  1. Device model
    -->> Samsung Galaxy A710Y 2016 Model
  2. ROM version (Android version, stock/OTA/Custom ROM)
    -->> Custom Rom Android 6.0.1 (CF-AutoRoot)
  3. Why do you think your device supports Hi-Res (link to device features, etc.)?
    -->> Exynos 7580 Octa, Qualcomm MSM8039 Snapdragon 615 (28 nm), and it is stated in the specs of the phone.

Thanks for the update. Poweramp is my only player for how many years now.

Thank you Poweramp. Thanks @maxmp

Share this post


Link to post
Share on other sites

Lg g7 supports hi-res out of box, there is no difference between opensl/non open sl hi-res, just different APIs.

Share this post


Link to post
Share on other sites
15 minutes ago, maxmp said:

Lg g7 supports hi-res out of box, there is no difference between opensl/non open sl hi-res, just different APIs.

Ty for help :) It was problem with dvc, so turned it off

Share this post


Link to post
Share on other sites

@Artas1488 you don't need root, just in any (e.g. total commander) file manager which can show / (root) open /etc/ and /vendor/etc folders and send audio_policy.conf, audio_output_policy.conf, audio_policy.xml files. Some of files may be missing or can be in either /etc or /vendor/etc folders.

Share this post


Link to post
Share on other sites

@Peniel Thanks for the conf, it's pretty standard qualcomm config. You should have Hi-Res support in Poweramp activated, do you have it?

On Meizu 16, hi-res audio via 3.5 (headphones/aux) output is specifically blocked by OEM (or misconfigured, but changing that requires root access).

Hi-Res via BT + LDAC works fine.

Share this post


Link to post
Share on other sites

@kirill_zverev check if audio.offload.disable=1 is set in your build.props (or via adb shell getprop), if so, hi-res output is explicitly disabled by Meizu for your device as well (as they did it for Meizu 16).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...