Jump to content
Poweramp
Nacho

Android 6.0 No album art

Recommended Posts

Or can I buy the "full" version and use the alpha with that license?

The registration key that you buy from the Google Play store will activate all versions of Poweramp, so download the store version first, then buy and install the key, then you can install whichever versions you like whenever you like, in including new releases from the site here and test versions.

Andre

Share this post


Link to post
Share on other sites

Im using android 6.0.0

My terminal is bq aquarius a4.5

Firmware 2.2.0

 

Nacho, I thought you had a different BQ model, but you have the same as me: it may be a problem with the terminal, not Poweramp, I don't know what to do next...

 

But you told me it worked before, right? In which version, which smartphone?

 

This is really a weird bug!

Share this post


Link to post
Share on other sites

The registration key that you buy from the Google Play store will activate all versions of Poweramp, so download the store version first, then buy and install the key, then you can install whichever versions you like whenever you like, in including new releases from the site here and test versions.

Andre

 

Thanks Andre, I didn't know this! I will buy the full version then and after that I'll test the alpha version thoroughly.

Share this post


Link to post
Share on other sites

i ve just installed the alpha version of power amp and still have the cover problem! So i dont know what can i do. It seems we are doomed to have no covers!

I ve used power amp for 4 years and it was fine until the 6.0.0 updated, in fact it worked fine with the present phone until the 6 updated.

Share this post


Link to post
Share on other sites

I would like to add more information about all this, since it seems to be related to the smartphone model Nacho and me are using. Maybe this serves to get some clue as to what is failing so we can report the problem to the phone maker.

 

Using alpha version or stable (build 582) version, if I long press the screen area where the cover should be to activate the downloader, I get what you can see in the attached image.

 

As you can see, it says "Failed to load Poweramp", which I don't know what means in this context: Poweramp failed to load some image? Some module? Some permission failed?

 

It may not be related to this problem but I thought it was suspicious as all this starts to smell like related to some permission problem.

 

The screenshot was taken using the alpha version, but the exact same happens with official version. I remembered it and that's why I took the screenshot, just in case.

 

I hope that helps...

post-36550-0-84019500-1455488289_thumb.p

Share this post


Link to post
Share on other sites

I tested another player (Neutron) which also does its own media library scanning (it doesn't use the Android Media Scanner library) and it properly shows the album art of my music library AND the album art contained in the test files I provided.

 

So, even if this problem is a weird interaction between Poweramp and my particular terminal model, it's definitely a weird interaction not affecting other players.

 

Neutron is not a bad player either, but the settings menu looks like it was designed by a psycho, no offence. Also, it's more expensive than Poweramp, so I would utterly love this issue fixed in Poweramp, because it's the one I will finally buy.

 

Please, investigate the cause of the problem, I'm ready to help with the debugging: this shouldn't happen, it actually doesn't happen in any other player I've tried!

 

Thanks A LOT in advance, and if Max needs any help with the debugging, I will be more than happy to lend a hand and make as many tests as needed. I can't fix this myself...

Share this post


Link to post
Share on other sites

Yes please,i have use power amp for a long time and i want to use it right in the future.i have no covers and it is a pity

Share this post


Link to post
Share on other sites

[Posted as new topic, "Galaxy S7e not displaying album art", but seems to be the same bug]

Tried with latest public build and the beta.

 

No album art shows at all despite it being embedded in the MP3 files.

 

Have played about with various settings to no avail.

Share this post


Link to post
Share on other sites

Hi, I wanted to add my two cents in - I just upgraded to the Galaxy S7e as well and no longer have any album art.  All my album art is embedded in the tags so there is no downloading - I don't download album art.  My last phone was a Galaxy S6e where it works fine (Lollipop, not Marshmallow).

 

On my GS7e, I have Android 6.0.1 and am running Poweramp build 584.  The Samsung Music Player shows the album art fine.

 

Just wanted to throw my hat in the ring.  :)

Share this post


Link to post
Share on other sites

I have asked Max if he could look into this as it seems to be a fairly widespread issue.

Andre

Thanks Andre.

 

I want to reiterate that I'm ready to help with any testing if needed, no problem.

Share this post


Link to post
Share on other sites

Like others, I have also recently bought a Samsung S7 (not the Edge) and no longer have album art (which is painstakingly embedded in all MP3s).  Previously I was using a S5 (lollipop) and it worked fine.

 

I downloaded the alpha version from this site and that also doesn't display album art.  The visualisations work well as a substitute though! :-)

 

Album art displays fine on other apps I've installed to test, but it's Poweramp I want! :-)

 

I've logged a ticket for this as well (while I was waiting to be validated on the forum).  I am happy to get involved with any testing if needed.

Share this post


Link to post
Share on other sites

As I pointed, looks like a weird interaction with SOME flavours of Android 6, since it works with a Nexus. My phone is part of the Android One program, so it has a Stock ROM, an Android as vanilla as possible, so the reason behind this problem is not some vendor modification, it happens in my ROM which is delivered directly by Google.

 

And as you, lcypurplepants, I'm happy to get involved in any testing, and yes, even though other apps show it, I bought Poweramp because it's the app I want. I can live without album art, of course, or using the workaround I'm using (saving the embedded album art as files in the music directories), but I would love to see this fixed. The visualizations are not a good subtitute for me  ;)

Share this post


Link to post
Share on other sites

DervishD, I didn't explain myself very well, visualisation are a good substitute, *until the issue is resolved* - I most definitely prefer album art.  Particularly when driving when the visualisations would be way too distracting to use!

Share this post


Link to post
Share on other sites

Oh, I understood you point, my intention was not correcting you, I just wanted to say I prefer album art over any other on-screen content and I wanted to say it in a lighter mood.

 

Hopefully in the alpha version we will able to choose both methods because this will be fixed  :)

Share this post


Link to post
Share on other sites

Not sure whether the album art fix referred to in build 585 (uploaded today) will resolve this issue, could someone with marshmallow check?

Andre

Share this post


Link to post
Share on other sites

Andre, as soon as the update gets into my phone (probably in a few hours) I will test and report anything. Thanks A LOT!

Share this post


Link to post
Share on other sites

I'll wait for the Google Play version, even if it takes a couple of days. I'm just awaiting a firmware update on my phone and I don't want to activate the "Unknown sources" to install PA by hand right now. After the firmware update, I will be able to install it by hand or from Google Play, what happens first.

 

I'll post any new in this thread.

Share this post


Link to post
Share on other sites

Cheers. Worth testing the existing 584 build with your new firmware first though, just to be sure to make a genuine test.

 

Andre

Share this post


Link to post
Share on other sites

Mmm, good point, Andre. I will do that, then. I first update the firmware, which should happen tonight or tomorrow, then will test my current 584 and after that I will install 585.

 

Thanks for the advice!

Share this post


Link to post
Share on other sites

I have the a Samsung Galaxy S7 and i have no Album artwork. All my album artwork is embedded into their mp3's. I have also installed the latest build 585 mentioned above and still no artwork

Share this post


Link to post
Share on other sites

Just wanted to add my 2 cents. Poweramp also doesn't show album artwork on my phone. It also has another semirelated issue with DVC, at least for bluetooth devices. DVC worked wonderfully on my S6 Edge before.

Phone: Samsung Galaxy S7 Edge
Android Version: 6.01
Poweramp Version: 2.0.10 Build 584

 

All of my MP3's have artwork embedded into them as well

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...