Jump to content
Poweramp
maxmp

Poweramp alpha-build-700

Recommended Posts

Tell me, do you spend more time looking at your music or listening to it?

 

Andre, this is a very strange comment considering they are adding Visualizations on this very release, lol.

 

I personally would much rather have an overhauled interface (Material or not) than the visualizations.

 

While originally demoing different music players on the Google Play store, I almost opted for n7player or doubletwist because of the better looking interfaces. I ultimately chose Poweramp because of the developer support, features, and compatibility etc. I could tell that it was an overall better product despite a more dated looking UI.

 

 

Current testing alpha 700 on my LG Volt. So far so good!

Share this post


Link to post
Share on other sites

Andre, this is a very strange comment considering they are adding Visualizations on this very release, lol.

 

I personally would much rather have an overhauled interface (Material or not) than the visualizations.

Hey, it wasn't me who added the visualisations... :)

I know Max has spent a lot of time on them (he mentioned 1.5 man/years - which I guess means, given that he's the sole developer, it took him about 18 months) but personally I think I might have put my priorities elsewhere? Yes the visualisations are very pretty, and it's obvious a lot of work has gone into them, and yes a few people had asked for them in the Feature Requests forum, but it was hardly the most highly-requested feature and I think so much more could have been done in other areas in that same timeframe, including updating the interface (Material or otherwise).

But at the end of the day, it's Max's project not mine, and he knows what he wants to work on. Just because I mostly happen to have my phone screen turned off when listening to music doesn't mean everyone does.

Andre

Share this post


Link to post
Share on other sites

Tested...Tried out Few songs and found out that the audio get distorted during the higher mid vocal and treble or parts with heavier bass which has never been noticed with the previous built...is it because the clarity of the audio engine had improved so these hissle and crackles could be heard more clearly or there is something else can be work on this matter? Ive tried changing to SOX Resampler and the dither options though...and i faced forced close issue sometimes when i am resetting the equalizer when listening music...

Device : Sony Xperia Z2

Build : Alpha-build-700

Share this post


Link to post
Share on other sites

Found a couple small bugs so far:

 

1. Album art gets mixed up in various ways. Usually involving the first played album's art later showing up on different albums.

 

2. Album change swipe reacts differently, it's less sensitive. Up swipe (next album) is especially unresponsive, sometimes requiring a faster or longer swipe to change.

Share this post


Link to post
Share on other sites

I have to agree with most everyone else so far, this alpha (if it is indeed an alpha) has been more stable than 90% of the betas I have tried. No major problems have occurred yet aside from occasional sluggishness.

I had 1 weird glitch happen where I exited out of another app and Poweramp resumed playback over a Bluetooth speaker despite having the setting unchecked and it also resumed the song where it had left off. Haven't been able to reproduce it though so who knows.

The visualizers are pretty cool even though I usually leave my screen off when I play music, but I might actually start using them now that they are built in and I dont have to use a separate app.

One quick question, I haven't had to time to go through all the different resampler and dithering options but do I need to disable Viper4android to test these out?? So far I can't really tell a difference

Galaxy S4 - stock 4.4.4 Touchwiz

Alpha build 700

Share this post


Link to post
Share on other sites

Hi Andre / Max

 

Just a few pointers - 

  1. Queue / Now Playing - Any way to combine the two? - This is because since there is no Now Playing feature, you cannot rearrange tracks. Only possible in a playlist, queue.
    1. Also, I am pretty sure a lot of people find the way the Queue works as confusing and bloated. Why not make it simple, combining enqueue and play next options with the Now Playing as a single queue ?
  2. Audio Focus - Poweramp still cannot reduce volume for loss of audio focus. I hate to rage on this topic, but a simple google search gives a basic understanding of that. More than 95% of music players on the play store do this. Why not Poweramp?

Share this post


Link to post
Share on other sites

Queue / Now Playing - Any way to combine the two? - This is because since there is no Now Playing feature, you cannot rearrange tracks. Only possible in a playlist, queue.

I think you have misunderstood the purpose of the queue (as you say, it's not very clear). It's not really intended for regular listening, but instead to allow you to temporarily 'break away' from your regular playback to listen a few specific tracks, and then return seamlessly to where you left off in your normal playback order. What you are describing is perhaps more of a Playlist feature. [i've removed your double-post from the other thread]

Andre

Share this post


Link to post
Share on other sites

I think you have misunderstood the purpose of the queue (as you say, it's not very clear). It's not really intended for regular listening, but instead to allow you to temporarily 'break away' from your regular playback to listen a few specific tracks, and then return seamlessly to where you left off in your normal playback order. What you are describing is perhaps more of a Playlist feature. [i've removed your double-post from the other thread]

Andre

OK great thanks for clearing that up.

But. .. If I want to move my tracks around in the current playlist/ selection, how do I do that ?

Also, the more important point - respecting audio focus. Any info on that ?

Share this post


Link to post
Share on other sites

The audio focus question is a longstanding wishlist item in the Feature Requests forum.

You can re-organise Playlists (or the Queue) by simply moving items up and down using the slider-thumbs to the right of each title. Other lists (Folders, Albums, Artists, etc) are automatically organised based on the sort order that you have defined for that category, but they can't be individually tweaked other than by altering the sort order. If you want to do that, make a Playlist of the one you want to alter (it's very easy - just long-press on any folder/album/etc title and tap Add to Playlist)

Andre

Share this post


Link to post
Share on other sites

Ok, been running V3 build 700 for just over a week... Over-all, it's fairly stable and it just sounds better in my car and with earbuds. 

 

A couple observations:

1) Playing through a Bose Bluetooth speaker, it crackles/static slightly every other song or so and will drop out for a fraction of a second about every 3rd or 4th song, didn't do this before

2) Has randomly just stopped playing music without touching the phone. This has happened with and without anything plugged in (no bluetooth). 

 

I think that's all I can think of right now? There was a 3rd one, but I can't remember it now? 

 

Like I mentioned, it just sounds better now. The lows are more defined and the highs are clearer, with the exact same EQ settings I had before the upgrade to the testing alpha-build. 

 

GREAT work! 

Share this post


Link to post
Share on other sites

After using it more now the only other problem I've had so far is with the visualizations. Sometimes it just won't load. Sometimes there will be a complete black screen, sometimes the overlay controls will be on and completely opaque and sometimes the overlay controls will be translucent. So far backing out of the app using the back button and not using the home button will reset it so it works again.

Share this post


Link to post
Share on other sites

Although I see similar bugs I don't see mine exactly.

 

With bluetooth earphones (Sony SBH50), when I listen to music and decide to make a call or answer one, the playback will briefly continue after the "call"/"accept" button has been pressed with distorted sound (probably because the device switches sound quality to "call") and then pauses as expected. However once the call ends, playback does NOT resume, furthermore, it will not resume even when I manually press the bluetooth's "play" button. The bluetooth will show that it has accepted the command itself (the on-screen display will change the playback icon from pause to play) but nothing will happen.

 

The only way is by opening Poweramp and tapping the play button from the app, at which point the last song starts playing from the beginning and at which point the bluetooth's controls start working again.

 

I am using a OnePlus One with a CM12.1-based ROM (Lollipop 5.1.1) with a CAF 3.4.0-based kernel (found HERE), Rooted and XPosed (but only for battery optimization and ad-removal, nothing that affects sound, playback, Poweramp or the Bluetooth wakelock).

I have also installed Sony's Smart Connect and the SBH50 plugin/driver but have not enabled any events from their end, just added some basic functionality like the time and SMSs being displayed on the bluetooth's screen.

Share this post


Link to post
Share on other sites

The bluetooth will show that it has accepted the command itself (the on-screen display will change the playback icon from pause to play) but nothing will happen.

I've noticed that sometimes commands seem to get 'held up' in a Bluetooth queue, I wonder if the same is happening with your system? I find that soon after Poweramp has started, sometimes (and it's intermittent) issuing commands such as Play/Pause or track changes from the car stereo has no effect... but about 1-2 minutes later all the pending commands suddenly trigger in quick succession. Could you try pressing Play and then leaving things alone for a few minutes to see if anything happens?

Andre

Share this post


Link to post
Share on other sites

Im using Poweramp with Xperia z1, on Bluetooth mainly alpine car headunit and Sony Bluetooth headphone.

1. Music will not auto resume when connected

2. After disconnection from Bluetooth, a second of a sound will play on phone's before stopping.

3. Navigation tts problem (same with stable version) music will pause but tts announcement will not finish what it is saying, but will continue to pause, then resume after (assuming navigation finished talking)

No comment with other features as I only use default settings

Thanks, I hope audio focus will be next since this affects my use with navigation and Poweramp too

Share this post


Link to post
Share on other sites

I've noticed that sometimes commands seem to get 'held up' in a Bluetooth queue, I wonder if the same is happening with your system? I find that soon after Poweramp has started, sometimes (and it's intermittent) issuing commands such as Play/Pause or track changes from the car stereo has no effect... but about 1-2 minutes later all the pending commands suddenly trigger in quick succession. Could you try pressing Play and then leaving things alone for a few minutes to see if anything happens?

Andre

Although it never happens to me even after hours of normal playback and will only happen after a call, I will try this and report back.

Also of note is that today, I made a call during playback and even though the music did not resume after the call ended, this time it accepted the manual "play" command from the bluetooth, first time it happened to me, not sure what's different as i haven't changed anything in my phone in months..

 

Im using Poweramp with Xperia z1, on Bluetooth mainly alpine car headunit and Sony Bluetooth headphone.

1. Music will not auto resume when connected

2. After disconnection from Bluetooth, a second of a sound will play on phone's before stopping.

Read previous post, I noticed the same thing, apparently it is a general issue with bluetooth as it doesn't appear to happen with wired earphones.

Share this post


Link to post
Share on other sites

Read previous post, I noticed the same thing, apparently it is a general issue with bluetooth as it doesn't appear to happen with wired earphones.

Read the whole thread on the subject ( http://forum.powerampapp.com/index.php?/topic/8516-poweramp-doesnt-resume-playback-after-bluetooth-phonecall-terminates/ ) it has been discussed a fair bit and is a known issue in the alpha release.

Andre

Share this post


Link to post
Share on other sites

Can we have the old implementation of stereoX back as well? 

 

I love how it brings the highs forward without producing the artificial soundstage or altering the actual frequency response. It could be renamed to "treble separation" for all I care, but I need DAT FEATURE! 

Share this post


Link to post
Share on other sites

When playing a playlist it doesn't show the correct album art. It shows the same cover for all songs of the playlist, but the cover it shows is not even in the playlist

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...