Jump to content
Poweramp
blk_jack

Unable to select microSD directories on Android 6

Recommended Posts

Long time user, first time poster.  First off, thanks for all your hardwork!  This is by far my favorite music app on Android and I've been using it for years now across all versions of Android.

 

Since Marshmallow scrapped set mountpoints for external storage, my microSD card is being dynamically mounted on boot as /storage/public:179,65

 

It actually shows up fine in Poweramp under Music Folders, but after I select a sub-folder (or the entire storage directory), it doesn't "stick" or save.  When I return to Music Folders, no sub-directories in /storage/public:179,65 are selected.

 

If I were to guess I would assume it has something to do with the directory containing a colon or comma?  I can't say, just my hunch.

 

Let me know if there's any additional logs/debugging I can do, I'm a developer myself so I'd be more than happy to help out.

Share this post


Link to post
Share on other sites

Ok, we'll see if it is possible to reproduce such an issue, what device do you use, do you run custom or stock ROM?

Thanks!

Sorry, reply notification went to spam!

I'm running the stock Concept M ROM that Sony is rolling out to testers. It seems to be almost entirely AOSP stock with very few additions from Sony so far.

Share this post


Link to post
Share on other sites

Same problem here, Sony Z3 Compact running Sony's Android concept initiative - M Edition.

The SD card is 128 GB, and was working happily with Poweramp on Android 5.1.1.

I have formatted the SD card, and copied the files onto it anew, but that didn't help.

Share this post


Link to post
Share on other sites

Also having the same problem , same Sony concept Z3C Rom/128Gb card combination.

A older 32Gb card works fine, it doesn't have a comma in the directory path. 

So that could well be the problem.

 

Not sure how Android M generates names for the External SD.

Share this post


Link to post
Share on other sites

Also still having this problem... LG G4 H815 EUR, Android 5.1.

 

Just a note, other apps (and audio players...) at handling perfectly fine this permission grant. This has to be fixed.

Share this post


Link to post
Share on other sites

Also still having this problem... LG G4 H815 EUR, Android 5.1.

 

Just a note, other apps (and audio players...) at handling perfectly fine this permission grant. This has to be fixed.

Are you sure you're commenting on the right thread? So far this specific issue (i.e. not being able to find the SD Card's directory to scan for music) has only shown up on Marshmallow (6.0) ROMs. Your comment sounds more like the issue with Grant Access in order to edit tags or delete song files from SD Cards.

Andre

Share this post


Link to post
Share on other sites

LG G Stylo, same problem. Other apps find my music, but Poweramp doesn't even see the card. Stock Marshmallow on Virgin Mobile. Not rooted, no custom roms.

Share this post


Link to post
Share on other sites

I've passed this on to Max, and he's going to look into it. It's a bit tricky to test though as he doesn't currently have any 6.0 devices with external SD Card slots, all of the 6.0 test units are Nexuses at the moment.

Andre

Share this post


Link to post
Share on other sites

LG G Stylo, same problem. Other apps find my music, but Poweramp doesn't even see the card. Stock Marshmallow on Virgin Mobile. Not rooted, no custom roms.

Other than your post, everyone who has reported this has been using Sony phones. Could you check what the assigned pathname for the SD Card is on your marshmallow device?

Andre

Share this post


Link to post
Share on other sites

Other than your post, everyone who has reported this has been using Sony phones. Could you check what the assigned pathname for the SD Card is on your marshmallow device?

Andre

 

Got the same problem with my Xperia Z3 Compact running Android 6.0.1 Concept Marshmallow, following folder path is being shown:

 

/storage/public:179,65

 

EDIT: Tried the Alpha Build v700, same problem presists...

Share this post


Link to post
Share on other sites

Sony again. Why would anyone design a route to an SD card with an embedded colon and comma inside the path?

Andre

Share this post


Link to post
Share on other sites

On my Galaxy S4 running an AOSP 6.0.1 ROM my sdcard, as reported via Poweramp, is at /storage/215F-1B08  It's been the same with all 6.x ROMs I've tried (from memory). And reading various internet forum threads the sdcard under 6.x is always in this format IF it's being used as an external device. i.e. as 'Document storage' in Marshmallow parlance. People seeing it differently haven't formatted their sdcard as internal storage have they?

Share this post


Link to post
Share on other sites

I tried with alpha build 702 on Stock 6.0.1 same problem.

TInkering with the app permissions in the settings told me that Poweramp was using the old method of storage permissions found on older Android Versions. Seems to me that unless Poweramp is recompiled with added permission syntaxes for android 6.X, it won't be able to acces external storage.

Share this post


Link to post
Share on other sites

Those that are having problems, how is your card formatted? I have mine formatted as fat32 (on the PC - for cards over 32GB search for 'fat32format' and if you're not a fan of the command line, 'guiformat') and that seems to get over a whole lot of problems that some people have with SD Cards in Android 6.x. One thing I found vaguely interesting was that when I formatted my sdcard (for some reason I did this recently - can't remember why ....) the mount point changed from the above '215F-1B08' to another string, though obviously the same format. Seems this 'string' only changes when formatted - maybe this is why some can't find their card?

 

Dave

Share this post


Link to post
Share on other sites

Sorry it looks like an issue with the phone on USB with mass file transfer enabled.  After I removed USB it found the card and music directory.

Share this post


Link to post
Share on other sites

did ya guys tried uninstall Poweramp and reinstall it fresh from playstore not from titanbackup ?

had similar problem when i updated to MM

Share this post


Link to post
Share on other sites

Same problem sony xperia z3, stock 6.0.10...

my Poweramp won't open. error: Poweramp can't verify the purchase through Google play license verification/APM

cause:/

Share this post


Link to post
Share on other sites

You might want to try the alpha test release from the forum Downloads tab and see if that helps. A few people have been reporting issues with 6.0.1 updates.

Andre

Share this post


Link to post
Share on other sites

Hi, I just upgraded to 6.01 on my Samsung S5 and can confirm that Poweramp can see the SD, but not access any files on it.

 

 

Share this post


Link to post
Share on other sites

Do you see the list of folders in the Music Folders menu, and can you tick or untick them? If that works, would does a Full Rescan discover?

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×