Jump to content

Recommended Posts

Hello Guys,


so... I've tried to create a custom theme for Poweramp and kinda failed at that in all ways...

So far I got ant running, I got the Android SDK on my hard drive (I use it for normal android development also, and it works fine).

I got thorugh the first steps of creating a custom theme from http://forum.powerampapp.com/index.php?/topic/3578-building-skins-quick-start-guide/ , but when I tried to compile it with ant (just the "ant" command) I get following error:

Buildfile: E:\CODE\PowerampHoloMD\poweramp_skin_sdk\skin_template\build.xmlBUILD FAILEDE:\CODE\PowerampHoloMD\poweramp_skin_sdk\skin_template\build.xml:90: The following error occurred while executing this line:java.io.FileNotFoundException: C:\AndroidSDK (Zugriff verweigert // This means access denied)	at java.io.FileInputStream.open0(Native Method)	at java.io.FileInputStream.open(Unknown Source)	at java.io.FileInputStream.<init>(Unknown Source)	at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:250)	at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:168)	at org.apache.tools.ant.taskdefs.ImportTask.importResource(ImportTask.java:222)	at org.apache.tools.ant.taskdefs.ImportTask.execute(ImportTask.java:163)	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)	at java.lang.reflect.Method.invoke(Unknown Source)	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)	at org.apache.tools.ant.Task.perform(Task.java:348)	at org.apache.tools.ant.Target.execute(Target.java:435)	at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:180)	at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:93)	at org.apache.tools.ant.Main.runBuild(Main.java:826)	at org.apache.tools.ant.Main.startAnt(Main.java:235)	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)Total time: 0 seconds

so... as far as I understand I don't have the permissions in order to read or use the android SDK. I've tried to copy it to another folder, same result. Tried to set all permissions manually through folder properties, same result. Same with deactivating the antivirus...

I'm pretty helpless with that and because of this special use case there are little to no help sources so I thought to post it here even though it's not directly a PA skin problem...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...