Jump to content
Poweramp
Sign in to follow this  
andrescm

Poweramp starts playing when it shouldn't

Recommended Posts

Hello,

I've been using this app since I bought it about 3 years ago. It's perfect in almost every aspect except one, which I discovered during the last year when I bought a car. I use the app to stream music via bluetooth. But many times I only have the phone connected via BT in case someone calls me, not to play music. Now I'll try to explain the sequence in detail:

 

1. (The "Resume on Bluetooth" option is always disabled).

2. The phone connects to the car stereo via bluetooth.

3. I start playing FM radio on my car stereo.

4. At some moment I receive a notification on my phone (an SMS, a Whatsapp message, a calendar reminder, etc.). The notification ringtone is heard through the car stereo.

5. The car stereo's sound source switches automatically from FM to bluetooth stream at this moment.

6. I switch the car stereo's source back to FM radio.

7. I hear the FM radio for a second and then Poweramp starts out of the blue playing from where it left off the last time I used it. If it was in the middle of a song, it resumes that song.

 

Conclusion: I have to unlock my phone, stop Poweramp and switch the car stereo back to FM radio for a second time.

 

How can I stop this from happening?. I mean, I'm not using the app at all at these moments, it's not even in the recent apps panel. As far as I know, it's only reacting to some kind of trigger launched by the car stereo when I switch to FM radio, but that's all I can tell.

 

I've read this post and it seems to cover my case, I've yet to confirm. If that's the case, is there any way I can trace the bluetooth commands so I detect which app sends the MEDIA_PLAY command?

 

I'll greatly appreciate any comment on this matter.

 

Regards,

 

Andrés

Share this post


Link to post
Share on other sites

You could try the Settings > Audio > Audio Focus menu and unticking the audio focus change settings, and/or try unticking Resume After Call.

Andre

Share this post


Link to post
Share on other sites

Thanks for your quick response. It's unticked already, the only enabled options are "Pause in call" and both short and permament audio focus change. The two resume options are disabled.

Share this post


Link to post
Share on other sites

It could be trying to resume thinking there was a call, or a focus issue, try them all in turn and see if any help.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...