Jump to content
Poweramp
Sign in to follow this  
djdarko

Gapless Lossy Glitch

Recommended Posts

Gapless Lossy Glitch

 

A light audio glitch/pop that occurs during a track segue ONLY while using lossy formats.

 

The glitch occured everytime while using these formats:

LAME MP3 Constant and Variable Bitrate

Apple AAC/M4A Constant and Variable Bitrate

 

Note: The files playback perfectly on iPod/iTunes/Foobar2000

 

This glitch did NOT occur for these formats:

WAV/CUE

WAV

FLAC

Apple Lossless

 

 

 

Information:

 

Phone: LG VOLT

Android: 4.4.2

Poweramp 2.0.10 Build 575

 

 

CD Source: Nine Inch Nails - Pretty Hate Machine Retail CD from 1989. Ripped using EAC (100% Accurate Rip)

Share this post


Link to post
Share on other sites

Okay, I did a bit more research into this and it's a common problem and basically no android player is able to play those files without a slight hiccup as of writing this.

 

The problem is that supposedly these files are not truly gapless the way lossless files are written, but written with start/stop point data which is read by iTunes/iPod/Foobar2000 which let's the program know exactly which sectors to skip to play seamlessly. It would be great if Poweramp could implement this feature.

 

Solutions:

 

1). Deal with the small problem until Poweramp implements proper decoding of those file types.

2). Re-rip files into single m4a/cue <--- already tested and this works. Place your .jpg image file into the folder so that the image shows when playing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×