Jump to content
Poweramp
gindi107

Moved all of my songs to Unknown artist

Recommended Posts

Hey there,

I have been enjoying the use of Poweramp for the last year and really impressed with the app, so far it worked great until a week ago that i opened my Galaxy 2 device and the player app and noticed that suddenly all of my songs as moved under the title of "unknown artist":

I went to check the files source on the sd card and it all seems fine, on the galaxy original player they are still under the right artist names and everything seems to be in place..

 

I have over 2000 songs and i just cant go one by one again to edit. what can i do to fix it?

Yours, Nitzan

Share this post


Link to post
Share on other sites

What do you see in the Info/Tags display for the files, is the artist name still listed in there?

Andre

Share this post


Link to post
Share on other sites

I have the same problem. Every once in a while, the app will freeze and when I get it to reboot (usually after rebooting the phone and unmounting / mounting the SD card), a large group of songs come back as "Unknown Artist - Unknown Album". However, all the data is still in the song tags so I have to go one by one and  hit Edit Tags then save as the song tags are still there

 

Sony 64gb SD card w/ Motorola Razr Maxx

Share this post


Link to post
Share on other sites

I have the same problem. 600+ unknown artists. The stock player only says 2. All tags are present except those 2 that the stock player is referring to. Version 2.0.9 build 558

 

Edit: It's also removing/adding songs upon rescans regardless of the fact that I haven't removed or added any songs to my phone. Saddening because this is my favorite player based on the UI alone. I can't use it if songs are going to disappear and reappear when they feel like it.

Share this post


Link to post
Share on other sites

I have the same problem with my HTC One M8 after upgrading and transferring all songs onto the SD card.

In the Unknown Artist folder itself, all the songs are listed in alphabetical order by song name which seems to be the only thing known eg:

American Dream

Unknown artist

 

If i long press and click on Info/Tags however, the Title, Track, Artist, Album names are all blank. I have tried a few ID3 tag fixers to fix the missing info but that doesn't work.

 

NB. When i open the stock HTC music player, there are NO Unknown Artists, all songs are in their Artist and Album folders.

 

Please help as i have 200+ songs in my Unknown artist folder and i prefer Poweramp to the stock HTC player.

Share this post


Link to post
Share on other sites

While it seems unlikely that it is all of your song files themselves that are at fault (and you are not the only user to report this problem) please could you send one of files by email to poweramp.maxmpz (at) gmail.com for checking. Thanks.

Andre

Share this post


Link to post
Share on other sites

i Andre, I sent a song that's in my Unknown artist folder to the email address you provided and the reply was all about Google searching for album art!

FYI I have done a full rescan and the songs remain in Unknown artist, while again they're in the correct folder in my stock music player...

Cheers

Share this post


Link to post
Share on other sites

Reply again, referring to this thread too, and saying it is nothing to do with album art (possibly some over-zealous use of stock replies there! :) ).

Andre

Share this post


Link to post
Share on other sites

Poweramp, you are smart enough to know what is happening.  by not replying to the various threads with a reasonable solution or at least explanation, an appearance of disregard seems to be the approach.  there are too many reports of this not to address it.  

 

device

samsung galaxy S5

 

music folder location

on device

 

in the all songs view, unknown artist / unknown album

when viewing tag, all accurate data exists.  

when clicking on the unknown artist / unknown album song the song plays and shows accurate data.

the issue appears in the all songs view

 

steps to reproduce

1. using PC, ensure that tag info is accurate and copy to music folder on mobile device

2. launch Poweramp

3. rescan

4. click on all songs

5. look at recently added

6. view 'unknown artist / unknown album' entries

7. view tag info

--will show accurate tag info

8. play selected song

--will show accurate tag info

9. go back to all songs view

--will show 'unknown artist / unknown album'

 

expectation

Poweramp will ALWAYS show accurate tag info in every view

 

actual

Poweramp 'all songs' view does not always show accurate tag info

 

**in other music players, the tag information renders as expected in all views.  this is a Poweramp specific issue.

Share this post


Link to post
Share on other sites

As of this week, any new music I download to my GN3 is identified as "unknown" in Poweramp. Tags are all correct. Any solution in the works? How about a status update on the previous bug reports in this thread? Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×