Jump to content
Sign in to follow this  
elias78

Annoying pauses during play on neo minix x5 from network storage wd mycloud

Recommended Posts

Hello, 

 
I use Poweramp for my media center and have this configuration: 

1. network storage device wd mycloud with mp3 files

2. neo minix x5 (android mini pc) with android 4.2.2 minix rom running Poweramp and playing the music from the mycloud device over the network.
3. i use mount manager to mount the music folder that is in the mycloud network disk using cifs 
from this path: //192.168.1.13/Media 
to this path: /mnt/sdcard/cifs/Media 
 
both devices (1+2) are cable connected to the router 
 
now, the problem is when I play, the music isn't playing continuously, there are annoying pauses! 
 
I read the "Skips, hiccups, stutters" issue in the Poweramp F.A.Q and other posts regarding this problems and changed some configurations on the Audio Advanced Tweaks:
1. set buffer size to 750 ms 
2. set audio thread priority to 3 and to "highest"

 

AND STILL THE PROBLEM EXISTS
 
My questions:
1. Does anybody is playing over network without problems?
2. maybe the problem is mount manager, are there good alternatives to this app?
3. Any ideas how to fix this will be welcomed

 

 

Thanks,

Elias  :)

 

 
Some links:
 
neo minix x5 device: 
mount manager app: 

Share this post


Link to post
Share on other sites

Does this happen if you play from local phone storage (internal memory/sd card)?

 

Unfortunately we don't test Poweramp vs network storages and generally its audio pipeline is not made for that. 

It's highly optimized for the cpu/memory limited mobile device, thus we have reduced buffers and specifically designed decoding time slices.

We have improved decoding logic in new Audio Engine though, which will much better handle such use cases.

Thanks!

Share this post


Link to post
Share on other sites

I would say you need a more powerful Android box. I used to have a Rockchip v8 box very similar to yours, and while playing from a CIFS mounted library worked I also experienced some stuttering, changing tracks was choppy etc. Now I have a Tronsmart Vega S89, which is based on the AMLogic S802 quad core A9 SoC and damn fast, and now I can play from my CIFS share no problem, even with library close to 1TB.

 

I can pretty much confirm that it's down to the device as it also works perfectly on my Nexus 5 -- I can even stream from my CIFS share over WAN on 4G :)

Share this post


Link to post
Share on other sites

Hi, I just joined here to try to get to the bottom of this very issue! Poweramp stutters like crazy for me when playing from network storage via cifs. It didn't used to happen. It's only started over the last month. I have been using it with cifs for just over a year with no problems with a 1.5TB library playing mostly flac, and often 24/96 flac, so large high res files (I know there's no odds on android, but I share my library with a system where 24/96 is an option). I've now returned to BSplayer which still plays tracks without issues.  Very peculiar.Is it possible that an update degraded network performance by accident? It's very unfortunate whichever way as for me Poweramp is easily the best player around for android. 

 

I've got a cheapo chinese yuando 101ii, rooted with custom firmware (so I could get cifs working)

 

Sorry I can't help! 

 

Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...