Jump to content
Poweramp
Lucky815

App Constantly Freezes when Searching

Recommended Posts

I'm using my Note 3 on KitKat, and the app keeps freezing while browsing my albums folder. Granted, I just started using a 128gb SD card, so my library is huge. Any ideas on how to fix this problem?

Share this post


Link to post
Share on other sites

I'm using my Note 3 on KitKat, and the app keeps freezing while browsing my albums folder. Granted, I just started using a 128gb SD card, so my library is huge. Any ideas on how to fix this problem?

 

I've had the same problem since around January and it's still the same with my 64gb card on note 3 kitkat.

 

If you find a work around let me know, since January I've had to revert to using samsungs music app whilst waiting for an update.

Share this post


Link to post
Share on other sites

I'm using a 64GB SanDisk card on my Note 3 with no such issues - although I only have about 30MB of music on the card at the moment. Have either of you managed to get any logfile data of these crashes (CatLog is the easiest way to do that)?

Andre

Share this post


Link to post
Share on other sites
Android 4.4.2 here, build 14.3.A.0.757 on a Xperia Z1 Compact, none rooted and the latest version of Poweramp. Same problem - since my new Android version I guess. Keeps stuttering in the album list, grid view, during scrolling. 
Quite annoying. Hope there's a fix for this, love the app.

NB. Maybe it's related to the not so long ago introduced high res album art? 

Share this post


Link to post
Share on other sites

This can be broken file(s) on sd card. In this case, Android file subsystem freezes and app can't do anything (no error returned, thread just go to permanent sleep). Also, if sd card unmounts by itself (or remounts) - it's the indication of such issue. I would suggest:

1. checking sd card for error (on computer)

2. limiting set of folders Poweramp scans on sdcard in Poweramp settings / Folders and Library / Music Folders to just folders with the music.

Thanks!

Share this post


Link to post
Share on other sites

Well, I'm going to check my sd card for errors then; option #2 isn't it; I already had only one folder selected for the library to search in.

 

Thanks for the suggestion, I'll let you know if it works! :)

Share this post


Link to post
Share on other sites

So, done some testing on my MicroSD card - it's a Samsung 32GB class 6 card by the way. No errors where found. And like I said before; only one folder for Poweramp to search through.

 

Any other suggestions?

Share this post


Link to post
Share on other sites

Try moving you music (or at least some of it) to your device's internal memory and see if you get the same problem when you change the Music Folders selection to play from there only.

 

Andre

Share this post


Link to post
Share on other sites

I copied about 4GB of music to my internal memory - didn't have more space left, and the problem didn't occur. So it could be the amount of music or the albumart, or the read difference between in- and external memory. Still hope it can be fixed in an update :-)

Share this post


Link to post
Share on other sites

So, no further solutions? I really love Poweramp but this bug is making it kind of unworkable when I'm driving my car. I'm trying another music player now which hasn't got this specific issue, but I really do hope this gets fixed.

Share this post


Link to post
Share on other sites

This is bad block on sd card. There are no other causes of this issue, as far as we can say.

Thanks!

Share this post


Link to post
Share on other sites

It's strange how this bad block doesn't affect other music players, e.g. GMMP.

 

But I really like Poweramp so I'll put in some more effort to fix this. Any suggestions as to how I can fix this bad block problem?

Share this post


Link to post
Share on other sites

But I really like Poweramp so I'll put in some more effort to fix this. Any suggestions as to how I can fix this bad block problem?

IF it is a bad block there are several things you could try. First, if you have enough space, copy your files onto your device's internal memory and try scanning/playing from there.

If not, copy everything from your memory card to a PC (and make sure that it's all there!) then try scanning the memory card in the PC for bad blocks. I think the command-line programs chkdsk or scandisk should help you.

Finally, reformat your memory card in the PC (using FAT32 - and select Full, not Quick formatting) and then copy everything back again. If you have any bad data areas, that should deal with them. I'm not sure of the easiest way to force a Full format on an Android device, but there will be an app to do it.

Andre

Share this post


Link to post
Share on other sites

IF it is a bad block there are several things you could try. First, if you have enough space, copy your files onto your device's internal memory and try scanning/playing from there.

If not, copy everything from your memory card to a PC (and make sure that it's all there!) then try scanning the memory card in the PC for bad blocks. I think the command-line programs chkdsk or scandisk should help you.

Finally, reformat your memory card in the PC (using FAT32 - and select Full, not Quick formatting) and then copy everything back again. If you have any bad data areas, that should deal with them. I'm not sure of the easiest way to force a Full format on an Android device, but there will be an app to do it.

Andre

 

So, I tried the second option (as stated, my internal memory doesn't have enough space to copy 30GB of files). My PC didn't find any errors on the SD card. So I formatted the thing, copied everything back like it was.

 

Aaaaand; the problem is not gone. :(

 

 

Any more solutions or workarounds are more than welcome.

Share this post


Link to post
Share on other sites

If you have multiple folders there, just try to check (In Settings / Fold. and Lib. / Music Folders) like 3-4 each time until offending folders are found.

You can also check a log (if you have root, with apps like Catlog). Poweramp won't log anything, but system media scanner will complain a lot on some file. System media scanner process is a separate non ui process, so you don't generally see if it freezes or crashes, but log can be useful.

Thanks!

Share this post


Link to post
Share on other sites

I already have only one folder selected for my music. And unfortunately, my phone is not rooted. 

 

 

NB. I noticed the freezing also occurs when scrolling through my library even when I'm not playing any music :huh:

 

So there's that. 240 folders (root/music/artist/album) with accompanying folder art seems to be a bit much for Poweramp (or my phone). But as stated earlier; other music players don't seem to have this problem.

 

 

(Android 4.4.2, build 14.3.A.0.757, with a Samsung 32GB class 6 SD card on a Xperia Z1 Compact)

Share this post


Link to post
Share on other sites

You first say you have only one folder selected for music, but then you say you have 240 folders? What Max was suggesting was to deselect all the folders/subfolders and then select them one-by-one (or groups at a time) until you find the one (or more) that might be causing the problem. I have a lot more folders/subfolders than you do, and I don't see the problems you do, so I don't think it's an inherent limit of the software.

 

Andre

Share this post


Link to post
Share on other sites

I am sorry that you misunderstood, or that I explained myself wrong. But who in their right minds has 30GB of music unorganized in 1 folder??

 

On my SD card there is 1 folder called music; this folder is selected for the library to search in. In this folder I created a structure as follows: about 100 folders of artist names and below each artist folder ar the album folders.

 

So yes; in the end I have only one folder selected, and below that is a neatly organized set of artist and album folders.

 

And Max' 'solution' (excuse the sarcasm); testing each folder and wait if Poweramp stalls is going to take me several evenings - if not more - something I'm not willing to do (excuse the laziness) anytime soon.

But I'll sleep on it, the problem is annoying enough to put some time in it. I was just hoping there would be an easy solution.

 

But thanks for the advice and support; I'm going to see what I can find.

And good luck with Uruguay!  :D

Share this post


Link to post
Share on other sites

On my SD card there is 1 folder called music; this folder is selected for the library to search in. In this folder I created a structure as follows: about 100 folders of artist names and below each artist folder ar the album folders.

 

So yes; in the end I have only one folder selected, and below that is a neatly organized set of artist and album folders.

 

And Max' 'solution' (excuse the sarcasm); testing each folder and wait if PowerAmp stalls is going to take me several evenings - if not more - something I'm not willing to do (excuse the laziness) anytime soon.

So you do have hundreds of folders selected, as we assumed. Being pedantic or sarcastic about whether they are folders or subfolders won't help anyone to solve your problem. The Music Folders list is a folder tree, you can expand it and select or deselect any level of folders and subfolders that you want.

The probably large quantity of folders is why both Max and I suggested enabling them in batches until you find out which folder or folders contains any problem content. Unless it's something specific to the file system of your phone of course, but as I too am using a Note 3 with KitKat and a 64GB external card (with a similar quantity of music and folders) I rather doubt that. My Note 3 is rooted, but still on stock rom/kernel.

Andre

Share this post


Link to post
Share on other sites

So you do have hundreds of folders selected, as we assumed. Being pedantic or sarcastic about whether they are folders or subfolders won't help anyone to solve your problem. The Music Folders list is a folder tree, you can expand it and select or deselect any level of folders and subfolders that you want.

The probably large quantity of folders is why both Max and I suggested enabling them in batches until you find out which folder or folders contains any problem content. Unless it's something specific to the file system of your phone of course, but as I too am using a Note 3 with KitKat and a 64GB external card (with a similar quantity of music and folders) I rather doubt that. My Note 3 is rooted, but still on stock rom/kernel.

Andre

Yesyes, I am truly sorry for any pedanticness on my side. No need to be so triggerhappy. Anyhow; I am still thankful for the help and I'm going to see what's what.

By the way: I am not the topic starter, I own a Sony Xperia Z1 Compact.

(Android 4.4.2, build 14.3.A.0.757, with a Samsung 32GB class 6 SD card on a Xperia Z1 Compact)

Share this post


Link to post
Share on other sites

By the way: I am not the topic starter, I own a Sony Xperia Z1 Compact.

Oops sorry, missed that in the thread.

Andre

Share this post


Link to post
Share on other sites

Hi again. So I did as you suggested; costed me quite a bit of time. But I didn't find any errors whatsoever.

But here's the strange thing. I was accustomed to using the 'folder mode'. In this folder mode I kept running into this annoying bug (list and grid view).

But! When I use the library in album view, artist view or any other of the options in there, the freezing does not occur! Only problem here is that the folder mode is easier to use for me for a number of reasons, so I'd rather scroll through the folders.

Anyhow, I sincerely do hope you guys got an explanation for this.

Share this post


Link to post
Share on other sites

Hi,

 

As my last post is almost a week old and has reached the amount of 0 answers since then, I come here curious of what's causing the silence.

As stated; I don't experience the problem as long as I use the library, but as also stated; the library doesn't work so welll (i.e. with soundtrack tags and it screws up the order of multiple cd albums).

 

Concluding; still loving the app; I just like some clues as to what else I can do to make my Poweramp experience a little bit less of a hassle.

 

 

Thanks in advance.

Share this post


Link to post
Share on other sites

If you have identified this as a repeatable issue now, you could send a bug report from within the app.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...