Jump to content
CardcaptorRLH85

Strange UI Issues in 2.0.9 build 555

Recommended Posts

I'm using Poweramp 2.0.9 build 555 on a Sprint Galaxy Nexus [toroplus] running the PAC ROM 2014-05-11 Nightly (Android version 4.4.2) with franco.Kernel r396+osm0sis KK RamDisk fix.

 

Since updating to build 555, I've had an issue where the UI on the 'Now Playing' screen is distorted.  S0FGeM5.jpg  

 

I'm sorry about the quality of the picture, I had to use my webcam to take a picture of my screen since the UI looks just fine when I screenshot it.  The issue also goes away temporarily just before and after a screen rotation.  I have absolutely no idea why this is happening since it happens with all of the built-in themes and I haven't ever used custom themes with Poweramp.

 

Thanks for any help you can provide with this issue.

Share this post


Link to post
Share on other sites

Odd that a digital screenshot looks correct, but the actual physical display showing on the device is wrong - that tends to point to an OS display driver issue of some sort.

Andre

Share this post


Link to post
Share on other sites

The screenshot doesn't look right at all. Everything is compacted at the bottom. The buttons are to small, and when attempting to use them they are either unresponsive, or respond to touch around them. Can't be coincidence that we both have the exact same issue.

Share this post


Link to post
Share on other sites

Have the same issue. Very annoying. Nearly impossible to navigate.

 

Are you running a custom rom too?  I want to try ruling that out as the issue before going through the work of restoring my stock 4.3.1 Nandroid.

 

Odd that a digital screenshot looks correct, but the actual physical display showing on the device is wrong - that tends to point to an OS display driver issue of some sort.

Andre

The thing is, this started happening after I updated to build 555 and I haven't changed my ROM since I installed it.  If I have to, I'll try restoring my stock 4.3.1 Nandroid backup and I'll see if I still have this issue.  Also, I'm not having issues with the display in any other apps.

Share this post


Link to post
Share on other sites

Looks like your device selects dimensions from wrong resolution/dpi folder. Please note that new resolutions/dpi were added to Poweramp 555 to support xhdpi and xxhdpi graphics. It 100% working on various "stock rom" devices and we test a lot of them (120+ in house), those are on latest firmwares and we also test on some CM variants.

 

Unfortunately, we can't tweak it for each possible device / rom / dpi tweak out of there, mostly because that number is close infinty)) and workarounds for some of them will affect "stock" devices. Also, this is usually a bug in a ROM, and fixing ROM issue via app is wrong (usually also ROM is fixed before).

We'll check if some workaround is possible when we can reproduce your issue on one of our device.

 

Poweramp sometimes uses Android features which are not widely spread, there is only a number of apps (mostly Google's) which have xxhdpi layouts and graphics for example. Thus, we expose ROM bugs which haven't been noticed before.

 

At this moment I would recommend using some 3rd party skin (without x/xxhdpi support). I also suggest reporting on that ROM developers forum.

 

Do you have DPI tweaks or other screen parameter tweaks?

Thanks!

Share this post


Link to post
Share on other sites

Looks like your device selects dimensions from wrong resolution/dpi folder. Please note that new resolutions/dpi were added to Poweramp 555 to support xhdpi and xxhdpi graphics. It 100% working on various "stock rom" devices and we test a lot of them (120+ in house), those are on latest firmwares and we also test on some CM variants.

 

Unfortunately, we can't tweak it for each possible device / rom / dpi tweak out of there, mostly because that number is close infinty)) and workarounds for some of them will affect "stock" devices. Also, this is usually a bug in a ROM, and fixing ROM issue via app is wrong (usually also ROM is fixed before).

We'll check if some workaround is possible when we can reproduce your issue on one of our device.

 

Poweramp sometimes uses Android features which are not widely spread, there is only a number of apps (mostly Google's) which have xxhdpi layouts and graphics for example. Thus, we expose ROM bugs which haven't been noticed before.

 

At this moment I would recommend using some 3rd party skin (without x/xxhdpi support). I also suggest reporting on that ROM developers forum.

 

Do you have DPI tweaks or other screen parameter tweaks?

Thanks!

 

Thanks for the reply!  It looks like it was the ROM after all.  I updated to the May 18th nightly last night and I haven't seen the issue crop up again since then.  It looks like the issue was discovered after a few fellow Poweramp users with the same ROM also complained.  Again, thanks for the response ^_^

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...