Jump to content

PA autoplays on BT connect in the car


Recommended Posts

Same issue here with my Kenwood head unit and my Google Pixel XL.  Sure, disabling the BT button support stops the auto play....but that also disables the head units control buttons to control the player......also...disables my controls on my BT headsets.

Any fix for this?

Link to comment
Share on other sites

  • Replies 34
  • Created
  • Last Reply

If you've disabled all of the auto-play and play on connect features in Poweramp, then the headunit is probably sending a Bluetooth Play command as soon as it connects to a remote device. Have you tried asking the manufacturer if it's possible to disable that functionality?

The current alpha test builds of PA v3 added a short delay after connection before accepting BT commands, it might be worth giving that a try if you haven't already?

Andre

Link to comment
Share on other sites

I have been using "alpha-build-703-play (fullVersion) for a while and on mutiple phones. (Moto X pure and LG V10)...is there a newer version somewhere?

This auto play thing only happens with Poweramp....no other apps. Also do not have this issue on my other 2 phones...just the Pixel which is bone stock Google Android.

There is no options for BT autoplay. only auto connect but that just means i have to manual connect the phone to the head unit (Kenwood HDC-BT762HD) and Poweramp still auto plays when first connect and when i change sources, then back to BT in.

Link to comment
Share on other sites

36 minutes ago, speedingcheetah said:

I have been using "alpha-build-703-play (fullVersion) for a while and on mutiple phones. (Moto X pure and LG V10)...is there a newer version somewhere?

There is no options for BT autoplay. only auto connect but that just means i have to manual connect the phone to the head unit (Kenwood HDC-BT762HD) and Poweramp still auto plays when first connect and when i change sources, then back to BT in.

Build 704 is available from the Downloads tab at the top of this page, but I don't think any changes were made to the Bluetooth code from 703. Worth a try though.

There is an option for Resume on Bluetooth, it's in Settings > Headset/Bluetooth. However if this is turned off then something else is sending Poweramp a play command. (I'm assuming you have Settings > Headset/Bluetooth > Audio Focus > Resume on Start turned off, otherwise PA would autoplay whenever the app launches)

Andre

Link to comment
Share on other sites

4 hours ago, andrewilley said:

Build 704 is available from the Downloads tab at the top of this page, but I don't think any changes were made to the Bluetooth code from 703. Worth a try though.

There is an option for Resume on Bluetooth, it's in Settings > Headset/Bluetooth. However if this is turned off then something else is sending Poweramp a play command. (I'm assuming you have Settings > Headset/Bluetooth > Audio Focus > Resume on Start turned off, otherwise PA would autoplay whenever the app launches)

Andre

Updated to build 704.

And both of those settings are disabled. The only setting that affects this issue is "Respond to Buttons".

Link to comment
Share on other sites

3 hours ago, speedingcheetah said:

Updated to build 704.

And both of those settings are disabled. The only setting that affects this issue is "Respond to Buttons".

Then there is definitely a command coming from somewhere (presumably the BT device when it notices that it has been connected to a player) which is causing this. Maybe in future when Max next revisits the BT code he might be able to extend the period for which PA ignores initial commands sent to it? I doubt that will be any time soon though as he's got a lot on his plate.

Andre

Link to comment
Share on other sites

10 hours ago, andrewilley said:

Then there is definitely a command coming from somewhere (presumably the BT device when it notices that it has been connected to a player) which is causing this. Maybe in future when Max next revisits the BT code he might be able to extend the period for which PA ignores initial commands sent to it? I doubt that will be any time soon though as he's got a lot on his plate.

Andre

It's however Poweramp works as no other media player apps does this.....

Not a big deal, just have to press my head units pause button every-time i change to BT audio source. 

Would be great if the dev could integrate BT device connect profiles(kind alike how the EQ settings can be auto set when assigned input is used).  So when ## device is detected do not respond to first play command....though that may not stop future play commands that occur when i change head units input source and back to BT....maybe make it changeable so that Play command can be long press or double press to play.

Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...