Jump to content
Poweramp
Sign in to follow this  
fhjkalfhu

nexus 4 (mako) glitch

Recommended Posts

I keep getting random glitch sounds while using Poweramp with a custom kernel installed that has faux support. The sound is not prevalent when using any other music app, and the problem occurs on every custom kernel I've tried. Faux support is necessary since the gain on mako is very low.

I have tried adjusting the buffer and the thread priority, and also clearing the app data, but nothing solves the issue.

The only option that works is using a stock kernel without the faux feature, I'm currently on the latest cyanogenmod nightly.

Is anyone else having this issue, and is this a known problem?

Thanks

Share this post


Link to post
Share on other sites

Most probably your kernel calls audiotrack callbacks too late, so it just can't keep up with buffer. Though, longer buffer should resolve this (for a cost of worse lag). It can be also Audiotrack API broken, this sometimes happens, then sound will be broken in the same way in games.

Thanks!

Share this post


Link to post
Share on other sites

Do you have any advice how to fix it? As I said in my previous post, adjusting the buffer doesn't help. I switched to aospa and it doesn't glitch as much, but it sill does. There's no glitch on any other music app (Apollo or Google) and I don't play games, so I think it's so related.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×