Jump to content
Poweramp
trenish

Galaxy S4, gapless Bluetooth playback broken since 4.3 update

Recommended Posts

Hi there, really hoping somebody can give me a secret-sauce recipe to fix my problem.

 

Samsung Galaxy S4, recently updated itself to kernel 4.3

 

When playing techno or Pink Floyd where the songs are intended to blend together, Poweramp inserts a brief "pause" command when switching from one track to the next.  I know it's a "pause" command because my car stereo is showing the command and then it quickly disappears as Poweramp moves on to the next track.  This behavior does NOT occur with headphones plugged in. 

 

Strangely, I have seen Poweramp not insert the pause on a couple of occasions where the next track came up, but then the next couple songs come along on the gapless album and the pauses just come right back.  Having it avoid the pause is the rarity, the brief pause is the dominant behavior about 19 times out of 20 (or worse).

 

I tried messing with various lock settings, BT metadata, and even tried uninstalling random apps that I thought might have some access to Bluetooth.  The only thing that I know for certain is that this problem started immediately after my phone updated from 4.2x to 4.3.  Wish I could go back...

 

Help, please?

 

Tom

 

Share this post


Link to post
Share on other sites

Oh, here's an important clue (maybe)

 

The bluetooth pause problem NEVER happens if the phone screen is on AND Poweramp is on the screen showing the track actually playing.  It's only if the app is running in the background that the bluetooth pause is inserted.

 

Please help!

 

Tom

 

Share this post


Link to post
Share on other sites

Did you try going into the blue tooth menu and turning on the "High Priority" option.

 

And perhaps also go to Misc > Tweaks > Keep Service. This should help with the gaps appearing when the screen is off.

Share this post


Link to post
Share on other sites

I have the same problem. I updated my s4 to 4.3 yesterday and ever since then Poweramp just pauses at the end of a couple of songs and disconnects my wireless beats. My brother has the same issue as well. I have tried every setting I can on power amp to fix this issue with no success.

Share this post


Link to post
Share on other sites

I, too, would like this issue fixed. One of the reasons I chose Poweramp for my music player is because of the gapless. I was kind of disappointed to find that it doesn't work for bluetooth unless you keep the app running in the foreground without shutting off the screen.

Share this post


Link to post
Share on other sites

Poweramp sends next track data immediately, there is no gap. It seems it can be introduced by BT stack, we'll investigate (though S4 gets 4.4 kitkat update now, and I can confirm there is no issue with Gapless on 4.4 @ S4 - as tested on euro S4 + Poweramp-build-550). 

Thanks!

Share this post


Link to post
Share on other sites

None of the stuff anybody mentioned fixed my problem.  However, my phone received the Kitkat 4.4 update this morning.  Here's a quick recap where Bluetooth, the Galaxy S4, and gapless playback are concerned:

 

Android 4.2 = win

Android 4.3 = broken

Android 4.4 = win

 

As a nice bonus, 4.4 is also now pushing a progress bar to my car stereo screen indicating time elapsed / remaining for the track being played.

 

For the sake of 4.3 users out there, I hope you guys take a look at overcoming the bad behavior of the BT stack.  For what it's worth, I tried another player and it didn't have the problem with pausing, but the UI was totally inferior.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×