Jump to content
Poweramp
kchasse

Play/Pause issue with Mazda Bluetooth

Recommended Posts

I have seen some other issues with Mazda Bluetooth integration, but none describe this exact issue.  I'm not even positive it is a Poweramp bug, but it might be or there might be a way to workaround in the settings.

 

Phone:

  • Samsung Galaxy S3

  • Android Version 4.1.1
  • Stock ROM from AT&T

Poweramp:  v2.0.9, build 525

Mazda CX-9 - 2013

 

The issue is this:  When I change tabs on my Mazda screen, it is supposed to pause playback by sending a pause to the player.  What happens is different if Poweramp is in the foreground or running in the background:

  • If running in the foreground, it pauses for a second, then resumes playing for 5 seconds, then pauses for good
  • If running in the background, it puases for a second, then resumes playing forever in the background.

 

When I return to the Bluetooth tab on my Mazda screen, it sends another play/pause message and either resumes music (for scenario 1) or pauses it (for scenario 2)

 

I have tried several headset and audio focus setting to no avail, but perhaps there is a setting combination that might work that someone can suggest.

 

I recognize this may be a Mazda bug (but it works perfectly with default player) -- but since the behavior is different within Poweramp between if it is running in the foreground or not.  By the way, I'm OK with the result in the foreground scenario, even though it is weird it puses for a moment and then plays for about 5 seconds and then pauses again on its own.

 

Thank you in advance.

 

Share this post


Link to post
Share on other sites

I'm having a similar issue.  When I try to fast forward past a song using the bluetooth steering wheel controls in my Mazda-3, the fast forward takes place but then Poweramp pauses.  Getting music to play again requires accessing the phone player controls directly.  Other music apps I've tried - stock Samsung music player, Google Play, Pandora, TuneIn Radio - all fast forward and continue to play without a problem.

 

Phone:

 

  • Samsung Galaxy S3In
  • Android Version 4.1.1
  • Stock Rom from Sprint
  • Poweramp Build 529

Share this post


Link to post
Share on other sites

I had the same issue with Samsung Galaxy Note 2, v4.1 with 2012 Mazdaspeed3.

 

I just upgraded my Note 2 to android v4.3 with MK4 Modem.  Now, the behavior is a little different (and a little better):

 

  • When the display is on, it appears to work properly.  By using the radio controls in the car, I can change songs without pausing.
  • When the display is off OR Poweramp is not in focus (playing in the background), it randomly pauses like it used to with the Android v4.1.

 

At least I feel like I can use my favorite player again.  However, I wish it were working 100%. 

RocketPlayer is a good alternative that works great with Mazda.  I guess I'll stick with Rocket Player!  :(

 

Poweramp:  v2.0.9 build 539

Phone: 

  • Samsung Note 2 (Sprint) SPH-L900
  • Android: v4.3
  • Baseband Version: L900VPUBMK4
  • Kernel Version: 3.0.31

Car:  2012 Mazdaspeed3 with Bose system

 

Thank you...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...