Jump to content
casinero.triste

Some files' ReplayGain don't work, what did I do wrong?

Recommended Posts

In foobar2000 I scaned all my files' track gain and they do all sound equally loud in foobar2000.

But copied into the phone, some of them just sound much louder in Poweramp.

I'm sure that songs are correctly updated onto the phone, and also that I've set the option as applying track gain.

So what did I do wrong? Any help appreciated.

And if this helps, it's ok for me to provide my files to you developers for analysis or something like that.

Just don't want no more sudden-high-volume-songs piercing into ears while jogging...

Share this post


Link to post
Share on other sites

Poweramp seems to use some sort of non-standard ReplayGain tag parsing. I don't see it working for me either.

There are threads in the forum, you could try them, but for me it doesn't seem to work as it does on JRiver Media Centre on my desktop (same file, or transcoded file)

Share this post


Link to post
Share on other sites

OK,

For one of the files you have used Foobar on to calculate and apply replay gain:

Show the file in Foobar, right click -> Properties -> Properties Tab

Do you see a ReplayGain heading followed by values for Track Gain and Track peak?

Share this post


Link to post
Share on other sites

Yes.

I don't know how to upload images therefore I can't show you snapshots of my screen.

A few minutes ago I copied files to the phone again and then did "full rescan" in Poweramp.

(I'm not sure about the exact wording in english because I use traditional chinese UI.)

Still no help.

Share this post


Link to post
Share on other sites

What types of files are you using (mp3, m4a, flac ...)?

A rescan isn't necessary as far as I know, Poweramp uses the values it finds when it starts playing the track.

Share this post


Link to post
Share on other sites

Right, let's find out what's going on.

First, select one of your mp3 tracks without replay gain tags in it - make sure it doesn't have itunes tags in it either as these can be used by Poweramp too.

Make a copy of the file. Name one WithGain.mp3 and one NoGain.mp3

Apply Replay Gain using Foobar to WithGain.mp3

Under Replay Gain settings in Poweramp set RG preamp to 0 (near enough will do). Set Preamp for songs without RG to its lowest setting.

Put both tracks on your phone and rescan.

Make sure Apply Gain is set and Source is Track

Play both tracks one after another - do you hear any difference in loudness between the two?

Share this post


Link to post
Share on other sites

No, no difference between these two as I can tell.

And with this setting (Preamp for songs without RG changed from 0dB to -16dB, which is the only difference from my original settings), the four files which sounded much louder now sound slightly lower than other files. I might live with this, at least they're not piercing now. Still don't know if this is the way things should work though.

Share this post


Link to post
Share on other sites

Right, from this we know that Poweramp is definitely not reading the tags on that file as it is attenuating the files it thinks have no tags.

Is there any way you can put one of the files you have added tags to somewhere so I can have a look at it?

Share this post


Link to post
Share on other sites

Right, I see now -

The "Geek In The Pink" track uses APE tags whereas the other uses id3.

It looks like Poweramp does not recognise the APE tags, these are a very old "standard" - so is not applying replaygain to these files.

In fact, when I looked at the tags of the files under mp3tag I could not see the replaygain as it does not like APE tags either.

I had a quick look at how to fix this but could not find anything obvious to convert the tags - but now you know why so I'm sure you can find a solution.

Share this post


Link to post
Share on other sites

×
×
  • Create New...