Jump to content
Sign in to follow this  
Erikm88

Album disc number

Recommended Posts

I have this really annoying problem that my album disc numbers are not recognized.

Now all my songs from the same album, but from various discs, with the same track number follow each other up directly.

Is this a missing functionality in Poweramp, or am I doing something wrong in my mp3 tags?

If you have the answer, please tell me cause it's driving me nuts! <_<

Share this post


Link to post
Share on other sites

I am also having this issue.

A multi disc album is not displayed correctly in Poweramp. I use the disc # of # ID3 tag option in iTunes which should put the tracks in the following order:

Track 1 disc 1

Track 2 disc 1

.

.

.

Track 1 disc 2

Track 2 disc 2

..etc...

This is not recognised in Poweramp. Poweramp shows the following:

Track1 disc 1

Track 1 disc 2

Track 2 disc 1

...etc...

I can confirm that Google Music can read these tags correcty, along with 'Music' on my iPad. This is unfortunate as I love Poweramp's functions, but this limits my ability to use the app for a double album.

Is there a solution available that does not involve renaming the album titles in iTunes to "Album name (Disc 1)" etc?

Is there a problem that I sync my music using iSyncr over wifi. iSyncr creates only 1 folder per album (ie does not make the distinction between disc 1 and disc 2)?

My file structure is

Music/Artist/Album/1-01 Track 1

Music/Artist/Album/1-02 Track 2

.

.

.

Music/Artist/Album/2-01 Track 1

Music/Artist/Album/2-02 Track 2

...etc...

Poweramp should be able to recognise the 1-01 etc?

I can see this is a common problem, the above poster has this issue, as does this user from 2011 http://forum.powerampapp.com/index.php?/topic/829-id3-tag-disc-not-recognized/page__hl__disc__fromsearch__1

Any advice appreciated!

Share this post


Link to post
Share on other sites

2 solutions:

1) Check your ID3 tags, make sure they're updated to ID3v2.3 - some of my albums sorted correctly after this. (also check the tags and ensure the discs are tagged correctly

2) within an album, hit the menu button, then list options and choose 'by file name'. This fixed the remaining albums as I have 'keep music organized' ticked in iTunes all my double albums are 1-01 1-02...2-01 2-02 etc...

Sorted. :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...