Jump to content
Poweramp
imrang

Galaxy S3 and Mazda 3 Bluetooth: Next track car control causes "PAUSE" on the next song

Recommended Posts

Hi Guys:

I hope you can help me with this absolutely infuriating problem. My Mazda 3 music via Bluetooth is paired with my S3 and I am using Poweramp. I have all the headset settings enabled and audio settings.

However, when I hit the "Next track" control on my car steering wheel, power amp switches to the next track correctly, but immediately pauses playback on the next track! Why does it do that?

(I have the pause setting set only for soft pause for navigation etc..)

There is no issue with the iphone or when using Winamp. This is a phenomenal product...but it's really killing me with this one issue.

Regards,

Share this post


Link to post
Share on other sites

Exact same problem here, Verizon Galaxy S3 and a 2012 Mazdaspeed3. Bluetooth connects fine, quiality is good, sends the the metadata, controls all work from headunit, but skipping to the next track causes it to pause also. Infact, if button beeps are enabled, you can hear can hear it beep twice when you hit the next button as though it is sending two commands. Have extensively played around with the settings in Poweramp to no avail, as well as trying disabling other apps. The only time it does not seem to do this is if the current song has been playing for quite a while, then sometimes it will let me skip without also pausing. Any help would be much appreciated.

Share this post


Link to post
Share on other sites

I too am having this problem with Poweramp and my 2011 Mazda 3. I bought the car last week. The first day or two I did not have this problem, but since then, anytime I skip to the next song, Poweramp pauses at the start of the next song and I have to press Play on my stereo. This does not happen if I am playing music through the Galaxy S3 stock music player or through Slacker Radio. I have tried changing various settings in Poweramp to fix this but cannot figure out how to do so.

Share this post


Link to post
Share on other sites

Hi there,

Same problem with my 2012 Mazda 3, the tracks pause immediately after switching tracks with the car controls. Switching two tracks causes it to pause twice or something and gets you playing again. This doesn't happen with the stock music player, but that thing sucks compared to Poweramp. Phone is a Samsung Galaxy S3 running ICS 4.04.

I've also noticed some oddness with pause and the car's dash display. Haven't narrowed down the steps to reproduce, but it will get into a spot where the car thinks the music is paused and displays "PAUSE", but the phone is playing and seems fine.

Not sure if there's a debugging mode I can turn on and send you guys logs of what commands the car is sending, but if there is such a thing, let me know

Thanks!

Share this post


Link to post
Share on other sites

Hi guys

I have similar issues with my Samsung Galaxy S3 (stock ROM ICS 4.0.4) with latest Poweramp v2.0.7-build-513 and a Mazda 6 Bluetooth Radio.

First of all, Poweramp is a great player and I use it also for my music and audiobooks. I tried different players and for Bluetooth Audio I did not find a better one than Poweramp!

Unfortunatelty there are some small bugs, I am sure No. 2 was not present in former versions of Poweramp:

1. After Bluetooth is connected, the Audio starts (even if I disabled "Start on A2DP connection" or "Start on headset connected")

2. After a few seconds, the Audio stopps and I have to press play again. In a few cases, the Track position is lost and the track starts from the beginning. This is very annoying for listening audiobooks, because most of the time I have one 7 or 8 hour file!

The Buttons for Skip and Play are working great and the ID3 Tags are also correctly displayed.

Thanks for your great work

Share this post


Link to post
Share on other sites

I'd like to bump this;

I have a 2012 Mazda3.

I have an unrooted, stock AT&T Galaxy S3, SGH-i747.

I bought the full version of Poweramp, fully updated.

I really, really like this app. It is the best music app I've tried thus far.

BUT this bluetooth issue is nearly a dealbreaker (kinda sorta).

Whenever I try to skip a track using the car buttons, the track skips, then immediately pauses. There will be times where the playback will be normal, but the bluetooth screen on the Mazda displays 'Pause'.

Please please get this sorted out. I check back here and the playstore everyday, just to see if theres been any kind of updates or acknowledgements.

Thank you for the great app and (what I'm sure will be) great support!

Share this post


Link to post
Share on other sites

I have the same issue (samsung galaxy s2x and 2012 mazda3). It seemed to work fine for awhile (ie April) the music would start playing when I got in the car. I got ice cream sandwhich for my phone and the song would come on, play for a second, go quite then start playing when i got in. I thought this was strange but it kept working. It might have been after a Poweramp update a little while ago (a few months maybe?) when it wouldn't start at all when it connected. it says pause on the screen media screen in the car. if I hit play, it sometimes starts playing again, but starts the track over at the beginning instead of continuing! once i finally get the music playing (sometimes it takes a few attempts at hitting 'play') it pauses when I skip to the next song. it used to stream seamlessly into the next one, but now it just cuts off. Please get this fixed!

thanks!

Share this post


Link to post
Share on other sites

I have a Mazda 3, Galazy S3 LTE and have none of the issues above. Everything works except the track length/time which is not displayed. Stock music player shows track time/length without issue.

Share this post


Link to post
Share on other sites

This issue might have been an ICS issue... I went to a Mazda dealership and tried it out with Jelly Bean and didn't experience the bug, so I do not know exactly where the problem stems from and due to the many changes Google has made between GB to ICS and ICS to Jelly Bean.... It's hard to figure this one out!

Share this post


Link to post
Share on other sites

Am currently running the Verizon sourced VRBLI5 Jelly Bean ROM, and am still having the same issue. Numerous AOSP ROMs have yielded the same results. Will be trying VRBLJ1 soon, but am not holding my breath. FWIW, am using another player at the moment that sends the Meta DATA properly without pausing when changing tracks. As a bonus it can control repeat and random from the headunit. Will gladly return to Poweramp when the issues are sorted out.

Share this post


Link to post
Share on other sites

Same issue here. Very annoying. Hard to believe this cannot be fixed. 3 other music players (incl. stock) work without this issue.

Share this post


Link to post
Share on other sites

I just downloaded Jelly Bean 4.1.1 update and newest Poweramp and am still getting the same error where the track will pause on track seek from car controls. This bug is extremely frustrating as I thought it would be gone when the Jelly Bean update came. Anyone have a fix yet?

Share this post


Link to post
Share on other sites

I just started using trial version of Poweramp...and everything is great except for this issue. Is it really just us mazda3 people having this problem? This is a dealbreaker for me because I use my car controls to advance through tracks while driving.

Have there been any solutions found? Any news from the devs on getting this fixed?

I won't buy the app at the end of my trial period if this isn't fixed. Too bad...seems like a good player...

Share this post


Link to post
Share on other sites

<bump> I have the same issue with Samsung Galaxy S2 (4.0.4) and my Mazda 3.

Share this post


Link to post
Share on other sites

<bump> I have the same issue with a Motorola Droid Razr M and my Subaru Forester. I am still waiting for a working link to an earlier version so I can go back to an earlier version that works.

Share this post


Link to post
Share on other sites

i have the same issue with my 2011 mazdaspeed3. it used to work perfectly until last year after one of the updates. im using a droid 4 on jellybean. sucks too because i was so happy when Poweramp started showing the track info on the car screen and then this happened. which made the player go from perfect, every function i needed to crippled.

Share this post


Link to post
Share on other sites

Same issue here.  I'll give all the info I can to help the devoloper(s) fix it.

 

Mazdaspeed3 - 2012

 

Phone:

  • Samsung Galaxy Note 2

  • Android Version 4.1.2 
  • Perseus Kernel
  • I've tried multiple ROMs and Kernels, so I don't think that is the issue.

 

Poweramp:  v2.0.9, build 525

  • I've tried multiple variations of the headset settings without luck.
  • The last couple of versions of Poweramp also had the same issue.

 

I've tried many other players; Poweramp is just the bestPlease fix this issue...

 

Note 1:  I've tried other players and they all appear to work okay with ONE exception, google cloud player (I think that is what's it called).  That player when next song is selected turns off shuffle.

 

Note 2:  I use other bluetooth headphones (R36 bluetooth dongle) and Poweramp appears to function perfectly.  Also, changing songs with my Pebble watch appears to work perfectly.

 

Note 3:  Also, when I change tracks, it does change to the next song, then it pauses.

Share this post


Link to post
Share on other sites

K so after getting frustrated with the problem I believe I have located where the problem occurs. The application seeks next track in my mazda with the controls no problem if i have Poweramp up on the phone but as soon as the phone times out and locks itself that is when the problem of seeking to next track causes a pause. I tried to remove the lockscreen swipe screen lock and set it to "none" and re did the same test letting the phone time out and sleep itself. Once it was off I tried to seek to next track and this time Poweramp did not pause my seek. 

 

Somewhere in the code for this app and the way it takes the lock screen is causing it some kind of hiccup and is pausing on seek. I hope this issue can be fixed as I have put up with it for a very long time now. Please I hope a developer reads this and looks into it. I love the application and refuse to use anything else but this problem is such a headache and a pain sometimes

Share this post


Link to post
Share on other sites

Well I just bought Poweramp because of its legendary sound quality, except that I own a mazda 3 2012 and my jelly bean galaxy S3 stupidly pauses every time I hit skip track... My other players work fine but they either do not display the meta data or the sound is crap...

I can't really believe that the bug is still present...

Share this post


Link to post
Share on other sites

Bump, reported this bug a long time ago via email to them, and they gave me a bunch of nonsense stuff to try but to no avail, due to their lack of support I uninstalled, furious that a paying customer would be brushed aside like a stray leaf, good to know many months later I'm trying it again and alas STILL no word and no fix, what phone we have isn't the issue, and as I myself use a RAZR max,. It's these guys who need a lit coal dropped in their pants. I wait for a fix, but don't expect one. Buyers regret ftw.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×