Jump to content
Poweramp
chucka82

Losing track position while pausing/resuming with headset

Recommended Posts

Hi!

I listen to podcasts a lot on my phone and files are usualy 1 hour long.

I use the headset button to pause / resume and with the latest version, when I resume, maybe 1 time out of 5 the track will resume from the beginning.

I'm on AOKP and would like to test previous build to see if my issue is Rom related but I can't seem to find download links other then the current or the old 1.4 version.

Regards,

Charles

---

Workaround: Go to Settings --> Misc --> Tweaks --> Keep Service.

Share this post


Link to post
Share on other sites

I'm really glad you posted this. I came here searching for the same thing. I've been having this same problem with the latest version, and I wondered if it's specific to my ROM. I'm running JBSourcery, so it's gotta be the latest version of Poweramp that is the problem. I have noticed that this happens if you pause while the screen is off. If the screen is on and you pause, it will resume in the correct position.

*edit - Galaxy Nexus, JBSourcery 2.3. Never had this problem with previous versions and I've been using this app for a very long time.

Share this post


Link to post
Share on other sites

Glad to see I'm not the only one.

Hopefully this will be fixed soon.

My phone is a Galaxy SIII by the way.

Very strange, I also have Jelly Bean on my GS2 and N7 and don't seem to be experiencing this issue. Does it only happen with long files/songs/podcasts? I don't listen to anything longer than 6 minutes, so maybe that's why I don't experience this.

Share this post


Link to post
Share on other sites

I've seen something similar, but only once in a blue moon and I put it down to finger trouble on my part at the time (and yes, this would have been with longer files).

Andre

Share this post


Link to post
Share on other sites

I rarely listen to anything else than podcasts lately so I couldn't say.

furious78 mentionned that it could be related to the screen being off or maybe some kind of sleep state.

Share this post


Link to post
Share on other sites

I'm seeing this too, on my Galaxy Note. I generally use Poweramp exclusively in my car, via bluetooth connection (Ford Sync). My Note is running ICS.

It appears that this 'restart track at the beginning' happens if the phone is locked (mine is locked with a passcode). I've also tried this with the phone unlocked (and the Poweramp screen up) and the track doesn't reset to the beginning. With the phone disconnected from Sync, hitting Play resumes the track from its current position.

I'm not sure when this behavior started, but it's pretty recent - probably with the last Poweramp update.

Share this post


Link to post
Share on other sites

Very strange, I also have Jelly Bean on my GS2 and N7 and don't seem to be experiencing this issue. Does it only happen with long files/songs/podcasts? I don't listen to anything longer than 6 minutes, so maybe that's why I don't experience this.

I'm seeing this behavior exclusively with regular old song tracks of varying lengths. I also wonder if it's specific to bluetooth headset buttons versus wired.

Share this post


Link to post
Share on other sites

I have also had this happen a few times, with normal length (< 6 minutes) songs (mp3's), and using a wired headset. Galaxy Note ICS 4.0.3 (stock Samsung ROM)

Share this post


Link to post
Share on other sites

I'm having the same issue when listening to podcasts. I will hit pause and when I come back to hit play it starts on a different song/podcast. I hope this issue is resolved soon.

Share this post


Link to post
Share on other sites

I confirmed that this happens with wired or BT headsets.

Screen on/unlocked (or screen on/locked): hit pause button on headphones --> music pauses and resumes as expected

Screen off/locked: hit pause button on headphones --> music stops, starts over at beginning of track

I only have 'slide to unlock,' no PIN, pattern or face unlock. Also tried with ICS-style lock screen widget enabled and disabled.

Share this post


Link to post
Share on other sites

I just wanted to report that I am also experiencing this issue, in case you needed more problem examples. It has been a recent development, and it does seem to be related to the screen being locked. I was able to replicate what furious78 said exactly.

I keep forgetting that this happens and I pause with my bluetooth headset; then I have to figure out where I was in Supper's Ready :)

Share this post


Link to post
Share on other sites

After seeing that the latest update from yesterday didn't fix the problem, I thought I'd try clearing data since I'm always restoring from backup as a crack flasher. Anyway, that didn't resolve the problem.

Share this post


Link to post
Share on other sites

Wen/Max, do we have some acknowledgement on this particular issue? I'm wondering if this is something you're working to resolve. Thanks!

Share this post


Link to post
Share on other sites

Wen/Max, do we have some acknowledgement on this particular issue? I'm wondering if this is something you're working to resolve. Thanks!

Please send a report in to customer service because I can't seem to recreate this issue regardless of the length of the track. Sorry I couldn't be of better help.

Share this post


Link to post
Share on other sites

That's a bummer... this is the latest version in Google Play which I received a few days ago, and it didn't fix the issue for me.

Same here. I got that update a few days ago. It didn't help.

Share this post


Link to post
Share on other sites

Please send a report in to customer service because I can't seem to recreate this issue regardless of the length of the track. Sorry I couldn't be of better help.

My wife has Poweramp on her Droid RAZR MAXX with stock install (runs ICS). She does not have this issue. That had me thinking that maybe stock and/or ICS might help, so I loaded stock JB for my Galaxy Nexus first and then the last ICS ROM that I personally ran which was AOKP Milestone 6. Both of these installs still gave me this experience of not resuming the song track where I left off. Neither of these roms had this problem at the time I used to run them, but these were with older versions of Poweramp. Since two updates ago, no matter what rom I load, I have this issue. Apparently it affects some and not others.

I'm not sure what reporting this to customer service would accomplish. I have exhausted all troubleshooting measures except for rolling back to a previous version. Where would I get access to that?

Share this post


Link to post
Share on other sites

Getting this problem as well since the last update. I use bluetooth, never a headset, the last track starts from the beginning when I reconnect. I also occasionally get the playlist unloaded as well (happened twice today).

Running a custom Samsung based ICS ROM on a SGSII. I originally thought it was related to the ROM or kernal as I changed them around the same time as the last update but I thought I would check here as well.

I will try keeping the service loaded when idle and see if that helps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...