Jump to content

Cannot add to playlists

Recommended Posts

Hi I am new here but been using Poweramp for a while.  I have a Chinese google head in my car with Poweramp running on it.

I have been trying to import some playlists, which where made within Poweramp on my phone, I put a folder named Playlist_Manager in the same directory as my music and ran a rescan and it found the playlists. When I try and add to them playlists it say I have to give access to that folder which i do through the filing system but still not let me add to them playlists.

Any help would be great because i want to keep my playlists the same on both devices and update them on a regular basis.

Thank you for any help


Link to comment
Share on other sites

It sounds as though you have got read access to your music folder (and hence all of its subfolders, such as your playlists in the 'Playlist_Manager' folder) but not write access for editing/deleting/etc. One way to check would be to try to delete a song file (after having made a copy first obviously) and see if that works. Might be worth disabling storage access in the Music Folders menu (so zero songs in Library) and then granting access to your main music folder again. You don't say which Android version your headunit is running (sometimes they are quite out of date) but I'd start with Legacy File Access Mode turned OFF.


Link to comment
Share on other sites

Hiya tried what you said but nothing - took the sd card completely out and put back in.

Its Running Android 10 and will not let the sd card have access unless i have file access legacy mode on, I will try and add some pics of when I try and add a track to a playlist. 

Any help is much appreciated





Link to comment
Share on other sites

So go to the link and download on my head-unit.

I have also just checked my Samsung phone which is android 11 and that will only find the sd card with Legacy File Access Mode switch on and my Samsung tablet with android 11 is the same

Link to comment
Share on other sites

Hi Andre

Still no luck on the Head-unit, On my Samsung phone & tablet I have change the filing from root to a folder on SD card and everything is great and working as it should without using Legacy File Access Mode.

On the head unit I have installed the latest firmware which I got from the manufacture (Joying) but I still have to use Legacy File Access Mode & still will not write to music folders, I have also change from root to a folder.  

Pulling my hair out.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...