Jump to content

"No lyrics found" when shuffle-playing music in Folders Hierarchy

Go to solution Solved by andrewilley,

Recommended Posts

When shuffle-playing songs from the Folders Hierarchy that are in a sub-folder of the folder being played (e.g. you play the folder /music/flac/ and a song located in /music/flac/foals/ plays) many components of the new lyrics system (which is nothing short of incredible and beautiful btw) become very broken. I consistently observe the following things when the bug occurs:

* Lyrics fail to load / "No lyrics found"

* Blurred background for lyrics screen fails to load / is black; normal background blur continues working fine

* Lyrics Swipe Up takes you to the lyrics screen (showing "No lyrics found") if the now playing song has lyrics, even when it's set to only show When local lyrics available

* Lyrics Button takes you to the lyrics screen (showing "No lyrics found") if the now playing song has lyrics, even when it's set to only show When local lyrics available. Additionally, the lyrics button would sometimes disappear if I returned to the main screen by tapping on the minimized player

* The wrong track info + cover art typically shows at the top of the lyrics screen; sometimes the top section is completely missing

Here's a setup to consistently reproduce this bug:

1) Navigate to Folders Hierarchy library view in Poweramp

2) Stop at a folder that does not directly contain songs (move songs a couple layers deep if you don't use folders)

3) Shuffle-play the folder you stopped at.

4) If needed, skip tracks until you land on one that is supposed to have lyrics (embedded or LRC)

5) Use any enabled method to access the lyrics screen

Usually, the bug can be fixed by either playing music via another category (such as All Songs) or by restarting the app.

I first experienced the bug on the following system:

* ZTE Axon 7 Mini, Android 7.1.2, LineageOS 14.1, running Poweramp build 952

But I was also able to re-create this bug on the following:

* OnePlus 5, Android 12, LineageOS 19, running Poweramp build 953

Attached below (hopefully) is a video recording demonstrating me re-creating this bug with a fresh install of Poweramp and two tracks in my library for simplicity (I trigger the bug at 0:45).



Link to comment
Share on other sites

I tried this a few ways (LRC file/embedded/etc) in my test folder as per your methodology, but I couldn't replicate it.

Then I tried enabling Settings=>Library=>Shuffle=>'Shuffle All Songs in Folder Hierarchy', and when a song which had lyrics started playing I could reproduce the bug as per your description . Could you try turning this option off and see if the problem still occurs for you? 


Link to comment
Share on other sites

Thanks! This is the only bug I've encountered with Poweramp beyond tiny visual glitches (and a library data reset which I believe has been discussed on this forum already).

I tested it on my original device and yes, turning off Shuffle All Songs in Folder Hierarchy (I just noticed that the setting is named "Folder" instead of "Folders" as it appears elsewhere) prevents the bug from occurring.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...