Jump to content

Navigating library hanging / folder artwork issues


Frank D
 Share

Recommended Posts

Hi all,

New to Poweramp - just picked it up to replace the forever buggy default app on my Fiio M11 player. I'm generally enjoying the app when it works properly, but have a few odd issues to report that almost render it unusable for me. Did a bit of searching and coming up empty on specific solves (probably not searching the write terminology), so any help would be deeply appreciated in advance! 

I have two 1TB SD cards in good health, with 210,000 songs or so across the both of them. All MP3s, all tagged well, in good shape to my knowledge. Here are the issues I'm having: 

Issue #1 - Navigating through the Library is very slow/buggy for me. Often, the app hangs when attempting to jump around to Artists or All Songs, for minutes on end. Often, the only fix is to force close the app, re-open it, walk away for a few minutes, and then come back, and it'll work until I close it or add some music and rescan, and then it's back to this lag for a bit. I did just turn off auto-scan for now, which should help in theory, but it STILL took five minutes or so before I was able to navigate or play music, and even now, it lags a bit when trying to check out my most played, recently added, or top rated tracks. Is this due to the size of the library and I just have to do my time and wait? Or is there something else afoot? 

Issue #2 - Even though my files have the correct album artwork attached in the metadata, the scan pulls up different artwork from time to time for the folders, which is weird. While I am easily able to change the artist photo via the scraper and it sets, re-setting the album folder artwork doesn't take, even if I select the correct artwork. It lets me choose the proper artwork as expected, but once selecting it, the folder cover stays the same.. I'm attaching three pics of the process - the wrong cover in the artist view first, the wrong cover showing while the correct cover shows in the metadata second, and then the correct option when trying to select the cover third. Once selecting the correct cover (I chose the first option in the upper right, though have tried all of them), it does not save, for some reason. 

Issue #2 is really not a dealbreaker but does irk my OCD aesthetic sensibilities, but the first one is a bummer so far. Thanks for the help, hope to solve these things soon! 

01.jpeg

02.jpeg

03.jpeg

Link to comment
Share on other sites

210,000 songs / 2 TB is a huge amount for an Android device to handle - and FiiO's Android is not very standard anyway - but as long as there aren't too many files in any one folder it should still be possible to navigate, although the 'All Songs' category list could be a challenge! Rescanning could take some time though, and a Full Rescan (which has to read the tags from every individual file) will take a long time - maybe an hour plus.

As a test, could you try enabling just a subset of your Library (perhaps one artist folder and its subfolders for example, so just a few hundred song files) and see if that improves the situation?

Artwork wise, check that there aren't any image files in your music folders or subfolders. These two FAQs might help understand how the image selection process works:

You could even try deleting the contents of the cache folders and starting from scratch if you want (you can copy in an out of those folders as you wish).

Andre

Link to comment
Share on other sites

  • 2 weeks later...

Hi Andre,

Thanks for your response! For the first issue, I've found that turning off rescan every time I open the app and just giving it a few minutes here and there really helps things, so I'm using the app now with no issues more or less. 

The artwork thing remains an issue though - I've done a full rescan and still those particular releases show the wrong artwork. I haven't checked all my files to see if this is happening anywhere else, but it appears that the issue is this: an album called Borderline by No Tears exists, as does an album called 13 by Lee Hazlewood. While the artwork for these releases under the band Asylum Party is correct in the tags (as you can see in the Borderline photo, this art is what it should be), the app wants to take the art from Lee Hazlewood/No Tears instead of what's embedded. Any attempt to change it doesn't take, even when manually selecting the correct artwork. As such, this seems to be a bug to me, since all the files have the proper embedded artwork. Any suggestions? 

Link to comment
Share on other sites

Yes, as your library is so big, once it has been scanned and is correct I would suggest turning off the Auto Scan mode in Settings=>Library=>Scanner, and only do a manual rescan when you add new content.

Stored/cached/manually downloaded images will override any embedded ones. Check in the artwork cache folders, as per the second link that I provided above, to make sure that there isn't an item savedfor this album, and if there is delete that image file.

Also one of your screenshots above shows the Artist image page, not the Album one, which is created separately to album covers.

Andre

 

Link to comment
Share on other sites

Hi Andre,

Sadly there is no downloaded/cached artwork that is overriding here. I checked the cache folder and there is nothing to be found that matches those images. Below I've attached a screenshot of the android-data-.com_maxmpz._audioplayer_selected_artist folder. It just has the one James cover in there, but nothing else. 

Maybe I'm not explaining the issue too well. What's happening is this: because there are two albums in my collection with the name Borderline (one by the band Asylum Party and the other by a band called No Tears), Poweramp is defaulting to showing the No Tears - Borderline cover for both No Tears AND Asylum Party. Same with Lee Hazlewood, as he has an album called 13, and there's also a compilation called 13 that should have the white cover with the numeral on it.

Lee and No Tears have the proper album artwork embedded in the file, as does Asylum Party's Borderline and the 13 compilation (which you can see above)... Poweramp just seems to be defaulting to one cover for an album of the same name, regardless of who the artist is. What's especially annoying is that when I try to change the image to the correct one, it doesn't take as it should. 

Also attaching a video of this behavior so you can see what I mean. Thanks otherwise, for chatting this through! 

Screen Shot 2023-01-22 at 12.21.40 PM.png

Link to comment
Share on other sites

I'm surprised how little is in the artwork cache folder, are you sure you are looking in the correct folder for your Android version? See the FAQ I mentioned earlier, for recent versions of Android the com.maxmpz.audioplayer folder name should NOT have an underscore at the start, even if a legacy version with the underscore may still exist.

Also, do all your files have the Album Artist tag properly populated, or just Artist?

Andre

Link to comment
Share on other sites

Yes, I'm positive it's the right folder - I just didn't type the full name out here. There are other folders that have the artist images I've swapped out. 

Not all files have album artist tag sorted - would that make a difference in this case for separating? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...