Jump to content

The music stops when the app is in the background


rychu9191
 Share

Recommended Posts

Hi 

I have navigation running and once in a while when music plays in the background and I receive a notification in the navigation, the playback stops, after going to the menu of available applications, the sound returns. Is there a way to change something in the settings of the player so that the sound doesn't stop?

 

 

 

Link to comment
Share on other sites

  • Replies 32
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

1 hour ago, andrewilley said:

Have you tried using volume dipping for notifications? In PA Settings=>Audio=>Audio Focus=>Duck Volume.

Andre

I didn't change anything in the settings. it's not that the music is quieter, it's that the music is completely turned off.

Link to comment
Share on other sites

This issue is related to build 945, I do experience it too, once in a while, the music will just stop, I will think I have a notification or sleep timer on, but nothing like that. 

Somebody may suggest excluding Poweramp from being killed by battery saver app, but I don't have anything like that turned on.

Poweramp will not report it was killed, the music just stops playing as if it was paused. 

I can not say it's related to RAM, I have 8 + 2. My Samsung galaxy m51 hardly reaches 4.2 RAM used. 

Bencherished 

Link to comment
Share on other sites

the application is always active (battery saving settings turned off) even when it is in the foreground I noticed that the music stops for a moment and starts again but there is no sound, pausing the start and changing the track does not help only entering the application menu restores the sound.

Link to comment
Share on other sites

14 hours ago, Bencherished said:

Oh, I see, what you are describing now is different from what I thought. 

Are You using AAudio output? And you've selected 96KHz sample rate? If this is the case, try Hi-Res output instead, and select a sample rate that matches your files.

I haven't changed anything in general, where can I change it in the settings?

Link to comment
Share on other sites

4 hours ago, rychu9191 said:

I haven't changed anything in general, where can I change it in the settings?

PA Settings=>Audio=>Output.

First restore to defaults, and then try using different output methods such as Hi-Res, AAudio, Audio Track, etc. Each one can be enabled separately for outputs to Speaker, Wired Headset/AUX, Bluetooth, USB DAC, etc.

Andre

Link to comment
Share on other sites

On 12/6/2022 at 9:57 AM, rychu9191 said:

 

I have navigation running and once in a while when music plays in the background and I receive a notification in the navigation, the playback stops, after going to the menu of available applications, the sound returns. Is there a way to change something in the settings of the player so that the sound doesn't stop?

 

 

 

Navigation apps mostly make use of your audio output to communicate the direction you ought to go. 

Whenever an app requests to use the Audio channel, Poweramp is set up to respect it,in which case, it will pause, or stop completely. 

This option can be changed in Poweramp settings according to your preference.

Go to Poweramp settings- in settings, enter Audio, in Audio, enter Audio Focus. 

In Audio Focus, I think you should disable Short Audio Focus Change/ Calls.

But don't forget, this may make it difficult to hear your caller, and your caller hearing you during phone call. 

Give it a try.

Bencherished 

Link to comment
Share on other sites

36 minutes ago, andrewilley said:

@rychu9191 So are you now saying that your Poweramp installation is actually on a car head-unit?

Andre

I think that is what he is saying, good thing I asked. I think the issue is with the navigation voice assistant, Poweramp have to pause when navigation app is in use. 

Bencherished 

Link to comment
Share on other sites

1 hour ago, andrewilley said:

@rychu9191 So are you now saying that your Poweramp installation is actually on a car head-unit?

Andre

Yes 

I deactivated the option

 Settings=>Audio=>Audio Focus, or at least set it to Duck Volume instead.

 

and set it to aux

Hi-Res, AAudio, Audio Track

 

I'll let you know if that helped

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...