Jump to content

Bug with DAC USB C


Recommended Posts

Builds 941-943

Device: Núbia Red Magic 6r and Xiaomi Mi9 (Android 11 and Android 10)

Problems connecting the USB C DAC, the original Nubia DAC stopped recognizing 24/192 supported on both devices after update (as shown below) Hi-Res and AAudio are the same. Samsung's original USB C DAC is muted when activating Experimental Hi-Res on Xiaomi Mi9 and on both devices (RedMagic 6r and Mi9) the DAC does not recognize 32/384khz nor 24/192khz it stays on 24/48 and 16/48 which gives a low volume effect and low sharpness (I had other devices including Pixel 3XL, Mi9T Pro, Xiaomi MiA3 and they were also giving a bug when recognizing the 32/384 or 24/192 of the DAC of the Samsung after an app update)

Is there any way to solve these problems of recognizing the maximum capacity of the USB C DAC?



Link to comment
Share on other sites

@Magenkyougan Muted when activated means DVC not working. Form most Qualcomm devices (exlc. samsungs and Pixels) Hi-res + DVC won’t work, so use No DVC option (this is the default setting) or use standard definition output and DVC. Please use Restore Defaults in Outputs settings and start from there.

Also Hi-res for AAudio is implemented by limited number of OEMs (again, by Google in Pixels and Samsungs).

Link to comment
Share on other sites

Link to comment
Share on other sites

@maxmpeven resetting following your tips to disable the DVC (I even disabled the EQ) the output is still limited to 16bits/48khz

Using the "original" DAC (24bits/192khz) or the original Samsung (32bits/384khz) both are limited to 16bits/48khz and don't go beyond that by disabling or not DVC, EQ or changing other options.


P.S. Sorry for my poor English, I'm Brazilian and I use Google Translate a lot to translate my Portuguese into English.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...