Jump to content

Poweramp not pausing when receiving or making calls


slizzap
 Share

Recommended Posts

Hey guys,

I'm a new user of Poweramp. Just started testing over the past few days, and purchased a license yesterday. I have a Joying 7" double-din Android head unit that I'm testing with Poweramp. I feel I've got things mostly dialed in at this point, but I just uncovered an issue after pairing my phone and testing out calls with the head unit. When I have Poweramp playing music with the main interface displaying on screen, I'll attempt to both make and receive calls to check the call quality and test everything. In doing so I found that Poweramp is being muted but the music is continuing to play...it's not pausing the playback. I'm not sure if this is a Poweramp configuration/software issue or an Android issue, but I figured I would start here.

The head unit is a Joying JY-UQ128N4G running their latest firmware (Android 12 - 2022-8-15). Poweramp version is "build-939-bundle-play" (Full Version - 64-bit).

Here are the settings from Settings -> Audio -> Audio Focus:

  • Resume After Call = Enabled
  • Resume On Start = Enabled
  • Resume On Reopen = Enabled
  • Wait For Storage = Disabled
  • Short Audio Focus Change / Calls = Enabled
  • Pause In Call = Enabled (Greyed out due to above being enabled)
  • Duck Volume = Enabled
  • Permanent Audio Focus Change = Enabled

Aside from skin settings, I haven't really wandered outside of the Audio -> Audio Focus settings, so the configure is largely default in that regard. Please advise if there is any other information I can provide to help troubleshooting.

Thanks!

Link to comment
Share on other sites

Try turning off Duck Volume, as that is intended to reduce volume rather than pause. It's meant to be for short focus changes (notifications etc) but could be getting applied to longer changes too. Android head units are pretty much a law unto themselves as to how controls and focus changes are are applied though.

Andre

Link to comment
Share on other sites

I just tried disabling that option, but the behavior was the same for both making and receiving calls. Any other thoughts?

Side note: Is it recommended to kill or close then re-open Poweramp when making settings changes, at least when troubleshooting issues such as this?

Thanks.

Link to comment
Share on other sites

My audio output was using, and defaulted to, OpenSL ES Output. It's currently showing "Active" next to that selection, as well as the "Speaker" section within. Looking through there and going into the Settings cog next to "Speaker", I saw there was an additional ducking option there "No Duck". I changed that from disabled to enabled, but that had no impact to the behavior. While there I also tested with DVC enabled and disabled, but no change in behavior there either.

OpenSL ES Hi-Res Output is not available for me since I'm not using Bluetooth or USB DAC. I don't believe I mentioned this before, but I'm using a USB flash drive with FLAC files connected directly to the USB input on the Joying head unit. My phone is not in play here other than being used to test phone calls through the head unit while playing music.

I did go ahead and try AudioTrack Output with and without the No Duck option, but no change in behavior with any combination thereof.

I did see that other thread you linked, but I didn't post there thinking his issue wouldn't apply to me because it was only impacting outgoing calls and not incoming. Also, much of that discussion was around the Audio Focus settings, and those are all the options that I had completely exhausted already when troubleshooting this myself. With that said, I'll go back and re-read through that thread to see if anything else sticks out as worth trying.

Any other ideas/thoughts would be appreciated.

Thanks.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...