Jump to content

Atoto Head Unit Android 10 Can't add music folder on USB


Recommended Posts

First, let me note that other music players have no trouble finding the drive and playing the music. I just can't get Poweramp to work.

I searched and tried the obvious:

  • Storage is enabled for the app.
  • I installed Files by google.
  • I tried legacy mode.
  • I rebooted.
  • I'm not running any "disabler" apps

When I try to select the folder I get a popup with:

No Activity found to handle intent { act=android.intent.action.OPEN_DOCUMENT_TREE (has extras)}

(Note I get that error in regular and legacy mode.)

Oh, and I am running the free version... I'll happily pay if that makes a difference.

 

What else can I try? Would some kind of log be helpful?

Link to comment
Share on other sites

On a whim I tried accessing the USB with "Files by Google". Interestingly that only yielded an "Access Denied"!

However, the default file browser does show all the folders and files, and Rocket Player works fine as well:

rocketplayer.thumb.jpg.de912c4e2cb6892aa63f54c86af20403.jpg

To me it appears some apps use a method that allows them to see the files while other's don't... like Poweramp.

Am I missing a setting somewhere?

Link to comment
Share on other sites

OK, I think I figured this out.

The current version of "Files by Google" does not have the necessary functions included to for this head unit. (Actually, it may not have the proper files for any Android 10 device with this problem.)

THIS SHOULD BE  CHECKED AND NOTED/CORRECTED IN THE Poweramp FAQ.

Installing the proper version of "documentsui.apk" for Android 10 solves the problem on my Atoto Android head unit.

details of my question on XDA here:

https://forum.xda-developers.com/t/atoto-s8-general-discussion.4114493/page-33#post-86956181

And the answer here:

https://forum.xda-developers.com/t/atoto-s8-general-discussion.4114493/page-33#post-86956471

Link to comment
Share on other sites

I don’t think it is the job of Poweramp to assume that standard Android APIs are installed on any device. Many of these car radios have taken liberties with the Android OS to only fit their limited design environment. It would be impossible to make such assumptions for each potential variable. I think it would be more feasible for those radios manufacturers to advise that their OS has taken many standard functions of Android out, and as such some apps may not function as expected.

Link to comment
Share on other sites

Glad you found a solution to fixing the file management features that were omitted by your device manufacturer. As the APK package you have found is an unofficial rip from Android though, and I can't see an official download option from Google on the Play Store (they suggest their newer Files by Google now) it's not something we would put in a general FAQ as it might cause issues for other users. It is something that is already listed in that FAQ as not to be disabled though:

image.png

This thread will remain here for anyone who searches for your specific device though.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...