Jump to content

Equalizer "disabled" after a few songs Fiio M17 - Apple Music


Recommended Posts

I love the application but i have a severe issue that makes it impossible to use.

Apple music shows up in the application as player, no issues there.
I start playing a song and i verify that the equalizer settings are working, fine! (i also lower the preamp level to make sure i notice if the equalizer is bypassed
After a few songs (random it seems).  Suddenly the volume is increased e.g. the equalizer is bypassed.
Poweramp eaualizer and Apple music is the only visible applications and it does not matter if it's in front or not..
However, WHEN this happens, if switch to Poweramp equalizer and Swipe it away (up) the equalizer is again enabled.
The same story then repeats itself where it's suddenly after a few songs disabled. 
Now since it's not running in the gui, i just open the app (Poweramp eq) again and swipte it away and it's again enabled ... and repeat..
During this i can see the Poweramp eq notification in the notification bar all the time

I have experimented with different settings on the m17, also made sure no powersave modes are set (as i can see) the ADB permissions is done aswell.
Any clue as to what i'm missing here?
It seems to happen more often if there are shuffle mode going on allthough it's not clear since it also happens when listening to one specific record, so one idea i have is if it's something to do with the format of the song e.g 44, 96 etc?

For knowledge, this is the only app i've tested so far and the one i use. The next step would be to e.g. try spotify or some other app and see if it's the same behaviour.

However i'm very interested in some pointers to get rid of this issue...

 

thanks

Link to comment
Share on other sites

Ensure Equalizer app, Music app are the latest versions. Use Restore Defaults in Eq Settings / Equalizer / Known Players / Apple Music as some options are critical there.

Also if equalization disappears while app is in background means background optimization is enabled and should be specifically disabled for the app (usually via long pressing its icon / ( i ) / Battery ...).

I would suggest testing it with some other player (e.g. Spotify or YouTube Music). Also Apple Music crossfade option may affect equalization (though it works in my tests).

 

Link to comment
Share on other sites

First test.
Have now been playing spotify the last 3 hours without any issues. So possibly related to Apple Music only then..  Of course spotify is always same quality output aswell.  Will reset settings next but also test another app which changes resolution depending on albums. if Apple Music still fails.

Link to comment
Share on other sites

OK So i tested apple music some more.

I could reproduce the issue each time i switch to a song that plays at a diffrent resolution e.g. 44.1,48,96,176 etc.

As soon as the switched to song was different, the equaliser was "bypassed/of".. 

I then tested to turn of the default DVC setting aand i've now tried the same thing for a little while without the issue occuring..

Will test some more now by letting it play a random playlist to see that it's just not conincidence.. or something else that causes it to work better..
 

Link to comment
Share on other sites

Posted (edited)

Nope.
Tried various settings now, DVC on, off, reset to factory defaults etc.
Just starting a playlist and skipping a few songs will disable the equalizer, more often when resolution was different but even if it stays 44.1 the equalizer is off.

Then as before i can bring Poweramp in front and swipe it away and suddenly it's enabled again. Even if i then open it and it stays in fromt, it will happen.

Will test some more.. (btw latest playstore version of both apps)

Edited by Peter Bratt
Link to comment
Share on other sites

Checking the DSP sampling rate in Poweramp eq  when using apple music on the m17 i can see that it always display the same sampling rate as the first track played. e..g if it's 96 it stays that way or if it's 44.1 etc. so even when tracks in apple music is other sampling rates it seems to lock on the first one, is that a clue?
Then if i swipe away the app and open again it will set it to the current playing song again.

Link to comment
Share on other sites

@Peter Bratt I can't reproduce issue with Apple Music (3.9.1) but I test on phones only - no expensive DAPs available. Also, please note that Android audio subsystem usually won't process effects for Hi-Res output (anything > 48kHz), except for Bluetooth LDAC 96kHz. Also, if Offload, Direct, or FastTrack output is used for the particular track, it won't be processed by effects as well. On Android phones, apps like Apple Music, Spotify or YouTube Music and similar never use Offload/Direct/FastTrack outputs - builtin players may do so. On DAP audio system is (probably) modified, so this may be the cause.

Link to comment
Share on other sites

Hey. Yeah probably. The DAPS of course in various way override the 48kHz limit in Android devices.
Would be nice ot have this app working in those devices of course aswell, i will test to see if it actually works better when disabling hi-res for apple music so it stays at 44.1

 

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

I had this issue just after installing Poweramp eq. I think the issue was caused by my existing installation of Wavelet, probably because it was competing with Poweramp for audio control. Uninstalling wavelet fixed the issue. 

I'm not sure this was what caused the issue, but if you keep having problems like this it might be a good idea to check for other apps that interfere with the audio pipeline such as Wavelet. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...