Jump to content

Can't ChromeCast from Poweramp


Recommended Posts

3 hours ago, andrewilley said:

By the way, been meaning to mention this for a while, does anyone know why both of the Chromecast devices on my home network appear twice in the PA list? Sometimes in other apps too. Not serious, but puzzling.

Perhaps you did setup your devices twice in Google home app?

Regards

Link to comment
Share on other sites

  • Replies 147
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

22 hours ago, asphalt45 said:

 I use the cast feature a lot as my home theatre sound system doesn't have Bluetooth.

Worked great until today. 
 
Normal working case:
I tap the cast button
Select my TV 
The TV screen momentarily goes blank 
The Poweramp logo appears with a small loading circle on the bottom. 
The album art loads
The audio starts playing
The seek bar readjusts on the TV and on the phone to show the correct position.
All is well... 
 
Not working case:
I tap the cast button
Select my TV 
The TV screen goes blank and stays blank!
 
Nothing loads, no logo, no audio. 
The app on the phone shows the seek bar moving. The chromecast output is also active. 
 
Things I've tried:
On the phone:
Rebooted
Uninstalled Poweramp and reinstalled. 
 
On the TV:
Force stopped the built in chromecast app. 
Uninstalled updates
Reinstalled updates
Cleared cache and data for the chromecast app and restarted TV. 
 
 
On the network:
Restarted my router
Turned off every other device on the network
Tried a different WiFi network. 
Tried the cast while being connected to the phone's Hotspot.
 
Why I think the issue is with Poweramp:
Because every other app is behaving as it should while casting. 
The Google home app can cast the phone screen without any problems.
A video in a chrome tab can be casted successfully. 
Casting chrome tabs and YouTube content works from two of my other PC's on the same network.
 
Extra info:
There were no other changes. 
There were no system updates to neither the phone nor the TV.
I don't remember the last time Poweramp updated. But the cast was working fine this morning. 
There were/are no other accessories connected to the TV. 
The TV did not experience any sudden power loss in the last 48hrs. (even if it did, it wouldn't matter) 
 
The TV is an Iffalcon (by TCL) Android TV running Android 9.
 
The cast feature worked really good until now all of a sudden. And I've tried everything. 
Any help is greatly appreciated! 
 

The cast functionality is suddenly working again!!! 🥳🥳🥳

Link to comment
Share on other sites

14 hours ago, maxmp said:

Ok, it should work now (no update to Poweramp is needed). The investigation shown some server misconfiguration related to ssl certificates. 

"Server" - may I ask where it is hosted? I see no update for PA so I have no idea about the infrastructure - where did the fix take place?

Despite audio being streamed inside home LAN, does CC still need to communicate with a remote server? 

Link to comment
Share on other sites

1 hour ago, Squeller said:

Despite audio being streamed inside home LAN, does CC still need to communicate with a remote server? 

Yes, see previous replies on this subject. Chromecast needs to phone home to its Google mothership. :)

Local music content doesn't go via the internet though, that is passed directly from your phone to the Chromecast IP address on your LAN.

Andre

Link to comment
Share on other sites

OK, sigh... need to check how tolerant CC is, in case there is no internet connection.

There are times, for me it is now, where you realize how easily and quickly you may lose internet/digital based services and assets. It's all worth a shit after all. E. g. a small example: Google/Steam kicks you out, because you live on the wrong spot on earth.

Edited by Squeller
Link to comment
Share on other sites

@Squeller As indicated above, Chromecast devices apparently need an internet connection to Google by design, even when the task will be a local LAN stream. If you unplug your router so there is no WAN, CC playback cannot be started. One of the compromises of a connected world I guess.

Andre

Link to comment
Share on other sites

41 minutes ago, andrewilley said:

@Squeller As indicated above, Chromecast devices apparently need an internet connection to Google by design, even when the task will be a local LAN stream. If you unplug your router so there is no WAN, CC playback cannot be started. One of the compromises of a connected world I guess.

If it is very strict (I will test it), rather one of the results of abuse of power. Look, Steam. They still have an offline scenario in mind. You can play your games when offline. It's just reasonable.

EDIT: With no internet access for CCA, in my testing, you cannot connect to CCA at all. 

Here's an explanation: https://www.reddit.com/r/Chromecast/comments/8srkn3/comment/e11v5md/

"Just to make it completely clear - Chromecasts are running slightly modified Chrome browsers in kiosk mode. "apps" are HTML5 web pages. Whether you are watching video on a video Chromecast or listening to audio on an audio Chromecast - the Chromecast is just opening a specific webpage (which is gets pointed to by Google when it says to Google - "I have been asked to launch this app <appid>" and Google responds - sure that's at "https://developer-site.com/clients/chromecast/chromecast-audio.html") directly from the internet on the app developers server, this means that when the app developer makes a change, fixes a bug or adds new functionality - it is instantly available to all devices. "

Edited by Squeller
Link to comment
Share on other sites

@Squeller Yes, Max's post was a TL;DR of that. Chromecast is a Google device, and needs to contact Google to get the 'app' details that it needs to run in its 'browser'.

So yes Google could break it at any time if they chose to do so. Same goes for quite a lot of smart tech these days.

Andre

Link to comment
Share on other sites

You can always use a device that supports local uPnP if that is desired. That would avoid the CCA external involvement and likely has better connectivity in your local environment as well. But that it dependent on what devices you have and if they support uPnP.

Link to comment
Share on other sites

2 minutes ago, Jessie Anna Vranken said:

I'm lost in this topic 🤷‍♀️ From one page to the next the posts went from broken to solved for everyone 😅 Am I missing the post that states the solution or...?

There is no required solution in terms of local updates for users. It was a central server-based setting that was causing the problem, and it was resolved for everyone when Max updated the server.

Andre

Link to comment
Share on other sites

Strange that I am still facing this issue today.  Have restarted my phone and my Harman Kardon Citation One and it doesn't seem to have helped.  Trying to cast to the several other Google Cast devices in my house displays the same behavior.

Wonder what I'm doing wrong.  Other apps that support this (Spotify for example) are working fine.

Link to comment
Share on other sites

  • 2 months later...
1 hour ago, Don_broco said:

Appears issue is back again - anyone experiencing the same problem as last time?

Long thread with lots of discussions, could you confirm the exact issue you are currently seeing?

Andre

Link to comment
Share on other sites

Posted (edited)

@andrewilley 

* I am able to click "cast" in Power Amp

* Power Amp thinks it is casting (allows to click stop, to control volume)

* But there is no "Ding" connection sound from Chrome Cast speaker as usual, and no output from Chrome Cast speaker

* After ~ 30-secs - 1 minute, Power Amp disconnects from Chrome Cast Audio, and Chrome Cast Audio makes a disconnection "Dong".

 

This started happening this morning.

 

All other "castable" apps working fine

Edited by Don_broco
Changed audio to speaker
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...