Jump to content

Not perfectly gapless?


Recommended Posts

Today, I noticed a really small but audible artifact/glitch during the transition between two tracks that are supposed to be played gaplessly. This glitch happens every single time I play those tracks, which means it is easily reproductible.

Both tracks are in 16-bit 44.1kHz FLAC format and are perfectly gapless when playing on other music players.

My settings should allow gapless playback without issues, I made sure to disable any resampling, fading and even equalizer, to be sure I have the "cleanest", most "direct" output:

image.thumb.png.482609e538558c1113eff6e341e24611.png

I even increased the "Preload Gapless Tracks" option, to be the largest value but the same glitch happens.

To understand the issue, I recorded the Poweramp output using Audacity and compared it to the original files, here is the result (top is the recording from Poweramp output, bottom is the original tracks combined):

image.thumb.png.1205f972c9ea799797c42496180b7fc9.png

The tracks I played are "Klaus I Love You" and "Outro" from M83's album titled "Hurry Up, We're Dreaming", I can provide my FLAC files if needed.

 

Do you think this is an additional setting to set or a bug inherent to Poweramp?

Link to comment
Share on other sites

If you're using some rather slow sd card storage, check "Preload Gapless Tracks" option in Poweramp Settings. Flac tracks are always gapless, Poweramp doesn't insert silence between tracks, obviously, unless you specifically set "Silence Between Tracks" option. Thanks!

Link to comment
Share on other sites

6 hours ago, maxmp said:

If you're using some rather slow sd card storage, check "Preload Gapless Tracks" option in Poweramp Settings. Flac tracks are always gapless, Poweramp doesn't insert silence between tracks, obviously, unless you specifically set "Silence Between Tracks" option. Thanks!

I made sure to set "Preload Gapless Tracks" to the maximum value to be sure that wasn't a slow SD problem but the problem still occured.

As you can see on the waveforms, silence doesn't seem to be "inserted" but actually "erased" over the very beginning of the next track.

Let me know if you want the FLACs files, I believe this is easily reproducible, it happens everytime on my phone.

Thank you!

Link to comment
Share on other sites

@Chewy please share couple of such tracks with imperfect gapless (preferable from the device/Poweramp itself via Send menu action - gpmaxmpz@gmail.com) - I'll try to investigate those. Poweramp do inter-track gapless smoothing by interpolating last and first samples a bit, but this improves audible gapless perception. Thanks!

Link to comment
Share on other sites

12 hours ago, maxmp said:

@Chewy please share couple of such tracks with imperfect gapless (preferable from the device/Poweramp itself via Send menu action - gpmaxmpz@gmail.com) - I'll try to investigate those. Poweramp do inter-track gapless smoothing by interpolating last and first samples a bit, but this improves audible gapless perception. Thanks!

Files sent!

This inter-track gapless smoothing feature could be the cause! Is there a way to disable it?

Thanks :)

Link to comment
Share on other sites

@Chewy it seems the artifact is introduced by the (default SwR) resampler flushing. You can try to switch to SoX resampler in Poweramp settings in the current Poweramp builds to workaround the issue. I hope the issue for SwR resampler will be resolved in the next builds. Thanks!

Link to comment
Share on other sites

1 hour ago, maxmp said:

@Chewy it seems the artifact is introduced by the (default SwR) resampler flushing. You can try to switch to SoX resampler in Poweramp settings in the current Poweramp builds to workaround the issue. I hope the issue for SwR resampler will be resolved in the next builds. Thanks!

Unfortunately, switching to SoX didn't change anything for me. I guess it makes sense since I'm using the Samsung Hi-Res output directly at 44.1kHz, without resampling!

Changing the sample rate to 48KHz and using the SoX resampler did not solve the issue either :(

Link to comment
Share on other sites

3 hours ago, maxmp said:

@Chewy please check this build, let me know it works for you

 

It's working a lot better with this build, yes!! No audible glitches anymore :) Thanks!!

 

Comparing the waveforms shows there are still minor differences between the two tracks combined and what Poweramp plays. I guess those come from the "smoothing" feature you were referring to. Out of curiosity, what's the point of such a feature when playing 100% gapless FLAC files?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...