Jump to content

Poweramp not playing any songs or loading album art


Utsav
 Share

Go to solution Solved by andrewilley,

Recommended Posts

I use 5he device galaxy m30s with Android 11

so in my case, I downloaded a movie(video) but for some reasons, in recent files of Poweramp. it is showing and when I want to play it it isn't playing and also no other song is playing nor loading album art unless I force restart Poweramp from settings.. here is a screenshot of what is happening. 

I think that this issue can be solved if I can figure out a way by which Poweramp will not search and show video files because this started happening after 8 downloaded the movie and went to recent and rescaned folder because for some reason, Poweramp doesn't detect new songs in my device unless I manually rescan Poweramp.

please help me with both the issues: Poweramp not detecting new songs automatically and Poweramp showing video track as songs

Screenshot_20211214-213936_Poweramp.jpg

Link to comment
Share on other sites

Settings > Library > Music Folders will allow you to specify only the folders which contain your music. You will also need to grant access permission to that location for Android 11, but you may already have done that.

You can also specifically tell PA to ignore any video files that it does encounter, using Settings > Library > Ignore Video Tracks. 

Andre

Link to comment
Share on other sites

@andrewilley

the first answer you provided will not work me as both my music and videos are saved in the same download folder. I tried changing that but it was without success.

and as for your second answer, that option was enabled by default on my Poweramp I think... I think that this problem is only caused by videos with .mkv format so if you have any answer on how to specifically filter that I would gladly accept it.

and while you are at it, can you also provide me a solution for Poweramp not detecting new songs by itself unless I manually rescan it?

Link to comment
Share on other sites

  • Solution

MKV files should not be scanned into the database if the Ignore Video Files option is enabled. I've just tested it by putting an MKV video file into my music folders and it worked as expected. I would suggest trying a FULL Rescan to see if the unwanted MKV files get removed.

This used to be an issue some time ago (as Android SAF does not discriminate between MKA audio and MKV video files, listing all of them as mime type */x-matroska) but as far as I know that was resolved back in March.


To enable auto-scan, see the options in Settings > Library > Scanner.

The real answer is to properly sort out your folder structure of course. A transient/temporary Downloads folder is not really the best place to permanently keep your music, especially if it is cluttered with other content too which will slow the scanner down.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...