Jump to content

Button labels missing when Material You Colors disabled


tmz
 Share

Go to solution Solved by tmz,

Recommended Posts

Poweramp bulld 912

Android 12 (SQ1A.211205.008)

Pixel 5

Using the default skins, both light and dark, the buttons are either mostly or entirely blank. Picking the light skin and restoring the defaults, the +/- 10 second buttons are blank.

Selecting the "More light" skin option allows them to appear. They are drawn black while the other buttons are white, which explains why they can't be seen.

Without the "More light" setting but with the "less rounded" setting, all the buttons are blank. They appear to all be drawn in black then.

The dark skin is similar, but there isn't anything corresponding to the "More light" setting, so it's not possible to fix the buttons without enabling one of the Material You Colors options.

Here's an example with only the Material You Colors option differing between the screenshots (settings screenshot included).

Screenshot_20211209-000917.thumb.png.5433de393a27addea9315a737870e68e.png

Screenshot_20211209-000938.thumb.png.ea4ff2cda53af15ae2caf05fc05385b3.png

Screenshot_20211209-001038.thumb.png.7af1e9e8ad667eae89b91ac2665f5669.png

Thanks, as always, for making such a nice app. I've been using it daily since the Nexus One days (I think, it's been a _long_ time).

 

Edited by tmz
Add screenshots
Link to comment
Share on other sites

Thanks for the report. Yes, due to the dynamic colors, some skin options may conflict and result in blended colors like this. It will be definitely polished for the next beta (and already is more polished in latest build-914). 

Could you please make a screenshot of your wallpaper settings? I will try to reproduce your colors exactly.

Link to comment
Share on other sites

Indeed, I can see how the dynamic colors may cause trouble.  In this case, it is only when the "Martial You Colors" are disabled that the problem shows up.  Combined with the "Less rounded" "Rounded Corners" option, all of the buttons are blank [likely, they're black on black, which looks the same as blank to our feeble human eyes. ;)].

Apologies for not being clearer.  I should have shown two screenshots of the settings and made sure to indicate which went with which screenshot of the Play UI.

In the screenshots above, the settings image corresponds to first shot, where the buttons have a dark blue background and off-white/light blue foreground.  The second screenshot, where the buttons are blank, is with the "Material You Colors" option disabled.  Hopefully that makes it a bit less challenging to reproduce.

The potential for bad contrast and/or colors with Material You colors system-wide is one reason why I use "basic colors" in wallpaper settings and chose "disabled" in Poweramp.

As a test, I did enable "dynamic colors" in the system wallpaper settings.  Poweramp worked just as well as "basic colors" at the system level and "Material You Colors" are enabled in the skin settings.

If you still want a screenshot of the wallpaper settings, just let me know.

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...