Jump to content

Poweramp builds 912-921


maxmp
 Share

Recommended Posts

  • maxmp pinned and featured this topic
  • Replies 156
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

This will please a lot of people, especially as Ratings and Play Counts can now be exported/imported. Will makes transferring a PA setup over to a new device (or doing a clean re-install) much easer:

image.png

I don't have any Android 12 devices to test, but I assume that by 'Stretch Overscroll' you mean that in addition to the rubber band bounce-back effect that you get when you reach the top or bottom of a long list, it also slightly expands or contracts the gaps between items in the list? If so, then very nice.

I like rounded corners in interfaces generally (I have them enabled everywhere in the skin I use). I do wonder whether Android 12 copied Windows 11, or the other way around? :) It's like Microsoft realised that Windows 7 looked better than any of its successors and are trending back in that direction - like home-interior fashions roll around again every ten years or so.

Andre

Link to comment
Share on other sites

41 minutes ago, Bencherished said:

the sleep timer bug is still present. 

Max gave me the impression that the last few months of work weren't going to be focussed on bug fixes or feature additions (apart from some already in progress) but more of a necessity forced upon developers by Google for the required SDK versioning for the Play Store and Android 12 compatibility. He also used the time to improve and update various tools and libraries. All of which I think took rather longer than he was hoping.

Hopefully now that is done, and he has a stable and fully compliant base platform to work with, he will be able to start addressing more of the little bugs and feature requests that have cropped up recently (things like the Timer bug, Playlist-saving corruption, etc).

Andre

Link to comment
Share on other sites

Hello all,

This morning during my commute the new build 912 glitched weirdly, following is my description of the bug I experienced.

  • Poweramp build number: 912
  • Samsung S20 FE (Exynos)
  • Android 11
  • Connected to Android Auto, played music, experienced bug

I was playing a song in its album folder (8 FLAC files in the folder) as always and after the first one finished, Poweramp did not proceed with the next song in the album but instead stopped. When I pressed play again it skipped all the songs in the present folder as if files were corrupt, proceeded to the next folder, skipped all the songs there and couldn't play again for a few folders like this until I pressed pause.

I tried to: replug the phone to the car, didn't fix it. Went to Spotify and that worked. Then got back to Poweramp and it was the same. Then I force stopped Poweramp and when I relaunched it, Poweramp continued from the song it first skipped (so 2nd song, 1st folder).

Since this had never happened before and the first occurrence of it for me is at the first time I listed to music with the new build I thought I should report

Edited by Yttersta
Link to comment
Share on other sites

Poweramp Build 912

After the recent update from Poweramp, the Stereo expansion feature has issues. When I play music and try to expand the Stereo, it produces a high pitched shilling noise that gets overlapped with the music, but when I turn it to 0% the shilling noise disappears. The noise is mostly sharp on higher frequencies. Appears to be a bug.

Build : 912 Beta (latest version)

Device : Realme GT Neo 2 (Android11)

 

Link to comment
Share on other sites

9 hours ago, Yttersta said:

Hello all,

This morning during my commute the new build 912 glitched weirdly, following is my description of the bug I experienced.

  • Poweramp build number: 912
  • Samsung S20 FE (Exynos)
  • Android 11
  • Connected to Android Auto, played music, experienced bug

I was playing a song in its album folder (8 FLAC files in the folder) as always and after the first one finished, Poweramp did not proceed with the next song in the album but instead stopped. When I pressed play again it skipped all the songs in the present folder as if files were corrupt, proceeded to the next folder, skipped all the songs there and couldn't play again for a few folders like this until I pressed pause.

I tried to: replug the phone to the car, didn't fix it. Went to Spotify and that worked. Then got back to Poweramp and it was the same. Then I force stopped Poweramp and when I relaunched it, Poweramp continued from the song it first skipped (so 2nd song, 1st folder).

Since this had never happened before and the first occurrence of it for me is at the first time I listed to music with the new build I thought I should report

I wanted to give an update after my commute back. It seems to be directly related with Android Auto. The exact same occurred in the car again, but now that I'm home it seems to work fine.

Link to comment
Share on other sites

Starting with this update, whenever Poweramp is running I get this new volume behavior when I turn the volume all the way down the music will pause and when I turn it back up the music will resume. I checked settings but didn't find any new options regarding this. Does anyone know where this setting is so I can change it? I am using a Google Pixel 4a with 5G running Android 12. Thanks

Link to comment
Share on other sites

1 hour ago, danorman7951 said:

 when I turn the volume all the way down the music will pause and when I turn it back up the music will resume.

Settings > Audio > Advanced Tweaks > Pause/Resume on Volume

There's a search function in Settings by the way, which would have popped it up for you.

Andre

Link to comment
Share on other sites

Samsung Galaxy 10 running stock Android 11. I listen to music via Bluetooth, total random always on, and latest Poweramp beta 912 just randomly stops playing, mostly at the end of any song, after playing a couple seconds from the next one; when I press play again it skips the track I got playing for a couple seconds, goes to the next one and keeps playing until it won't, again.

Edited by teorouge
Wrong word
Link to comment
Share on other sites

3 hours ago, andrewilley said:

@Yttersta I tried the same setup as you this afternoon, Android Auto head unit and Samsung Android 11 on my phone, but it worked fine.

Actually, no it's not always fine. Driving home this evening I had the same problem as @Yttersta.

I was in Folder Hierarchy > Shuffle mode in my acoustic moods folder, then I tapped on the Play button on the Android Auto screen and that first song started playing as expected. But at the same time, the track info and cover art started to rapidly cycle through about 5-10 more songs, and then playback gave up and it stopped. If I pressed Play again, the same thing happened. If I then disconnected the USB cable from the car, all the songs play fine on the phone.

@maxmp I'll email you a log of the above incident.

Andre

Link to comment
Share on other sites

@Yttersta @andrewilley thanks for the report/details - that will be investigated shortly. The log from Poweramp "Last processed commands" as well as the log from Settings / Get Support / Send Log will help greatly. 

Edit: this is now fixed for the next build. In the meantime, the issue can be worked around by launching Poweramp UI on the phone first (prior starting Auto).

Link to comment
Share on other sites

5 hours ago, maxmp said:

@Yttersta @andrewilley thanks for the report/details - that will be investigated shortly. The log from Poweramp "Last processed commands" as well as the log from Settings / Get Support / Send Log will help greatly. 

Edit: this is now fixed for the next build. In the meantime, the issue can be worked around by launching Poweramp UI on the phone first (prior starting Auto).

Ah man, I had a reinstall last evening to build 911 to get it fixed. I'm updating again now to hopefully break it again and send you a log. This time I'll update my settings export as well 😄 It took half an hour yesterday to get everything right.

Link to comment
Share on other sites

20 hours ago, danorman7951 said:

Starting with this update, whenever Poweramp is running I get this new volume behavior when I turn the volume all the way down the music will pause and when I turn it back up the music will resume. I checked settings but didn't find any new options regarding this. Does anyone know where this setting is so I can change it? I am using a Google Pixel 4a with 5G running Android 12. Thanks

On my Samsung Galaxy m51 running Android 11 One Ui 3.1, when I get to Zero volume, music pauses, pressing Vol + one step plays the song, Vol +two steps stops the music, no matter how many times I press the Vol +, music will not continue, my volume is set to 100 steps. 

Edited by Bencherished
Link to comment
Share on other sites

@Bencherished The problem seems to be with multiple-step volume adjustments, it works fine with system default stepping.

Playback actually stops just before you get to the zero point - seems to be around 2 on a 76 scale. So when you increase again from the real zero up to 1, PA starts playback as expected - but as soon as you click once more to go up to 2, PA thinks it's arrived at the mute level and stops again. If you click up one step so it starts playing, and the tap the slider to a mid-level (so it never settles on 2) it works.

Andre

Link to comment
Share on other sites

  • maxmp changed the title to Poweramp builds 912-921
  • maxmp unfeatured this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...