Jump to content

Android 12/Android Auto Artwork


tedfroop
 Share

Recommended Posts

Phone: Pixel 4a

OS: Android 12 Kernel 4.14.234  Build SP1A.211105.002

In android auto only. 

Added Christmas music (All FLAC with artwork embedded in tags.) 

Music scanned ok, songs added to library.  Made a playlist. 

Now when I play it in the car it randomly shows the wrong artwork on Android auto head unit only.

Phone shows correct artwork for all songs.

 

Link to comment
Share on other sites

  • 4 weeks later...

I get this problem intermittently in Android Auto too. Most tracks display their correct artwork on both the phone screen and the AA headunit, but maybe one in twenty tracks will get some completely random cover art from a track not even in the current playlist shown on the HU. The cover art shown in Poweramp on the phone is always correct, it's only the HU screen that shows the random image - and the incorrect image stays linked to that track if you skip forward and backward again. Very strange!

Andre

Link to comment
Share on other sites

I was planning on doing some more testing tomorrow; I will try to get a video of both screens changing track side-by-side, and an Android log of same. There does seem to be one particular playlist that often causes it, and the mismatched images often seem to come from assorted songs from one particular folder, so hopefully I can recreate it. All images (the correct ones and the mismatches) are embedded into their respective audio files. 

Andre

Link to comment
Share on other sites

Thanks for the logs/video. My investigation shows that Android Auto may cache wrong album art and reuse it for some tracks. When Auto does this, it doesn't even request any album art from Poweramp, so Poweramp can't do anything about that to refresh that image.

I was able to fix this by doing "Clear cache" in Android Auto app settings (in phone settings). Not sure why invalid album art got there, I guess it may be the album art from the previous "iteration" of the Poweramp db. Poweramp may reuse ID for track (e.g. after Full Rescan or new songs added), so if Auto caches it, it may in turn reuse some old album art.

I will try to implement some serial numbering or something that will prevent Auto from reusing old album arts.

Link to comment
Share on other sites

Thanks Max. I'm not going to clear my AA data/cache in the meantime so I can properly test the workaround. I now know a number of specific tracks which are affected by this issue (it's consistent and repeatable for whatever tracks have been affected) so I can check them again after installing the next PA release.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...