Jump to content

[Solved] Library scanner not working


Ali Rahal
 Share

Recommended Posts

Hi, 

The media scanner is failing completely and does not scan files even after the permission is grated (on a clean install on lineage 18.1 android 11) resulting in an empty library.

Tested with a clean install; with the play store apk version and with the uni version the issue is still present.

Bug : PA Activity : .ACTION_SCAN_DIRS 

CMP : .scanner.ScanDispatcherService "without permission blocked by firewall"...

Here are the different captures... is Poweramp missing a permission declaration ? I tried to allow the additional MANAGE_EXTERNAL_STORAGE on ops but it does not work I guess because the app is not declaring that permission, but other similar apps work without that permission just with read/write permissions... 

Note that if I restore a titanium old backup I can still read my music but the scanner does not work... also on the scanner's file selector I can browse the subfolders etc. after allowing the app... 

I also tried the experimental feature legacy file access with the same result...

Note that I did buy the app and the equalizer as well. (PA + Equalizer + Unlocker are installed...)

Can you please help with this issue.

 

 

 

 

Screenshot_20211203-064118_Settings.png

Screenshot_20211203-063555_Termux.png

 

 

 

 

Screenshot_20211203-054654_OS_Monitor.png

Edited by Ali Rahal
Link to comment
Share on other sites

  • Ali Rahal changed the title to Library scanner not working, urgent

@maxmp will need to check the detail, but it does sound like you've done everything correctly.

You don't actually have some firewell app running that could be causing this do you? The Legacy File Access mode should be turned OFF for Android 11.

Again, sounds like you've done this, but try revoking all storage access permissions and try granting access again via PA Settings > Library > Music Folders. Ideally to just one music folder, not a root location. Try internal memory first, then try external SD Card.

Andre

Link to comment
Share on other sites

@andrewilley thanks for the reply and suggestions, indeed i already did all what you suggested without a solution.

When I noticed the problem, I made a backup and uninstalled everything and just installed a clean PA and kept testing the different possibilities while uninstalling and reinstalling each time. it took me some times to test about a dozen of possibility I thought of... even thought of patching PA to add the permission on the xml file but I did not went that far... may be a special system xml permission file can solve that but I prefer keeping things in a "normal" mode lol... wait and see :) just one thing sorry but the attached log is not from the clean test install but from my main setup... 

Edited by Ali Rahal
Link to comment
Share on other sites

Yes data cleared as it was reinstall, Yes I know that PA can not support everything, this is why I asked for advice as I do not know the content of PA's .scanner.ScanDispatcherService unless i reverse engineer it... and for a proprietary paid app this is a little odd, the rom is my own I am a dev, its basically a clean lineage build without many addition... 

just asking for technical advice as its an advanced permission bug. 

Thanks ;)

Link to comment
Share on other sites

  • Ali Rahal changed the title to Library scanner not working

Myyyyyyyyyy baaaaaaadddddd !!!!!!!!!! problem solved !!!!!!! 

I did not use the app for few months and few months ago I was calibrating intent firewall on android, I don't know why and how "ScanDispatcherService" remain blocked on that firewall... my fault for sure... anyway I just unblocked it on the android intent firewall and its working now !!!!

Ohhh myyy, never a problem/bug took me that long, I did not trust the logs and though there is a bug somewhere, where I just needed to trust the log and go from there as it was indicating an intent firewall problem.

Ayway thanks @andrewilley

Edited by Ali Rahal
Link to comment
Share on other sites

  • Ali Rahal changed the title to [Solved] Library scanner not working

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...