Jump to content

Album Title in Artist field on Bluetooth device


Jeff Isaac
 Share

Go to solution Solved by Jeff Isaac,

Recommended Posts

Poweramp build-911-arm64

Pixel 3a XL

Android 11

 

On the receiver in my car, the album title is being listed after the artist name in the artist field (ie: artist name album title) and the album title field is empty.

During troubleshooting, I've tested several different players, (Foobar2000, Onkyo HF player, Rocket Player, N7, Neutron Player, Black Player, Jet Audio, Musicolet, AIMP...) all of which display the tags in the proper fields which would indicate there is no inherent issue with my receiver displaying the tags correctly. I'm not sure if this is a bug in Poweramp or if I've configured something incorrectly in the settings.

Link to comment
Share on other sites

I remember that setting as well, which is why I was wondering if I didn't have something configured properly. I thought maybe I just couldn't find the setting. Unfortunately I don't have another bluetooth device that can display this tag info to test with. Thanks for the reply!

Link to comment
Share on other sites

  • 4 weeks later...

The problem came back after adding some new music to my phone, triggering a manual library scan, then adding all songs to a playlist and shuffling that playlist. This was all I did. I didn't change any settings. This issue appears to be intermittent, because I've done this exact thing many times without having the problem reoccur. 

This time I couldn't fix the problem just by clearing the app cache. I had to clear the app storage and reconfigure Poweramp. I did export my settings before clearing the storage, but importing those settings apparently just imported the problem back into Poweramp because the issue was still there. Manually reconfiguring did work though.

Very strange little gremlin!

Link to comment
Share on other sites

  • 2 weeks later...

Same Poweramp build as above

New phone, new OS.

Pixel 5A

Android 12

This settings corruption (?) issue happens quite often with this setup. Almost daily, without even doing anything inside the app. Just using the phone. For example: Things are displaying properly, restart the phone, now I get the issue. Go into the supermarket and use Google Keep Notes for my grocery list, come back to the car and find that I have the issue again... 

I did use this phone for a couple of weeks using Android 11 before 12 was released, and the problem only happened when I was manipulating things within the app as mentioned previously. Android 12 has significantly worsened the issue and now somehow, actions outside the app can cause the issue.

I've done testing with quite a few other music players (Foobar2000, AIMP, Neutron, N7, Black Player, OTO Music, Rocket, Musicolet, etc...) to see if it has something to do with the head unit in my car when this issue is occuring with Poweramp, but none of the other players have issues displaying the data properly.

I can always restore the 'good' settings to fix it, but I feel like I'm walking on eggshells with the app these days. Any ideas what's going on here, @maxmp?

Link to comment
Share on other sites

  • 4 weeks later...

I have the same issue.

 

Device: Pixel 3 XL

OS: Android 12 (this already occurred when I was using Android 11)

Car: Toyota Prius

 

I’ll clear the cache before I get in the car next time, see if it helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...