Jump to content

Crossfade


Recommended Posts

As a test, try setting the Crossfade Length to max (15 seconds). Near the end of the last queued song it should commence the auto-advance about 8 seconds before the end of the song and fade into the original playback category. Obviously 'Silence Between Tracks' should be turned off. Manual advancing would need to be set to 'Crossfade' to get the same effect (I have mine on Short).

Andre

Link to comment
Share on other sites

My settings has been exactly as you just suggested, I only noticed this from Version 905 and the present 909. Please just check it out, play a song from all songs category, then add Queued and play next, sometimes I even noticed silence between Queue and play next. 

Link to comment
Share on other sites

That works fine for me.

I starting playing music in 'All Songs' category, then I added one song to the Queue and then another song using 'Play Next'. PA correctly crossfaded at the end of the currently playing track into the first (Play Next) track, then it crossfaded into the earlier queued song, then it crossfaded back to the original 'All Songs' playback. Obviously if one of the files has a long silent section at the start or end, that will affect the overlap of actual music.

My test settings (PA 909):

image.png

Andre  

Link to comment
Share on other sites

The only thing I had different was preload gapless track, mine was a bit above normal, now all the way down, but I still have same result (no crossfade) it plays the last Queued song to end before returning to previous category. 

Link to comment
Share on other sites

No idea then, I just checked in case Shuffle or the 'Ignore Shuffle for Queue' modes make a difference, but they don't. It works fine for me whatever category I start in, and with shuffle on or off. Even if I choose the Auto-Advance Fading > 'Shuffled Songs' mode, it still crossfades  correctly when going in and out of the queue.

Are you saying that the function does not trigger at all - i.e. the counter goes all the way to the very end of the last track before the next track commences? Or that the next track does commence shortly before the end of the last track as expected, but the sound doesn't seem to do what you want?

Andre

Link to comment
Share on other sites

Thanks for your response, I have managed to sort it out, the problem was on the main player screen where you have repeat off, repeat category, advance category, etc. I set it to repeat off, so after switching options off and on in the audio and library settings, same issue. 

I decided to try changing playback mode, from repeat off to advance category(boom) it worked, silence gone. 

Link to comment
Share on other sites

18 minutes ago, Bencherished said:

I decided to try changing playback mode, from repeat off to advance category(boom) it worked, silence gone. 

I've just tested your method (i.e. entering and leaving the queue with Repeat mode set to 'Off') and you are right, the audio does not crossfade properly when exiting from the Queue - although it's fine when starting the queue. Other options (Repeat Category and Advance Category) work as expected and they crossfade on queue exit. Glad you found that, I couldn't work out what was causing it!

@maxmp Could you take a look at this when you get a chance? The bug only occurs when exiting from the Queue while Repeat mode is set to 'Off'. Thanks.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...