Jump to content

Poweramp uses incorrect cover art for album with same title as another album by different artist


Go to solution Solved by MotleyG,

Recommended Posts

Poweramp version: build-905-arm64-play
Device: Galaxy S9 (SM-G960F)
Android version: 10

Steps: I had an album by artist Katharsis with album name "666" already in the Poweramp library:

Screenshot-20210614-095636-Poweramp.jpg

Added a new album by artist KAT that also have the album title, "666". When using artist view and entering entry for KAT, the artwork that is displayed in the album list is the artwork for Katharsis' 666 and not KAT's 666:

Screenshot-20210614-095628-Poweramp.jpg

When playing music from KAT's 666, the correct artwork is displayed, but when going back to the "track list view" for current album, the incorrect album is displayed at the top:

Screenshot-20210614-103701-Poweramp.jpg


I've tried picking the correct image from gallery several times but it just won't change, so not sure if I'm doing something wrong or if it is a bug. Not the biggest thing, but thought I'd report it anyway.

Edited by void
Link to comment
Share on other sites

  • Solution
43 minutes ago, void said:

Poweramp version: build-905-arm64-play
Device: Galaxy S9 (SM-G960F)
Android version: 10

Steps: I had an album by artist Katharsis with album name "666" already in the Poweramp library:

Screenshot-20210614-095636-Poweramp.jpg

Added a new album by artist KAT that also have the album title, "666". When using artist view and entering entry for KAT, the artwork that is displayed in the album list is the artwork for Katharsis' 666 and not KAT's 666:

Screenshot-20210614-095628-Poweramp.jpg

When playing music from KAT's 666, the correct artwork is displayed, but when going back to the "track list view" for current album, the incorrect album is displayed at the top:

Screenshot-20210614-103701-Poweramp.jpg


I've tried picking the correct image from gallery several times but it just won't change, so not sure if I'm doing something wrong or if it is a bug. Not the biggest thing, but thought I'd report it anyway.

Do you have the AlbumArtist tags completed for all tracks in both Albums? That is what is used for differentiating the two. This is different than the Artist tag.

Link to comment
Share on other sites

Posted (edited)
1 hour ago, MotleyG said:

Do you have the AlbumArtist tags completed for all tracks in both Albums? That is what is used for differentiating the two. This is different than the Artist tag.

Thanks for the suggestion; I added the tag for the tracks and then Poweramp updated the library and changed to the correct artwork! Learning something new every day..!
 

Edited by void
Link to comment
Share on other sites

3 hours ago, void said:

Thanks for the suggestion; I added the tag for the tracks and then Poweramp updated the library and changed to the correct artwork! Learning something new every day..!
 

Glad to help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...