Jump to content

Poweramp Causes Android Auto to Cycle Bluetooth Connection


Go to solution Solved by andrewilley,

Recommended Posts

Just got a new Ford with Sync3.  All other devices (wife's phone, work phone) connect to wired Android Auto just fine,  personal phone with PA has an issue.  When connecting to android auto it causes Bluetooth to disconnect and reconnect every few seconds. Read on another forum that PA might be the issue.  Uninstalled PA, and sure enough android auto stopped cycling Bluetooth.  Really hope this can get resolved as PA is my preferred way play music on my phone.  Here is the last sent BT commands from PA

 

==================
16:19:53.292 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:19:53.295 PlayerService reloadPipeline
allowPlaying=true forceResume=false state after reload=2
==================
16:19:54.658 BTReceiver headset event
connection BT=true am mode=0 Ford Expedition
==================
16:19:57.630 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:19:57.630 PlayerService reloadPipeline
allowPlaying=false forceResume=false state after reload=2
==================
16:20:06.690 BTReceiver headset event
connection BT=true am mode=0 Ford Expedition
==================
16:20:07.269 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:20:07.271 PlayerService reloadPipeline
allowPlaying=true forceResume=false state after reload=2
==================
16:20:11.926 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:20:11.926 PlayerService reloadPipeline
allowPlaying=false forceResume=false state after reload=2
==================
16:20:21.567 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:20:21.567 PlayerService reloadPipeline
allowPlaying=true forceResume=false state after reload=2
==================
16:20:22.027 BTReceiver headset event
connection BT=true am mode=0 Ford Expedition
==================
16:20:25.833 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:20:25.833 PlayerService reloadPipeline
allowPlaying=false forceResume=false state after reload=2
==================
16:20:34.629 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:20:34.629 PlayerService reloadPipeline
allowPlaying=true forceResume=false state after reload=2
==================
16:20:35.458 BTReceiver headset event
connection BT=true am mode=0 Ford Expedition
==================
16:20:39.366 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:20:39.367 PlayerService reloadPipeline
allowPlaying=false forceResume=false state after reload=2
==================
16:20:48.682 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:20:48.682 PlayerService reloadPipeline
allowPlaying=true forceResume=false state after reload=2
==================
16:20:49.488 BTReceiver headset event
connection BT=true am mode=0 Ford Expedition
==================
16:20:52.631 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:20:52.631 PlayerService reloadPipeline
allowPlaying=false forceResume=false state after reload=2
==================
16:21:03.650 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
16:21:03.650 PlayerService reloadPipeline
allowPlaying=true forceResume=false state after reload=2
==================
16:21:05.699 BTReceiver headset event
connection BT=true am mode=0 Ford Expedition
==================
16:21:05.984 BTReceiver headset event
disconnection BT=true am mode=0 Ford Expedition no_keep_notif_on_dscn=false
==================
16:21:05.984 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
16:21:10.165 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
16:21:10.165 PlayerService reloadPipeline
allowPlaying=false forceResume=false state after reload=2

 
Link to comment
Share on other sites

Unfortunately, the issue is still occurring.  Switching outputs seemed to resolve it temporarily, but I still have a constant disconnect/reconnect of the Bluetooth connection the next time starting AA. Changing output had no effect.  I removed PA from my phone and the issue immediately went away.  I'm really disappointed I can't use PA with Android Auto as it's definitely my preferred music player

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...