Jump to content

Recommended Posts

Hello

I have poeramp latest version build 905 on android. When I choose the option of "shuffle all", I keep receiving error "SD card unmounted error" when player goes from one track to another, although when I choose the option "shuffle songs", everything works fine and tracks play properly as it shifts from one track to another. These same tracks showed the "unmounted" error with the shuffle all option.

Link to post
Share on other sites

'Shuffle Songs' only shuffles songs from the currently playing category (e.g. from one album or folder at a time) whereas 'Shuffle All' will pick from anywhere in your Music Library.

Sounds like at some point your SD Card mount may have changed, and while the music has been rescanned in under the new name, the old entries still exit - although they won't work as they point to now-non-existent duplicate file paths. Try PA Settings > Library > FULL Rescan. That should remove any obsolete entries and rebuild the whole library correctly. Has your device recently updated to Android 11 by the way? If so, please also check that PA Settings > Misc > File Access Legacy Mode is turned OFF. 

Andre

Link to post
Share on other sites

I have repeated a full scan, still though the same issue although it's the same tracks that appear with both shuffle options, but the "shuffle all" still shows the issue. I never removed the sd card since i installed the app. I attached a photo of the error.

20210514_204124.jpg

Link to post
Share on other sites
Posted (edited)

@Miro can you access the card easily? Is there any chance that removing it to clean the contacts may help? Maybe this is a long-shot, but worth checking. Is this an in-car unit? Perhaps some dust or moisture has built up causing this? And if so I also doubt the device has updated to Android 11, with the issue mentioned above by @andrewilley

Edited by MotleyG
Link to post
Share on other sites

Have a look in PA Settings > Library > Music Folders and make sure only the location of your audio files is ticked, and that there are no duplicates.

On one of the songs which shows as 'Failed to Play', long-press on the cover artwork and tap 'Info/Tags' to see where Poweramp is looking for the file. Is the tag info (Title, Artist, Album, etc) complete, which would mean the file's header data at least can be read. Can you play it manually (tap on it from the folders list for example)?

Is that a phone, or some other gadget like a car headunit (you just said "on android" in your first post). If the latter, they are notorious for losing track of storage access or settings when powered off and restarted via the car ignition, that might be connected with your issue.

Andre

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...