Jump to content

Poweramp not finding album art in folders


Recommended Posts

I have Poweramp build 905 (full version).  I use iSyncr to copy music (and album art) from iTunes on a PC to my Android phone. 

This used to work fine, but now no album art.  Music still works.  Album art not displayed and if I check via the menu it says "data not available". 

I confirmed the jpgs are in the song folders with the mp3 and m4a files.  File Browser associates album art with the music files. 

Visualizations turned off completely (easy to accidentally turn on; more difficult to turn off).  Album Art Cache cleared.  Negatives cleared.  Music library deleted and completely reloaded. 

Nothing I've tried helps. 

Link to post
Share on other sites

JPEG in-folder image files (folder.jpg, cover.jpg ideally, but it will look for others if they are not present) are only used when you are browsing in Folders or Folders Hierarchy modes, not in library album/artist/etc modes. For more details on how the selection process works, please see:

 

This recent thread might give a bit more background too:

Andre

Link to post
Share on other sites
Posted (edited)

Thanks for the info,

Not sure what changed to make this not work, but iTunes labels all album art files as "AlbumArt.jpg".  Same file name in every album/artist/song folder.  That seems to qualify for being album art for Poweramp.  Files sizes are over 4kb and less than 1mb. 

One observation: "full rescan" takes seconds and I have GB of music files so that makes me think its not actually scanning everything, even though it says "done". 

Which version am I using?  I don't see a version number in the About section of the settings.  Just Build #s for the app and unlocker. 

 

 

Edited by ddt000
clarity
Link to post
Share on other sites
56 minutes ago, ddt000 said:

Not sure what changed to make this not work, but iTunes labels all album art files as "AlbumArt.jpg".  Same file name in every album/artist/song folder.  That seems to qualify for being album art for Poweramp.  Files sizes are over 4kb and less than 1mb. 

One observation: "full rescan" takes seconds and I have GB of music files so that makes me think its not actually scanning everything, even though it says "done". 

For iTunes, you have to make sure the images are embedded, otherwise these images are stored elsewhere and only accessible by iTunes' database.

A full rescan of 1GB+ should take a bit longer than a few seconds. Make sure you have pointed the Library to the correct folder, then try another Full Rescan to load them back up.

BTW - No mention of your device or Android version above. But I have found in some cases a reboot is necessary after a large transfer of data if you are using an external uSD card. I think is is OS based, but not sure.

Link to post
Share on other sites

The initial part of a Full Rescan should take a second or two, which detects all the folders and filenames in the Music Folders location(s). You'll quickly see the total number at the top of the PA Settings > Library screen. The second phase is to access every one of those files individually and scan the embedded tag data into PA's music database, and that part can take much longer - mine takes just over a minute for nearly 7,000 audio files. It does not read images at that point though, that would use up far too much temporary storage. Cover images are loaded as needed when you view the various lists (or play a song), in the priority order given in the FAQ (with embedded images first).

If you are using Android 11, please disable PA Settings > Misc > File Access Legacy Mode, and make sure you are using a recent build of Poweramp (905 is the latest beta release).

Andre

Link to post
Share on other sites
Posted (edited)

Sorry, I didn't think to share my platform: Pixel 4 running Android 11.  Now that you mention it this was working on my Pixel 2, which is also running Android 11.  I switched phones recently.  I have deleted all the music/folders and reloaded but maybe its a PA database error that's not clearing? 

I use iSyncr to transfer my iTunes playlists (and associated music files/album art) from a PC to the phone.  Its been functional, and as I said the "AlbumArt.jpg" files are in the music folders on the phone. 

I tried a reboot and no change unfortunately.  But I did check info at the top of the library settings and found: Folders: 0, Playlists: 8, Songs: 0 (so something is up)  Rescan/Full Rescan don't change that, but selecting the "music folder" did.  I didn't think to do this because the music was already playable.  Now full rescan took a bit of time, and...

Album Art is back! 

So, possible bug for the programmer: I'm guessing that PA users should be told to reselect the Music Folder after transferring between phones (Pixels just connect to eachother and VIOLA! everything is on the new phone).  Somehow it "kinda knew" where the music was (via the playlists or the transferred database files). 

I feel special now.  Thanks for the help people! 

Edited by ddt000
clarity
Link to post
Share on other sites
34 minutes ago, ddt000 said:

 I switched phones recently ....Somehow it "kinda knew" where the music was (via the playlists or the transferred database files). 

You didn't mention that bit before. Probably Google restored PA's settings from your old device from the cloud, but the path description to your storage then no longer matched with what was there before. Re-selecting the correct new path allowed PA to see the files again, and rescan them all into the database. Just a guess anyway, but the "Folders: 0, Playlists: 8, Songs: 0" seems a pretty likely indicator of that.

Andre

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...