Jump to content

Having trouble using the Resampler


Recommended Posts

I've been using the resampler for a while now to upscale 44.1khz songs to 48khz. But, I discovered that of late the resampler function isn't working, even when I restored the default settings. Please anyone with knowledge of the matter help me out. :)

I've attached screenshots of my audio info.

photo_2021-03-20_16-04-48.jpg

photo_2021-03-20_16-04-47.jpg

Link to post
Share on other sites

Changing the resampler options on their own won't change the final output frequency, only how the audio is processed to get there. You need to change the frequency setting in the Output driver options screen. Mostly that's for Hi-Res Output, but on some devices the OpenSL ES driver also allows some frequency adjustment. e.g. for Hi-Res Output:

image.png

 

However if your device is capable of outputting 44.1kHz natively (not all devices are) and that's what your files are encoded as anyway, why upscale them at all?

Andre

Link to post
Share on other sites

The reason why I'm giving this complain is that, it worked before and suddenly I realized that the resampler is disabled and I can't do anything to make it work.

PS: Previously whenever I change the resampler, the music would pause for a second, but now nothing happens as if it doesn't work.

I know this is being nitpicky, but I'd be happy if you can give me any solution.

Link to post
Share on other sites

What output frequency have you defined in the Output menus? That should define the frequency if you want to override what the device and its Android firmware is defaulting to (which can change as ROMs receive updates).

But if your device is capable of outputting at 44.1, and your audio files are 44.1 too, why do you want to upscale to 48k anyway?

Andre

Link to post
Share on other sites

No, as I've stated twice already, the Resampler DID NOT ever choose its own new output sample rate (frequency) - any more than it could chose the input sample rate of the MP3 audio file that you are playing. Take a look in PA Settings > Audio > Resampler, it simply has no options to choose different frequencies, only to control the method it uses during whatever processing tasks it needs to achieve:

image.png

All that the Resampler does is to take whatever source data that you provide (in this case your 44.1kHz audio file) and convert the sampling rate to match your device's current output frequency. Android mostly uses 48kHz output by default, although some hardware/ROM/firmware setups may use 44.1kHz as that is the de facto standard for CD-derived recordings. But the rate used is entirely up to your device/ROM/firmware/settings from the manufacturer, and could potentially change when a new ROM update happens. On a few devices, the OpenSL ES implementation allows for some user adjustment of the output rate, but most don't.

You haven't said what device or Android version you are using, but for example on my Samsung A70 with Android 10, the regular output hardware is set to 48kHz / 16-bit. 

If you do particularly want to force output to 48kHz - you still haven't said why though - you can change your Output method to another type which does allow for more adjustment - such as Hi-Res Output or AAudio Output (the latter is new, and requires PA build 899 or later). Go to PA Settings > Audio > Output > Hi-Res Output and enable the switch for Wired Headset/AUX. You can then tap on it to adjust the output rate within the range that your device's chipset and firmware support:

image.png

Andre

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...