Jump to content

Recommended Posts

4 hours ago, andrewilley said:

@ReeceS269 Could this be a permissions issue of some kind? Sounds odd anyway. Try doing a Settings > Library > FULL Rescan and see if all of your songs are picked up correctly into the library database.

[Edit] Just a silly question, but you haven't accidentally activated the 'One Song' mode using the Repeat icon in the player screen have you?

Andre 

Sadly, its neither of those. The songs are recognised, they can be played but only after I force close the app. If I close the app the overlay still acts like the song is playing after its stopped.

Link to post
Share on other sites
  • Replies 223
  • Created
  • Last Reply

Top Posters In This Topic

6 minutes ago, andrewilley said:

What overlay?

Andre

When the app is open you can access it from the drag down menu of your phone.

 

EDIT: suddenly it's working again.

Edited by ReeceS269
Link to post
Share on other sites
9 minutes ago, ReeceS269 said:

When the app is open you can access it from the drag down menu of your phone.

Ah, the Notification panel you mean, dragged down from the status bar at the top.

Andre

Link to post
Share on other sites
8 hours ago, ReeceS269 said:

My app now freezes after playing 1 song and will not proceed to play the next. I have to force close the app to get it to working again. 

I have the same issue. For me is seems to be because Poweramp is scanning my library when you start it up. If you just wait it should start playing again when the library scan is complete. Depending on how big your library is the scan could take a while.

Forcing the close solves the problem momentarily but unfortunately when you open the app again, it restarts the library scan again which causes the problem again.

Link to post
Share on other sites
14 hours ago, andrewilley said:

Just uninstall 899 completely, and re-install Poweramp from the Play Store. Please remember to export any internal playlists before you do, as anything saved in PA's internal database will be cleared when you uninstall. You will also lose any ratings and play counts (all of these can also be backed up using third party app New Playlist Manager).

Before you re-install 893 though, I would suggest giving 899 another try as a completely clean install first (and clear app data just to be sure). If that doesn't work, you can always uninstall again and install 893.

What version of Android are you using, is it a recent Android 11 update? 

Andre

Andre,  Sorry if this is the wrong way to reply, but I could not find a reply button to hit on your response.  I tried multiple times to do a clean install from the app store, the same issues persisted.   On both my phone and tablet I now have no auto updates set.  Then I download the 893 APK from this site, to my PC, and copied that to the download folder on both my phone and tablet.  After that I used a file browser on both devices to do an install of the APK onto the device.  In both cases that worked, and now I seem to be good again at version 893.

I'm sorry I don't have a lot of time to troubleshoot the problem, but too many things were wrong with 899 for me to live with.  I hope MP can fix the problems and put out another fantastic version of the app.  In the meantime, I have 893.  Thanks very much for your response.

Best Wishes, Sincerely,  Paul R.

Link to post
Share on other sites
13 minutes ago, prubinstein said:

Andre,  Sorry if this is the wrong way to reply, but I could not find a reply button to hit on your response.

You can just use the 'Quote' link under any post if you want to quote in a reply. I've adjusted your post for clarity.

If you re-install PA from the Play Store you should get build 893 (unless you are set up as a beta tester on the Play Store anyway, which you should disable if you want to stay on 893 for the time being).

So to clarify, even a completely clean install of build 899 from the APK is still giving you the locking-up issues on both of your Samsung devices (as per your post https://forum.powerampapp.com/topic/20879-poweramp-builds-895-899/?do=findComment&comment=95673 ) but build 893 APK is now working fine for you.

Andre

Link to post
Share on other sites
19 hours ago, richg0404 said:

I have the same issue. For me is seems to be because Poweramp is scanning my library when you start it up. If you just wait it should start playing again when the library scan is complete. Depending on how big your library is the scan could take a while.

Forcing the close solves the problem momentarily but unfortunately when you open the app again, it restarts the library scan again which causes the problem again.

I think you're right, I just turned off auto scan and its working again.

Link to post
Share on other sites
  • maxmp changed the title to Poweramp builds 895-900

Build 900:

  • new Unsplit Artists option
  • new option switchers in Settings
  • AAudio output works starting from Android 9
  • Recently Played time now updated only if track Counted as Played
  • bug fixes and stability improvements
  • translations updates
Link to post
Share on other sites
28 minutes ago, maxmp said:

Build 900:

  • new Unsplit Artists option
  • new option switchers in Settings
  • AAudio output works starting from Android 10
  • Recently Played time now updated only if track Counted as Played
  • bug fixes and stability improvements
  • translations updates

It works on android 9 now, according to the Changelog in app. You might want to update the changelog on this thread.

And BTW, is there a way to get play distribution versions? Uni is big. I prefer the play variant but Google Play probably hasn't accepted the update yet. So I didn't see an update there.

Link to post
Share on other sites

@maxmpA big thank you for the quick fix. The duplicate tracks in "Album Artists" category issue is fixed (based on a 10s test) and now I can use PA in my preferred way.

@Someguyonlinethe new version is probably in Google Play but it can take some time before it rolls out to all users. I had to wait close to a week for one version in Google Play before it updated for me. So now if I'm in a rush, then I will just side load the web version.

Link to post
Share on other sites

Ah, this version is bit buggy. On AAudio output, if just play a song, then seek, play/pause, audio randomly stops, but on Poweramp the track isn't paused. It looks like it's still being played, but I can't hear it. It doesn't happen on Hi-res output. I checked. I sent a full system bug report to Poweramp.maxmpz at gmail.com.

Edited by Someguyonline
Link to post
Share on other sites
2 hours ago, Someguyonline said:

Ah, this version is bit buggy. On AAudio output, if just play a song, then seek, play/pause, audio randomly stops, but on Poweramp the track isn't paused. It looks like it's still being played, but I can't hear it. It doesn't happen on Hi-res output. I checked. I sent a full system bug report to Poweramp.maxmpz at gmail.com.

Tested it. Working fine here 

Link to post
Share on other sites
4 hours ago, maxmp said:

Build 900:

  • new Unsplit Artists option
  • new option switchers in Settings
  • AAudio output works starting from Android 9
  • Recently Played time now updated only if track Counted as Played
  • bug fixes and stability improvements
  • translations updates

Thank you @maxmp🍻 This new working update re Symbols to Split Multiple Artists is interesting. I no longer have to go to a specific album artist if I have the tag set to include say 2 of them. The track/song will be available in their lists. Example, I just go to AArtist1, or AArtist2, then the track they share will be on both of them.

20 minutes ago, Scorpion said:

What does this option do? 

IMG_20210317_132829.jpg

I got the idea by testing tracks with multiple artists in Album Artist category (AArtist) (my go-to). With this feature disabled, if you have AArtist1 and AArtist2 on a track, this track will appear on both Album Artists's List.

On the other hand, having this feature enabled, it will create a separate track with the combined AArtists. 

I would also like to know what this feature really do.

Edited by invaderzim
Link to post
Share on other sites

@Scorpion when this option is enabled, the original unsplit artist (alb artist, composer) is visible in the appropriate category. This is disabled by default, and for Artist1/Artist2 you will see those 2 separate Artist1 and Artis2 artists. If enabled, you also get Artist1/Artist2 artist as well.

Link to post
Share on other sites

Thanks for the update. 

Upon testing the Count as played feature, when I play a song to the end and carry on and play onto the next song, the played times and last played sections under tags do not update.

When I skip a song that I have played past the threshold, those tags update.

Samsung Galaxy S10+ android 11, build 900

Link to post
Share on other sites
  • andrewilley changed the title to Poweramp builds 899-900
3 hours ago, maestro30k said:

Thanks for the update. 

Upon testing the Count as played feature, when I play a song to the end and carry on and play onto the next song, the played times and last played sections under tags do not update.

When I skip a song that I have played past the threshold, those tags update.

Samsung Galaxy S10+ android 11, build 900

The same here
Link to post
Share on other sites
4 hours ago, maestro30k said:

Upon testing the Count as played feature, when I play a song to the end and carry on and play onto the next song, the played times and last played sections under tags do not update.

When I skip a song that I have played past the threshold, those tags update.

I can confirm that. Listening to a song fully to the end, and allowing PA to auto-advance to the next track, the Play Count does NOT get incremented. However, manually skipping to the next track in the folder (after having played beyond the threshold position) does correctly update the Play Count.

Also, there seems to be some discrepancy between the number displayed in the 'Most Played' category screen and the content in the Info/Tags display. The following screenshot was taken after clearing the play count data (so the 'Most Played' Category was completely empty) and then listening to a song. Both numbers ought to have been '1', but the previous value seems to have been retained, but it has been incremented differently:

image.png

Andre

Link to post
Share on other sites
10 hours ago, maxmp said:

Build 900:

  • new Unsplit Artists option
  • new option switchers in Settings

Both are excellent Max, thank you! The use of the same 'lozenge shaped' selector options elsewhere in the Settings interface, instead of loading a sub-menu of radio-buttons, is very elegant too.
 

One trivial suggestion, but could you allow the symbols list to overflow onto subsequent lines if needed?

image.png

The "..." displayed in the same style of bubble as the other symbols above looks like it is the last of five separator options, whereas there are three more when you tap to edit:

image.png

Andre

Link to post
Share on other sites

I am still seeing the bug I mentioned before. MKV files (with video stream) are still being interpreted in Poweramp as mka and they are being shown even though Ignore video tracks is enabled.

IMG_20210317_221336.jpg

Edited by Someguyonline
Link to post
Share on other sites
  • maxmp changed the title to Poweramp builds 899-905
  • maxmp changed the title to Poweramp builds 899-903

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...