Jump to content

Chromecast with Google TV - stuttering/silence


exor
 Share

Recommended Posts

Hello,

I saw there were other threads about this but I didn't want to necro something a few months old. I've pieced together all the advice from various threads and tried everything, but I'm still having some of the problems others have described. I figured a new thread with everything laid out (+ an error log to accompany this thread via email) would help with troubleshooting

 

Poweramp build number: build-893-arm64-play [893004-dd1054bc]

Device model: Samsung Galaxy S10e

Android version: 11

ROM name/version: N/A (stock/not rooted)

 

Steps to reproduce/bug description:

1. start casting to Chromecast w/ Google TV

2. hit play

3. the first couple seconds of audio are heard, followed by 14~16 seconds of silence, and then the audio picks back up and the rest of the song plays through

 

Mitigating things I've tried in various combinations:

- Forced output to 44.1 kHz / 16 bit

- Set buffer to max value (4000 ms)

- Tried stopping (i.e. long-press on the pause button) and starting the music

- Tried different bitrates of MP3s (192 kbps, 320 kbps, VBR)

- EDIT: Also turned off background power saving for both the app and the unlocker.

 

Other notes:

- My WiFi signal is quite strong. The router is within 5ft line of sight to both my phone and the Chromecast. (I know other apps stream from the cloud, but I had Steam Link games working earlier and it tested my Chromecast's connection at >100Mb/s.)

- I can stream music from my desktop to the Chromecast just fine (MP3s, not radio apps)

- I've never had trouble casting to older Chromecasts with this same phone/app. My friend's older-model CC on a lower quality WiFi network works just fine and I've never had to mess with Poweramp's settings to get it working.

- I've attached my full audio info chain as an image

- I'm emailing a support log and referencing this thread

 

I hope this is everything you need to be able to troubleshoot this. It looks like I'm not the only one with this model of Chromecast that's having this problem!

poweramp1.jpg

Link to comment
Share on other sites

Just a quick update: I gave this another shot and noticed that when the music cuts out for 15ish seconds, it resumes playing at the same point where it cut out. The player keeps going, i.e. playtime keeps going up and track progress proceeds, but it's like the Chromecast's cast is pausing at some point, then resuming. Almost like it's buffering repeatedly?

Link to comment
Share on other sites

@maxmp i might take my Chromecast with Google TV back because of this bug, still got a couple weeks to make a final decision. Is there anything else I can provide or do to help with tracking down the culprit here before I return it?

Link to comment
Share on other sites

  • 1 month later...

Unfortunately no, I ended up taking the CCWGTV back and buying a Shield instead, and the chromecast in there works just fine with Poweramp. Hopefully this post helps figure out the issue for someone else though!

Link to comment
Share on other sites

@andrewilley no, but I will try to get one. If it's not a battery optimization issue (when casting is OK while phone screen is ON and stutters when screen is off/app is on background), then CCwGTV probably requires some tweaks.

(Currently Chromecast testing setup is Google Home, Home Max, Chromecast 3 and Ultra + couple of Android tvs with the embedded chromecast app).

Link to comment
Share on other sites

Ok, I pushed the Chromecast update with some support for CCwGTV. This should work with the default (1800ms) buffer settings in Poweramp for Chromecast output.
No Poweramp update is needed.

This device has much more memory/resources vs traditional chromecasts, so Google increased various buffer times, at the same time increased the minimum buffer Chromecast player wants to maintain to play something - it's 5sec vs 1.8sec for other Chromecasts. This somewhat increased latency and the presentation time on Poweramp now differs for those 5 seconds - this will be improved later as it requires changes to Poweramp.

 

Link to comment
Share on other sites

  • 2 weeks later...
On 3/25/2021 at 9:00 PM, maxmp said:

@andrewilley no, but I will try to get one. If it's not a battery optimization issue (when casting is OK while phone screen is ON and stutters when screen is off/app is on background), then CCwGTV probably requires some tweaks.

(Currently Chromecast testing setup is Google Home, Home Max, Chromecast 3 and Ultra + couple of Android tvs with the embedded chromecast app).

Bad news. At the second track, and then at the start of every track, after a few seconds there's 2 seconds of silence. Buffer is 1800ms

Link to comment
Share on other sites

@Squeller thanks for the report. I tested and haven't noticed any additional pauses - but I will test it more. Extra silence can be optionally introduced by "Silence Between Tracks" option, also, due to large buffers, change of track is somewhat not-in-sync with the actual audio (within few seconds).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...