Jump to content

Poweramp Was Killed - Poweramp is not being optimized.


Recommended Posts

Does not happen all the time, so not a show stopper by any means.

87sB5Yb.png

I do not have it optimized in the battery optimization area, and I am not running any special apps that do that.

image.png.d1031ed6b3e7e65b67ec704debbe89dd.png

Not sure what else to look for, or what to do.  Didn't find any further suggestions from the FAQ or Google search.

 

Thanks for your time and assistance.

Link to post
Share on other sites

Does this happen when you turn the screen off? I very occasionally (maybe once in one or two months) get this message when I turn the screen off at night. When I turn the screen back on, PA is still there but with the Killed message in front of it. I just need to tap Play (or press the equivalent headset button) to resume listening where it stopped. 

Andre

Link to post
Share on other sites
On 1/23/2021 at 5:12 AM, Someguyonline said:

Are you running it on an emulator? (Just out of curiosity,I'm not a support staff)

No, running on Samsung S10e.

On 1/23/2021 at 6:30 AM, andrewilley said:

Does this happen when you turn the screen off? I very occasionally (maybe once in one or two months) get this message when I turn the screen off at night. When I turn the screen back on, PA is still there but with the Killed message in front of it. I just need to tap Play (or press the equivalent headset button) to resume listening where it stopped. 

Andre

It happens when I am going to sleep usually, so the screen is off... and maybe I manually turned the screen off.  Not sure.  Doesn't happen all the time, but enough to make me double check myself that I had it removed from battery management.

 

Thanks.

Link to post
Share on other sites
1 hour ago, LewZephyr said:

It happens when I am going to sleep usually, so the screen is off... and maybe I manually turned the screen off.

Sounds pretty much the same as for me.

My evening routine is to put my headphones on and start playback, turn the Sleep timer on, and then press the power button to turn the screen off. Very occasionally playback immediately stops as soon as the screen turns off. I can restart playback by tapping on the cabled headset button - but if I turn the screen back on first to check, I see the 'PA was Killed' message superimposed over the player interface. Next time it happens (it's pretty rare) I'll see if I can save a log.

Andre

Link to post
Share on other sites
  • 4 weeks later...
On 1/26/2021 at 12:27 AM, andrewilley said:

Next time it happens (it's pretty rare) I'll see if I can save a log.

It happened again last night: I plugged my headphones in and started my usual night-time shuffled playback, set the Sleep Timer to 30 minutes, and tapped the Power button to turn the screen off. At that point, the music immediately stopped. When I turned the screen back on, it was showing the "Poweramp detected it was was killed during active playback" popup. PA was still running behind this though, and playback could be restarted by tapping on the headset button.

Nothing helpful in Last Processed Commands, just the messages from when I plugged the headset in:

image.png

I grabbed a diagnostics log and will email it to @maxmp.

Andre

Link to post
Share on other sites

@andrewilley received the log, thanks, but in the case of process killing, Poweramp won't collect the log from the previous run. It's only possible to do that via Developer settings / Bug report / Full, ASAP after the issue as that log contains only last couple of minutes or less.

Btw, the wakelock option won't work on recent Androids and not recommended esp. on Samsung Android 11 which is very restrictive about wakelocks.

Link to post
Share on other sites

I wasn't sure if the log contained anything useful, but the timestamps did show from around when I plugged in the headphone cable, right though until after the audio was killed, so I hoped there might have been something useful. Next time I'll try to remember to get a full dev bug report (if I'm awake enough to remember :) ). 

Andre 

Link to post
Share on other sites

@maxmp It just happened during the daytime for once. Exact same scenario as happens at night: inserted headset plug, started PA playing normally, tapped the power button to turn the screen off and the audio immediately stopped. When I woke the screen again, there was a message saying PA had been killed (as per the first post of this thread).

I requested a bug report and will Dropbox it to you as it's probably too big for email. Hope it helps.

Andre

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...