Jump to content

Latest Android Update (11) broke Poweramp


SnipeStar
 Share

Recommended Posts

I updated my S20 Ultra to Android 11 last night and now Poweramp is saying my SD Card is unmounted.  It's not, of course, as the rest of my phone (and other music players) are able to access the contents of the card just fine.

I tried doing a full rescan which didn't work. I also tried re-adding the music folder in the settings -> music folders, and i noticed that the SD card isn't even listed there anymore. When i click on the + button and manually try to add the folder which contains my music, it lets me navigate the folders of the SD Card but won't let me add any of them to the selected music folders.

Not sure what else to do at this point.

Link to comment
Share on other sites

Well granting access wasn't working because it would still give me the error about the storage being unmounted.

so i went and checked that file access legacy mode setting, and it was already enabled- so i disabled it. the SD Card is now showing up in the Music Folders area, and when i chose the folder that has my music, it automatically did a full rescan, and is now working again.

thanks brother!

Link to comment
Share on other sites

50 minutes ago, SnipeStar said:

Well granting access wasn't working because it would still give me the error about the storage being unmounted.

so i went and checked that file access legacy mode setting, and it was already enabled- so i disabled it. the SD Card is now showing up in the Music Folders area, and when i chose the folder that has my music, it automatically did a full rescan, and is now working again.

thanks brother!

If I recall correctly, @maxmp had said earlier that this option has to be DISABLED for Android 10+.

Link to comment
Share on other sites

Google constantly changes what will work and what won't in the future version of Androids. The typical pattern is: in Android X function Y won't work -> it doesn't work in Android X beta -> in Android X release it's allowed as exception. For file access, this happened for 10, 11, and now is happening for R.

Link to comment
Share on other sites

  • 2 months later...

Exact same issue here, when my Samsung S10 migrated to Android 11 this morning.

I certainly don't remember enabling legacy mode earlier.  If legacy mode was the PA default, I suspect a lot of people are going to run into this issue (assuming they keep their music on SD card).

Thanks.

Link to comment
Share on other sites

@Niggle It appears to be a Samsung Android 11 bug - the OS reports that File Access Legacy Mode is still working, but it doesn't seem to be. Please try turning it off via PA Settings > Misc > File Access Legacy Mode, and then go into PA Settings > Library > Music Folders and check that your music folder is ticked.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...