Jump to content

$YAPS$ is now called YAPS


Recommended Posts

  • Replies 215
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

@maxmpfound a small error in the attrs-styles-powerui.xml

<!-- Parametric -->
        <attr name="EqParamColorCircleSelector" format="reference"/>
        <attr name="EqParamGainLinearKnob" format="reference"/>
        <attr name="EqParamGainLinearKnob" format="reference"/>
        <attr name="EqParamPlaceholder1" format="reference"/>
        <attr name="EqParamPlaceholder2" format="reference"/>


and in styles-powerui-styles.xml

<!-- Parametric -->
        <item name="EqParamColorCircleSelector">@style/EqParamColorCircleSelector</item>
        <item name="EqParamGainLinearKnob">@style/EqParamGainLinearKnob</item>
        <item name="EqParamGainLinearKnob">@style/EqParamGainLinearKnob</item>
 

 

there are 2 EqParamGainLinearKnob references

Link to comment
Share on other sites

  • 3 weeks later...
17 minutes ago, flyingdutchman said:

@doctorman you can hide any or all of those buttons. As for the tempo knob, i do not think it is possible. Knobs etc are part of a given layout which a skin cannot change. 

thanks, well Tempo did not need to be a knob, anyway to enter the higher speed would be fine, 

I guess I have to request it as a feature... 

Link to comment
Share on other sites

  • 2 weeks later...

Hi

Love the new version

Is there any way to make the background of the Poweramp default play button blacker?  Im a minimalist and it now doesnt match the black background.  I dont know how to do it either.  Or maybe you can make a button with just the arrow like it but transparent background?

Thanks

Amber

 

20211026_102110.jpg

Edited by amber438
Link to comment
Share on other sites

@amber438 switch off gradient background (reset default), select black as background colour (app background colours), hide next prev and category play buttons should do it. Maybe also circle colour to black

Ps, i notice that setting the icon colour of the play buttons is misbehaving. I will check that out

image.png.f2aeb09ec20ae7c36617067cb4b969b5.png

Link to comment
Share on other sites

30 minutes ago, flyingdutchman said:

@amber438 switch off gradient background (reset default), select black as background colour (app background colours), hide next prev and category play buttons should do it. Maybe also circle colour to black

Ps, i notice that setting the icon colour of the play buttons is misbehaving. I will check that out

Thanks!  I was going to say that has all been done but the play button colors are not behaving :)

Link to comment
Share on other sites

5 hours ago, flyingdutchman said:

Ps, i notice that setting the icon colour of the play buttons is misbehaving

Has been for a while for me too. The transparency level of the centre play/pause button when using opaque colour settings still doesn't quite match with the other four pro buttons.

In this example, the Music Button background colour is set to Black Opaque, but the middle button looks slightly more transparent than the others:

image.png

Andre

Link to comment
Share on other sites

@andrewilley it seems to be impossible to correct this. I suspect Poweramp itself applies something over the buttons. Each of those buttons has exactly the same definitions applied (apart from the bitmap itself). All styling has been pared down to dimensions, left/right margin and scale and drawable (bitmap). All other aspects are handled by Poweramp itself. 

Link to comment
Share on other sites

8 minutes ago, flyingdutchman said:

@andrewilley it seems to be impossible to correct this. I suspect Poweramp itself applies something over the buttons

How strange, it only affects opaque middle buttons, and it's fine if the colour is solid. I'm sure this has only started happening relatively recently, but maybe I only started using opaque buttons recently?

Andre

Link to comment
Share on other sites

16 minutes ago, flyingdutchman said:

@andrewilley agreed, I tried everything I could think of. I think that because it is opaque some other (unknown) layer, (when switching play/pause)  affects the button

Currently it's the same transparency whether in play or pause state. At some point in the past, I seem to recall it changed between play/pause conditions. It's really trivial, just a bit irritating to look at.

Andre

Link to comment
Share on other sites

3 hours ago, flyingdutchman said:

sometimes you just do not see it whilst it is in front of ones eyes.

That's usually where stuff hides, it's never in those really obscure bits of code that you just spent ages digging through.


Now, while we're on a roll :) could you maybe add some smaller values for the 'Resize Metainfo field' width control? Even at 250dp (below) the maximum width of the meta content is still quite a bit wider than I'd prefer, especially when counter values are in hours rather than minutes:

image.png

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...